Lost internet

I was connected to the internet. And then i lost my connection.

Problem found is “The Intel(R) Wi-fi 6E AX210 160MHz is experiencing driver - or hardware-related problems” Not Fixed

Any ideas of what to do?


Thank you Rupert.

I will have a go at using that in the morning. It’s late at night here.


Hi Rupert.

I downloaded the file, put it on a usb stick. Then tried to run it on the framework, and was told it couldn’t run because an internet connection is needed.


Hi I am having a similar problem. The WiFi adapter was working for the first two days, but is now not working at all. I was able to try Rupert_Woods suggestion by connecting my Framework DIY to the internet with a LAN-USB C adapter. But I still have the problem.

1 Like

The Wi-Fi 6E AX210 160MHz is the only thing in the Device Manager with a “!”. The Adapter was pre-installed on my machine… and was working for a while.

1 Like

I made another attempt to follow those instructions with my Framework Laptop connected to the internet via LAN and this time it was successful. The WiFi adapter is now working again.


If you don’t want to run Intel DSA, try downloading the WiFi and Bluetooth drivers from Intel’s website and manually installing them from Intel Download Center.

1 Like

Got a message from Framework. As I asked for help the other day.

They said to download bias and run it.

As I’m in bed with an illness, will do that when i can get up.

Hi, on my system i couldn’t use 5GHz and the connection was broken intemediatly. I have read some information about the wifi modul in the first DIY configurations. So i imagined, that i could have a problem with this modul.
What i have seen: the connectors on the modul were very close connected. So i turned one of the connectors a little bit to get more distance between the connectors. Also is put a small tape on the iron cover to prevent electrical contact.
Now the system is using stable 5GHz wifi since 5 hours.

Thank you for all of your replies and suggestions. I have just returned from a few days away, and I discovered that the problem was that the black lead had been disconnected from the wifi card. It is now connected and working correctly.


Rupert’s suggestion fixed this for me!

I had internet, downloaded the framework drivers and installed them, then lost internet.

Installing only the Intel WiFi drivers here worked Windows® 10 and Windows 11* Wi-Fi Drivers for Intel® Wireless Adapters

1 Like