Memory Support specs?

@uhhmeeyell For me, that kit does NOT run at full speed. 2667MT/s

1 Like

Just in case someone is looking for additional memory options, I used two ATECH/ADATA 8GB DDR4-3200 modules in ours and they’ve worked fine so far at 3200. I didn’t do a deep dive on the modules so I don’t know who made the actual DRAM ICs.

They are double-sided and fit snugly but without issue. Make sure to route your WiFi antennnae in the provided guides if you use both :wink:

1 Like

Unfortunately I’m not optimistic that’ll work as you hope. If you look at G.SKILL’s spec page for that exact SKU:
it specifically states:

Additional Notes: This product requires enabling XMP in BIOS to operate at the rated speed. Otherwise, the memory kit will operate at the default speed set by the system.

In contrast, for the F4-3200C22D-64GRS kit that I just ordered:
it instead just states:

Additional Notes: Rated SPD frequency requires compatible CPU and chipset support

There’s a pattern for all of G.SKILL’s DDR4-3200 memory that if it’s rated for any latency CL18 or lower, it will be marked as requiring XMP to run at the rated speed. All of their CL22 ones seem fine. It seems that G.SKILL is a manufacturer that’s pretty up-front about the XMP requirement as long as you’re looking at the official spec page.

1 Like

Does this come down to the memory controller on the intel mobile processors? I figured dual rank memory would have worked.

Got my DIY laptop yesterday and this kit runs at full 3200 native speed.

1 Like

My Framework laptop arrived the other day, and I can confirm this G.Skill 64GB memory kit runs nicely at full DDR4-3200 speed as I expected it to (given it’s lack of XMP requirement for such). Memtest86 also came out clean, so all is good :slight_smile:


@computerhac no idea

Confirming the G.Skill 64GB (F4-3200C22D-64GRS) kit works properly on my end as well!

Brought my 3DMark Fire Strike score up ~2-300 points as expected probably due to 2133MHz of my old kit → 3200MHz.

I also did some battery tests in comparison with my old kit, see here.


@AlexS, Can finally confirm. The (2 x 8GB) G.SKILL Ripjaws (Model F4-3200C16D-16GRS) that I had do run at 3200MHZ… Unfortunately, because of the lack of XMP on the framework laptop the CL is 22 instead of 16. :stuck_out_tongue:

1 Like

That’s the CAS latency the DDR4-3200 modules Framework sources, CL22.

“Seems” bad but it seems like that’s what native DDR4-3200 runs at. The number keeps popping up which leads me to believe they’re all using the same ICs.

My desktop system uses XMP and can clock at either DDR4-3600 CL16 or DDR4-3200 CL14, but its native speed seems to be DDR4-2666. :confused: But that’s another set of numbers that keeps popping up, denoting similar ICs: DDR4-2666 native, DDR4-3200 CL16 by XMP or DDR4-2666 native, DDR4-3600 CL16/DDR4-3200 CL14 by XMP for the higher-end memory ICs.


i’m not an expert but i think i read that each individual motherboard / cpu has a limit for the total number of ranks allowed, and also number of dram chips per memory module.

it would be nice to know exactly which are supported by framework. does it support quad rank, dual rank, 2rx8, x4, x16, etc…?

1 Like

Can confirm that Crucial 2x8GB ‎CT2K8G4SFRA32A runs at full 3200Mhz speed.

Just adding my experience here. I’m reusing RAM from my old laptop (OEM Samsung M471A1K43CB1-CTD, 8GB 2666MHz, plus a matching stick from eBay, so 16GB total) and though it’s rated to 2666MHz CL19 it’s running at 2133MHz CL15. Edit: nevermind I think all is well here, probably has to do with running in Gear 2 mode so I’m misreading something.

Additionally, I tested the 16GB kit of Kingston HyperX Impact 2933MHz CL17 (HX429S17IBK2/16). Similar to the 32GB kit mentioned earlier this one also refused to boot with any combination of sticks installed. As stated several times probably best to stick with sticks that run natively at 3200 CL22.


I just ordered the Framework DIY Laptop and was going to use “PNY XLR8 Gaming 32GB (2x16GB) DDR4 3200MHz (PC4-25600) CL20 1.2V Dual Rank Notebook/Laptop (SODIMM) Computer Memory Kit – MN32GK2D43200X”.
Its on Amazon for $114.99 right now.
It says it has “XMP 2.0 support” but the JEDEC listed on their website is 3200MHz (PC4-25600).
So I does that mean the XMP is just to overclock the RAM above 3200Mhz?
Any thoughts if this is OK to use for the Framework Laptop?

It might run at 3200MT/s it may not, I can’t really tell

If it has support for JEDEC 3200MT/s then it’ll be fine

Otherwise it’ll default to whatever JEDEC speed it’s set to

XMP can refer to higher speeds or tighter timings, neither of which is supported by Framework

Since CAS latency is set to 20, that’s XMP since JEDEC spec is a CAS latency of 22

Not necessarily. RAM modules have a default profile and optionally XMP profiles. Nothing really says that the default profile has to match JEDEC specs. For example, take the specifications for KF432S20IB1K2 modules where the default specs are CAS 20. Motherboards that don’t support XMP should use the default profile.

The best way to find out is to find the datasheet for the modules, hope it lists the default profiles, and hope it’s correct. FWIW, I have that Kingston RAM in my Framework.

1 Like

And what timings does it run at?

I mean, like I said, you basically have to take the datasheet on good faith because the Framework BIOS doesn’t show it and dmidecode doesn’t include it. Sure I could benchmark but I have no comparison. Anyway, according to Wikipedia 20-20-20 is a JEDEC timing for 3200 MHz, but 22-22-22 is probably the most common.


You can use software like CPU-Z or HWINFO to detect the subtimings.


I use Linux :slight_smile:. Anyway, apparently decode-dimms is the thing to use, here’s the relevant portions of its output:

---=== Memory Characteristics ===---
Maximum module speed                             3200 MT/s (PC4-25600)
Size                                             16384 MB
Banks x Rows x Columns x Bits                    16 x 16 x 10 x 64
SDRAM Device Width                               8 bits
Ranks                                            2
Rank Mix                                         Symmetrical
Primary Bus Width                                64 bits
AA-RCD-RP-RAS (cycles)                           20-22-22-42
Supported CAS Latencies                          22T, 21T, 20T, 19T, 18T, 17T, 16T, 15T, 14T, 13T, 12T, 11T, 10T, 9T

---=== Timings at Standard Speeds ===---
AA-RCD-RP-RAS (cycles) as DDR4-3200              20-22-22-42
AA-RCD-RP-RAS (cycles) as DDR4-2933              19-21-21-39
AA-RCD-RP-RAS (cycles) as DDR4-2666              17-19-19-35
AA-RCD-RP-RAS (cycles) as DDR4-2400              15-17-17-32
AA-RCD-RP-RAS (cycles) as DDR4-2133              14-15-15-28
AA-RCD-RP-RAS (cycles) as DDR4-1866              12-13-13-25
AA-RCD-RP-RAS (cycles) as DDR4-1600              10-11-11-21

---=== Timing Parameters ===---
Minimum Cycle Time (tCKmin)                      0.625 ns
Maximum Cycle Time (tCKmax)                      1.600 ns
Minimum CAS Latency Time (tAA)                   12.500 ns
Minimum RAS to CAS Delay (tRCD)                  13.750 ns
Minimum Row Precharge Delay (tRP)                13.750 ns
Minimum Active to Precharge Delay (tRAS)         26.250 ns
Minimum Active to Auto-Refresh Delay (tRC)       45.750 ns
Minimum Recovery Delay (tRFC1)                   350.000 ns
Minimum Recovery Delay (tRFC2)                   260.000 ns
Minimum Recovery Delay (tRFC4)                   160.000 ns
Minimum Four Activate Window Delay (tFAW)        21.000 ns
Minimum Row Active to Row Active Delay (tRRD_S)  4.375 ns
Minimum Row Active to Row Active Delay (tRRD_L)  5.625 ns
Minimum CAS to CAS Delay (tCCD_L)                5.000 ns
Minimum Write Recovery Time (tWR)                15.000 ns
Minimum Write to Read Time (tWTR_S)              2.500 ns
Minimum Write to Read Time (tWTR_L)              7.500 ns

As we can see, reported timing for 3200 MHz is CAS 20. For some reason, decode-dimms only finds one DIMM even though I have two installed and active :man_shrugging:.