Not booting after selecting Disconnect Battery and adding an EFI file to secure boot

TL;DR: After messing up with the BIOS, the Framework did not boot anymore, and the leds on the sides blinked red and green. I fixed it by disconnecting main battery and RTC battery for 10 minutes.


I prepared with my old laptop a live USB stick with Linux, and was able to boot it on the old laptop. When I plugged the USB stick into my new Framework, and pressed F12 during boot, I could only see the NVME disk option, no USB. I tried several times, swapping the USB key to different ports, unsuccessfully.

I entered the BIOS and selected “Disconnect Battery” (first stupid error), because I thought it would allow me to keep using the laptop only when connected to the power supply. I did not know the purpose was only to temporarily disconnect battery in order to open the case. :man_facepalming:

I had the power supply connected, and I kept it connected.

Without quitting the bios, I investigated why my USB stick did not show up in the boot options. “Boot from USB” was enabled, “Secure Boot Status” was disabled, and then I saw that there was an option to “Select a UEFI file as trusted for execution”. I roughly knew that UEFI works by only allowing signed bootloaders to run, so I thought (second stupid error) that I needed to add the EFI file from the USB stick in order to allow it to boot.

I selected that option, and then selected the USB device, which I chose because was labelled as GPT (where the other one was labelled NVME, so I exluded it). By doing so, some of the content of the EFI partition of the USB stick was shown, and I selected the grubx64.efi file from /EFI/qubes. There were other two files in that directory, xen-4.14.3.efi and xen.efi, but I discarded them because I though the right one was grub.

I saved the BIOS settings and rebooted, and then the nightmare begun.

The Framework did not boot anymore. After pressing the power button, the light went on for a dozens of seconds, and then it simply powered off again, without anything shown on the screen.

After some minutes of fear and self-blaming, I discovered that the battery disconnection option is reset by unplugging and replugging the power adapter, and tried several times, but unsuccessfully. Same behaviour as before.

At that point I noticed that the leds on the side were bliking green and red. I landed on this page, where the meaning of each led blink is explained.

In my case, the sequence was

W[GGGRGGGGRRGG]O[GGGGGG]
     ^    ^^     ^^^^^^
     |    ||     ||||||
     |    ||     unsure about these
     |    ||
these seemed wrong to me

I tried googling some more, but it seemed that nobody had the exact same sequence before. I read someone fixed a similar problem with blinks nr. 4 and 9 by disconnecting the main battery and the RTC battery, so I tried that.

When I reconnected the battery, I saw the leds blinking red all the time until I closed the laptop.

It booted. :see_no_evil: :hear_no_evil: :speak_no_evil:

Now I see from the BIOS that there is a new signature in the Secure Boot’s “DB Options”, but I’m still unable to boot the USB stick. I wrote this post just to document my last hour spent, in the hope to help someone else that could encounter the same problem.

If you happen to read past this point, and can tell me what to do in order to boot the USB stick, thank you!

3 Likes

It’s odd that Secure Boot is disabled but it still won’t boot from your USB (FWIW, I forgot that Secure Boot was enabled when I installed Debian since everything “Just Worked”, which is impressive). How did you create your bootable USB?

dd if=path/to/iso of=/dev/sdd

Okay, that’s the same way I create my bootable USBs…

Is this a qubes-specific issue? That is, if you burn, say, Debian or Ubuntu or Linux Mint to that drive, are you able to boot?