Nouveau error message on boot, Dell

Hi! I have this issue too on a Dell pc for ubuntu 22.04 and it seems that it can’t continue booting any ideas here? Thanks !

@Juliosimonpedro_Boho ouch, that seems bad, do you eventually boot properly? worth troubleshooting details in dmesg

can a Mod fork this as a new topic since it’s not pci-related?

@Matt_Laurenceau Will try with troubleshooting, thanks!. I was booting properly couple of days ago and then this happened. This screen shows after the error of PCI. After trying a couple of boots it works, but I need to try many of them hehehe

Great, good luck finalizing!

for mtd device must be supplied (device name is empty), didn’t find a way to fix or hide it

For the /dev/nvme messages, I had a somewhat similar error (and very slow boot time) after I tweaked some partitions (/home and swap) without updating /etc/fstab properly

For Ubuntu 22.04 there is a “fix committed” on
The bug report, with a workaround included until the fix is released, can be viewed at…
Bug #1981622 “mtd device must be supplied (device name is empty)...” : Bugs : systemd package : Ubuntu

With the fix on the way it is probably easiest to just wait for the release than using the workaround at this stage. I used the workaround successfully on this very install I’m posting from now.

Edit: I should note that to use the workaround you will need to be logged into the launchpad site. If not logged in, some of the workaround details will be masked as an email address. It isn’t an email address but has the same format as one and as such gets masked.

1 Like

(meta – thanks @Fraoch for forking this topic from ACPI tables error! :raised_hands:)

@yetiman_64 thanks! I never looked at launchpad details, so I’ll use your recommendation, and wait patiently.
Do you indeed contribute to kernel tweaks? (last time I recompiled a kernel was about 25 years ago, to add support for an audio card :innocent:)


No, I don’t do any coding or “kernel tweaks”. I’m just a long time (15 years on Ubuntu/Debian) Linux user that can’t help digging into the system and seeing what I can make it do.

I do a lot of bash scripting for my own use, things like screenshows for displaying images or looping gifs/videos on the desktop (a bit like MS’s live desktop on VIsta but for Linux DEs); even a mount/unmount script for drives/partitions that I’ve hidden from the DE.

My “tweaking” is low level home “tinkering” type scripting only. I haven’t gone in for compiling or recompiling kernels, I’ve been lucky with Ubuntu over the years and my hardware has always been well supported generally.


The wait is almost over, the systemd update to fix the “mtd device” error has been released for 22.04 (Jammy). It is a phased update and is currently being held back on my install. I can see it in the “held back” section every time I do an update in the terminal. It may take a couple more days or so to be finally installed.

I’m looking forward to seeing the end of that boot screen error; I undid the workaround a day ago and have got it back so I can see how effective the update is when it finally arrives here.

1 Like

Thanks, I learnt that it was good NOT to force upgrades when items were held back.

I recently saw that GRUB appeared a couple of seconds when booting, not sure what I did that triggered this. I’ll look for for some quiet options, Grub customizer used to make it easy for me.

1 Like

@yetiman_64 my last sudo nala upgrade did the job, various systemd items were upgraded, and indeed, “mtd device” issues do not appear anywore!

Thanks for following on your side!!

@Juliosimonpedro_Boho is everything working ok for you now?

1 Like

I’m really glad to hear that. It’s a pity I didn’t follow the advice I gave you, :laughing: .

I still have the error even after updating the systemd packages. I suspect that when using the workaround I made a couple of mistakes initially and may have inadvertently done some sort of damage to a systemd config file. Or it is possible some of the other “tweaks” I’ve made in the /etc/systemd/system folder, related to my booting to a CLI screen with automatic log in to the terminal screen, may be somehow causing issues with this error.

I’ve reverted back to using the workaround for the time being; I expect sometime in the next month or two I’ll end up doing a full backup and re-install of Xubuntu and that, with the new systemd packages, will finally put this to rest here as well.

You’re welcome :slight_smile: I hope @Juliosimonpedro_Boho waited for the updated packages rather than using the workaround, like you did, and all is well.

1 Like