NVME dissapears randomly - AMD Framework 13" / Linux

Hi all !

From time to time ( something like 2 or 3 times a week), the nvme of my laptop dissapears.
I can’t investigate since my root filesystem is on the disk.
I’m just left with:
$ ls
ls: command not found

I think this didn’t happened with 3.03 firmware.
Any hint on that ?

OS: debian testing (kernel 6.7.12-amd64)
Laptop: AMD Framework 13"
Laptop Firmware: 3.05
NVME FW: 620331WD

It may be relative to Heads up: NVMe dissapearing after resume on 6.9.0-rcX and AMD Framework 13
But, but it’s not the same kernel nor nvme


Usually the NVME disappearing has to do with the drive getting put into a state incorrectly, and then the drive not resetting to a usable state as a result. Since the kernel is the one responsible for these actions and not the BIOS, I would be looking more to it than the BIOS.

Just my 2 cents.

1 Like

What’s the firmware version? (You can check with nvme or lshw. I’m on my phone so can’t give you the exact command)

Laptop FW is 3.05

Node                  Generic               SN                   Model                                    Namespace  Usage                      Format           FW Rev  
--------------------- --------------------- -------------------- ---------------------------------------- ---------- -------------------------- ---------------- --------
/dev/nvme0n1          /dev/ng0n1            23306C802277         WD_BLACK SN850X 2000GB                   0x1          2.00  TB /   2.00  TB    512   B +  0 B   620331WD
1 Like

Mmh ok no idea. That should be the latest version. I have the 1 TB version and same laptop without issues (except for GPU freezes).

No special kernel args or anything?
Also try to check the logs for anything interesting right before it disappears. (journalctl -b -1)

There’s a newer firmware version for your SN850X


try updating to that. I had a similar issue and since updating the firmware, this no longer happens

I’ve since then updated the firmware my SN850X

ok, thanks !

I’ll do that.

I had also many GPU freezes, and I had to:

Those problems should be solved with kernel 6.8+ and bios 3.05 (and are completely solved for me). This is a different/new issue. Fedora 40 on the Framework Laptop 13 - #47 by kholdstare

I have similar issue running Ubuntu 23.10 + WD BLACK SN770 1TB,
end up break the OS…

update the SSD firmware from 731110WD to 731120WD
also install Ubuntu 24.04 LTS

The issue never happened again,
not sure what solves the issue though.

It has been 5 days now that I updated the nvme firmware and I didn’t experience any freeze :slightly_smiling_face: