Periodic stuttering on fresh gnome.40 wayland install on Arch Linux

Hey there :wave:

As the title states I’m getting stuttering that I don’t quite know how to diagnose. Not sure if it is caused by gnome 40, wayland, arch linux, or the framework.

For the record, I’ve tried latest kernel and 5.12.15.

Anyone else having stutters on wayland? It appears as mouse and keyboard lag every once in a while.

1 Like

I have the same issue on Sway/wlroots/5.13 kernel, so my guess would be an intel driver issue

1 Like

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

Check the fedora 34 community tab on the framework community website, I had this same issue and I have since then resolved the issue. I also fixed a vertical sync issue that was very apparent when my display would update.

1 Like

Awesome, thanks @Jerry! Here’s the link for others who find this Fedora 34 on the Framework Laptop - #16 by Alan_Ning


Have had this same issue on Arch (with Sway and other wlroots compositors) and can confirm that disabling PSR fixes it. Rather than pass it to the kernel from the bootloader, I instead created a file /etc/modprobe.d/i915.conf containing just this line:

options i915 enable_psr=0

Works great.


I’m honestly shocked that Panel Self-Refresh is enabled by default.


FWIW, after updating to kernel 5.14.2-1 I no longer see any stuttering. (Manjaro 21.1.2 Gnome 40 wayland).

No issues with stuttering: arch/sway/5.15.2-arch1-1

No issues with stuttering: arch/sway/5.15.2-arch1-1

Nor 5.14.10.

Does bluetooth work on 5.15?

I can confirm that William’s suggested fix above worked for me in Manjaro Gnome 21.1.16

Hey guys,
Using kernel version 5.16-1 here. I had the same problem, plus screen flickering whenever my mouse moved to the left side of the screen, but disabling PSR still worked for me.

1 Like

I realize this is a tad older, but wanted to share disabling PSR resolved my screen flickering when mouse moved to left of screen, same as Arturo. I didn’t have flickering normally, only with mouse movement to the left.

did you install the intel video driver? as for wayland i havent tried it yet i just use sddm with xfce on my arch configuration and everything is functional.

I’m running Manjaro Linux on Wayland and can confirm this helped out with the screen issue.

I’m on Gnome 41 and 5.16.12-arch1-1. I just disabled PSR yesterday and things seem to have improved. The stuttering seemed to get worse as I watched videos in my browser, especially youtube.

I think this is related: screen flicker on gdm 41.3+kernel 5.16 on TigerLake-LP GT2 [Iris Xe Graphics] (#2156) · Issues · GNOME / mutter · GitLab

I was having some really bad stuttering issues, every minute or so it would totally freeze before coming back to life, this was for the current Void Linux on the 12th Gen Intel Framework:

  • Fine
    • Sway, XFCE
  • Awful
    • LXQT, bspwm, dwm, i3

The following Fixed it:

  • Uninstall xf86-video-intel and use modesetting
  • Disable PSR by setting options i915 enable_psr=0 in /etc/modprbe.d/i915.conf

What didn’t work was changing the kernel, using picom or swapoff -a.