Qualcomm NCM865 Fastconnect 7800 Windows 11 fixes

So I swapped out my Mediatek with the Qualcomm NCM865 wireless card and had a few issues that I am sure others have experienced. I believe I have worked out the main problems and this is for anyone doing the same swap:

Problem 1: Drivers, No idea why it is so hard to get up to date drivers for this card. The usual posted ones have timestamps from last year. With those drivers I was getting very abnormal connection rates (between 5-300Mbps) and the closer I was to a transmitter the worse it got.

Windows update would not find anything newer but you can manually download the newest drivers for both wifi and BT from the windows update catalog: Microsoft Update Catalog

Just open the CAB files and extract to get the latest drivers. My upload/download speeds are now about where I expect them at 600 down 500 up

2: Bluetooth audio, I was also having issues with bluetooth headphones not getting audio, the usual fix of disabling the telephony service did not help in my case.
I found for some reason my headset was being associated with 2 bluetooth devices in windows, The Qualcomm one and another listed as “AMD BT Audio Device”.

By disabling the “AMD BT Audio Device” located under “Sound Video and Game Controllers” in the device manager all my issues were resolved BT audio works perfectly now.
image

These fixes were tested on a FW16 7840 no dGPU

1 Like

Just wanted to thank you for this. I put the same card in an ASUS G14 (2024) and had the same bluetooth audio issue. Your solution worked for me as well.

I found the updated drivers from Lenovo but your solution is more elegant.

Thank you thank you thank you, I got the MSI Fastconnect 7800 and this solved the bluetooth headphone audio problem, one restart and my AirPods Max work perfectly now.

Thanks for the guide. I’m upgrading my AP and looking for a wifi 7 card myself.

Have you tested this under Fedora? How easy is it to get this working there?

If you don’t have Fedora installed, can you see if it works with just the live USB?