Razer Core X Chroma eGPU

I did a write-up here .

Yes I read it! I should probably have posted it here for reference.

Framework has promised a firmware update to their Framework Laptop soon too, that will fix the power delivery anomaly I was seeing. I’d need the eGPU hooked up along with a secondary power supply if I wanted to game for longer than four hours at a time.

Have the same problem: PD does not work on the first connection. But here is how I do it:

  • Boot the Framework with the eGPU plugged in: the LED is usually off.
  • At the Grub screen, unplug/replug the eGPU: the LED then turns on (so there is power/PD is working)
  • Continue to boot the OS I want.

So far it works.

1 Like

I have been trying to get an eGPU working under Ubuntu 21.04 using a different box, but am having some trouble. When I plug it in I see the BOX connected in dmesg but after installing the nvidia driver I am not seeing any GPU connected and the box doesn’t signal that it is properly connected.

[ 106.773600] usb 3-1: USB disconnect, device number 2
[ 111.581519] usb 3-1: new low-speed USB device number 5 using xhci_hcd
[ 111.733162] usb 3-1: No LPM exit latency info found, disabling LPM.
[ 111.740618] usb 3-1: New USB device found, idVendor=2a8c, idProduct=0030, bcdDevice= 3.61
[ 111.740628] usb 3-1: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[ 111.740631] usb 3-1: Product: eGFX Breakaway Box
[ 111.740634] usb 3-1: Manufacturer: Sonnet Technologies, Inc.
[ 111.740637] usb 3-1: SerialNumber: 1D06330155FAE59EB242EEA9CDE72569
[ 112.323813] usb 3-1: USB disconnect, device number 5
[ 112.629364] usb 3-1: new low-speed USB device number 6 using xhci_hcd
[ 112.781032] usb 3-1: No LPM exit latency info found, disabling LPM.
[ 112.787814] usb 3-1: New USB device found, idVendor=2a8c, idProduct=0030, bcdDevice= 3.61
[ 112.787824] usb 3-1: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[ 112.787827] usb 3-1: Product: eGFX Breakaway Box
[ 112.787831] usb 3-1: Manufacturer: Sonnet Technologies, Inc.
[ 112.787834] usb 3-1: SerialNumber: 1D06330155FAE59EB242EEA9CDE72569

Are you connecting the eGPU on boot or after the boot-up process.

I tried turning off the machine totally and then connecting, but nothing seems to really happen. I might try setting up windows to test it?

Looks like the USB device is disconnecting/reconnecting.

Have you tried the BIOS version 3.06?

Have you tried a different USB-C port/expansion card?

Have you tried the USB-C shielding fix?

Hi there,

New important stuff! Using the latest BIOS (3.06) I have found a way to reliably get all the USB-C peripherals plugged to the eGPU to work as expected. If works 99% of the time on both Windows and Linux (Fedora 35, Linux 5.15.5-200.fc35.x86_64):

  • Unplug the eGPU.
  • Boot.
  • At the GRUB screen, plug the eGPU (I’m using the top left slot of the laptop).
  • Select the OS and resume boot.

With this technique, the following peripherals are connected to the eGPU and work at boot and do not disconnect:

  • The embedded Ethernet card (though its chipset driver is buggy on Linux)
  • My SSD (Samsung T5).
  • My webcam (Razer Kio).
  • My keyboard (Keychron K9).

My conclusion is that the eGPU (including the USB hub support) issues are mainly caused by a faulty BIOS.


The trick above :arrow_up: works even better than expected: it also works on a stock Ubuntu 20.04!

  • Install Ubuntu 20.04
  • Do all the updates
  • sudo apt-get install nvidia-driver-495
  • plug the eGPU
  • run nvidia-smi to verify the GPU is detected
  • install and configure egpu-switcher
  • power off

Then the trick:

  • unplug the eGPU
  • boot to GRUB
  • plug the eGPU
  • boot Ubuntu



The trick above :arrow_up: also works on Ubuntu 21.10, which is officially supported by Framework (21.04.3+).

I can confirm the above trick also works with Manjaro 21.2.6 and the Razer Core X Chroma.

1 Like

The same trick works with Ubuntu 22.04.

The fact that this needs to be a ‘trick’ means Framework has got some fixing to do.

Ever since I got my Core X Chroma about half a year ago, my Framework does not boot into Windows if I press the power button with the Thunderbolt cable connected. If I make sure the cable is disconnected then attempt to boot, all is well and I can plug in the dock at the Windows login screen to use my external keyboard etc.

I finally did some more troubleshooting tonight and get a post code of 10111000 on the diagnostic LEDs. Any clues? I’m running BIOS 3.10 and Windows 10 build 19044.1826

I have a Sonnet 750 eGPU (RTX 3070) and I’m guessing you’re having a similar issue with either TPM and/or Bitlocker being tripped and either causing Windows to request to enter in your recovery key or a blank screen all together. It’s a known “security” feature listed on this site around eGPU & Windows 10 security features (https://egpu.io/forums/pc-setup/bitlocker-tripped-on-reboot/). Removal of the TB cable looks like the only real “fix” for now…or manually deprecating TPM/TB functionality.

1 Like

The trick above also works on Ubuntu 22.04 with the 12th gen i7-1280P board.

In my case I am using an Arch derivative, sddm greeter, X11, and plasma desktop. The system wants the eGPU added on the sddm greeter, not before, not after. Pretty much any other timing of plug in else results in kernel panels on 5.18.* with nvidia 515.65. Hot unplugging always results in kernel panic. I have both a Sonnet 550 and Razer Core (not X), same behavior on both, with Nvidia 1050Ti.

I have not tried Wayland lately, maybe that has gotten over some of its teething problems by now…

1 Like

I do have Bitlocker enabled, so that’s the likely cause. It’s a minor inconvenience but not unmanageable. Thanks for the link!

1 Like

Late to the game, but I got a Core X Chroma for my Framework (11th Gen i5) Running Arch. I was having issues, so I decided to do a fresh install. I got the actual graphics card working pretty quickly and reliably, with no issues with that so far. However was having issues with the USB hub on the eGPU and the Ethernet port (which is just a USB to Ethernet adapter, so it inherited the USB issues). I didn’t see this trick, but figured that out as well, and it works. I have found that if I do reboot then the USB accessories won’t work, unless I do this trick. However if I do poweroff wait a couple seconds, and then press the power button, I don’t need to do this (at least I didn’t have to a couple times in a row).

I do full disk encryption, so I plug the TB cable in when I get the the password entry prompt to decrypt my root, and then that works.

I noticed that when the USB stuff doesn’t work, my keyboard would like up before the GRUB menu shows up, then it’ll turn off during loading initramfs, and won’t come back on. Inspecting the dmesg output I noticed issues with the xHCI driver and seeing things that weren’t responding and assuming they are dead.

But following this trick has been pretty reliably been able to make things work so far. Also to those who don’t realize it, if you’re using egpu-switcher to handle the xorg.conf configuration file, you have to plug your eGPU into the same port on the laptop every time, since they all will give the card different pci addresses.

I have the Core X Chroma with a 3090 in it and it works great in Windows. But I have yet to get it to work in Manjaro.

Would you mind giving a run down of what you did in Manjaro? Whenever I install the intel/nvidia prime drivers from manjaro-settings and reboot, upon booting the system appears to freeze right before launching GDM.

Update: Solved this here: [GUIDE] Manjaro, Kernel 5.18+, eGPU, Nvidia

Glad to see you got it running

@Framework had you all seen this? I could not find any known issues documented around this? It seems pretty easily reproducible with 11th and 12th gen Frameworks.

If there’s anything that you need to help diagnose this for a BIOS update, i’m also willing to help! :slight_smile: