[RESOLVED] AMD - Following Ubuntu 22.04 Guide -- Secure Boot?

I went through the install guide yesterday on my new framework 13 AMD, and in the install it says to check the box indicating to install 3rd party drivers. In the actual install, it says you need to enable secure boot to have 3rd party drivers, but the install guide doesn’t mention this and the screenshot there doesn’t include it.

So I enabled secure boot and after the install I am not able to get past the login screen. Every time I type my password and press enter, it crashes and looks like it may be restarting (get the framework screen).

I tried reinstalling without secure boot checked at the install step and that fixed that issue but now I am facing some other issues:

  • The mouse pointer is very laggy and freezes and skips around a lot, especially with an external monitor connected. It’s to the point that it is not usable. This began occurring after I followed the steps in this guide
  • I can’t install the bios update (removed link to guide because it won’t let me have more than 2 links in post)

When I do
fwupdmgr refresh

It says

Failed to connect to daemon: Error calling StartServiceByName for org.freedesktop.fwupd: Failed to activate service 'org.freedesktop.fwupd': timed out (service_start_timeout=25000ms)

So I’m wondering – was I supposed to use secure boot? If so, then has anyone else seen the issue where you can’t get past login? If not, then how can I diagnose the other issue I am seeing?

I have solved the laggy cursor issue by getting past the issue with upgrading the BIOS. I uninstalled the apt version of fwupd and installed the snap version, and then I was able to upgrade the BIOS. However, now I am not able to follow the steps to upgrade the fingerprint reader.

Following this guide, when I run
sudo fwupdtool install --allow-reinstall --allow-older goodix-moc-609c-v01000330.cab

I get

Failed to open file “goodix-moc-609c-v01000330.cab”: Permission denied

I am still curious if we are meant to install 22.04 with secure boot or not, and also how to get past this issue installing the fingerprint update.
This is my fwupd version info:

fwupd.fwupdmgr --version
compile   com.hughsie.libxmlb           0.3.6
compile   com.hughsie.libjcat           0.1.9
compile   org.freedesktop.fwupd         1.9.7
runtime   org.freedesktop.fwupd-efi     1.4
compile   org.freedesktop.gusb          0.3.10
runtime   org.freedesktop.gusb          0.3.10
runtime   org.freedesktop.fwupd         1.9.7
runtime   org.kernel                    6.1.0-1025-oem

Hi @skroth, welcome the community!

While I don’t have the time at the moment to capture screenshot for the guide, I did update it to reflect your feedback.

The BIOS update will help with this. You have verified you’re running the OEM C kernel after following this section I am sure. Easy to verify with a uname -r in the terminal. You should be looking at as your kernel.

I’d start off fresh, new install. As I suspect this has to do with the varied stuff happening that lead up to this point.

  • Disable secure boot, leave it off, it’s unneeded.
  • Install Ubuntu 22.04.3, making sure to follow this updated step by step guide (also linked in section 9 of the main guide).
  • Now follow this guide to get the BIOS updated. The latest BIOS is a 3.03 release for AMD.
1 Like

Hey Matt, thanks for the response. I did a fresh install and everything seems to be working now. I no longer have the issue with fwupdmgr, so was able to keep using the apt version and was able to get the fingerprint reader working. Thanks!

Fantastic news! Thanks

Regarding the oem-c kernels on ubuntu 22.04.x LTS - I tend to enable the hwe kernels (kernel - What is hardware enablement (HWE)? - Ask Ubuntu) only and remove the regular ones. Don’t know if oem-c kernels are the same as hwe kernels to be honest. Still don’thave my FW16 AMD device here, but I have a home-server with a AMD kernel, and that has helped take care of some issues.

admin@terminus:~$ dpkg -l | grep hwe 
ii  linux-generic-hwe-22.04                                                                          amd64        Complete Generic Linux kernel and headers
ii  linux-headers-generic-hwe-22.04                                                                  amd64        Generic Linux kernel headers
ii  linux-hwe-6.2-headers-6.2.0-36                           6.2.0-36.37~22.04.1                                                   all          Header files related to Linux kernel version 6.2.0
ii  linux-hwe-6.2-headers-6.2.0-37                           6.2.0-37.38~22.04.1                                                   all          Header files related to Linux kernel version 6.2.0
ii  linux-image-generic-hwe-22.04                                                                    amd64        Generic Linux kernel image

This way, I’m always on the latest hwe kernels and I don´t have to “fix” a kernel to boot in grub.
Newest will always be taken.

As soon as I get my FW16 laptop, I’ll try it out and report back.

Please do what works best for you. We test against and support OEM C. :slight_smile: