[RESOLVED] AMD FW13 Internal display not getting recognised after update to kernel version 6.6.x

Hello Framework Community,

I have an Issue with Fedora 39 on my Framework with the Ryzen 7 7840U. When I update to the newest Kernel 6.6.5 and above the laptop screen stops working (I updated it via the terminal). I can still connect it to an external display and it works just fine but it doesn’t recognise the build-in screen at all. This also happens when I boot an Arch Linux ISO with Kernel Version 6.6.2. I have the newest BIOS Version 3.03 installed and, as far as I recall, I only disabled Secure Boot and put the iGPU to “Game optimised” in the BIOS setting. Reverting those settings doesn’t work either. I also tried to add the kernel parameter amdgpu.sg_display = 0, but that didn’t work either.
I looked through the systemd journal log. The left one is the 6.6.8 boot that doesn’t recognise the screen and says “No EDID read” and the right one is the working 6.5.6 boot. Does anyone else have this issue and knows a solution?

Hi @VandelBlake , Welcome to the community :slight_smile:

Is the behavior of not detecting built-in screen consistent even on Fedora 39 live and on Ubuntu 22.04.3?

1 Like

Hello @Loell_Framework,

the Fedora live session does work fine and it ships with kernel version 6.5.6 and I haven’t found any more recent images to flash and try out. I can install Fedora just fine but after a Kernel upgrade, it reboots I see the Framework Logo and then it doesn’ transition to the Fedora boot sequence and just shows black. I haven’t tried out Ubuntu yet. I will test it and see if that works.

I tried the Ubuntu live session. It works but rather slow and it gives me this error (cros_ec_lpcs.0: EC ID not detected) when booting up and after I click “Try Ubuntu”. In the second case it stays on that screen for a while and then the desktop appears.

That’s the expected behavior on Ubuntu 22.04.3 for AMD FW13,

Strange that you are having screen issues with Fedora 39 Kernel 6.6.8

can you take pictures of the screen when booting to 6.6.8 kernel? Is whole screen black out or having messages on screen?

and also can we make sure no extra parameters when booting to kernel 6.6.x?

Ok, thanks for the info. It doesn’t show any messages. It just transitions from just the Framework logo on the laptop screen to a black screen and the Framework logo with the fedora logo shows up if I connect it to an external display. In the OS the internal display doesn’t get recognised anymore. I haven’t changed any other kernel parameters and this issue has persisted even after a fresh install. And it happens since Kernel version 6.6.5. Excluding the Kernel from an update works. Here are some pictures of the boot up sequence and the settings menu before and after.
Sorry for the german text.

Also when you tried booting with kernel 6.6.x , can we try it with no external connections? except with power cable, see if screen shows.

That also doesn’t work. I tried it with the latest kernel update 6.6.9 and the issue persists even after removing the HDMI expansion card. The screen does get power and the backlight is on.

I have also tried Fedora Rawhide live images and the issue persisted but I didn’t find anything related to an EDID. Instead I found this error regarding the amdgpu and another one relating to PCI. I don’t know if that helps.

I don’t think the PCI issue you are seeing is related to your problem. I get the same message with kernel 6.6.11 but everything works fine:

[    0.361898] pci 0000:00:00.2: can't derive routing for PCI INT A
[    0.361900] pci 0000:00:00.2: PCI INT A: not connected

I don’t have the amdgpu related errors you are seeing. Out of curiosity, are there other amdgpu related messages prior to these errors that indicate that amdgpu has been successfully initialised and firmware blobs loaded?

Thanks for the info. I’ll check that more carefully the next time. But this error does come up more often.

Ok, I booted the 6.6.9 kernel on my fedora install and looked through it. I think the GPU gets initialized correctly but that EDID error is still there.

I also found these other errors

. (?)

Then why is Ubuntu 22.04 listed as an officially supported for AMD FW13? I got the same issue “EC ID not detected” on my laptop. What’s the workaround?

Hi @Roman_Proskuryakov ,

welcome to the forums, can you give details on your specific issue?


I created a new topic for my case: Ubuntu on FW13 AMD 7840

I haven’t come back to the issue but it still persists. I tried it with the newest fedora Rawhide build with 6.8. I don’t know if it is a hardware or a software issue at this point… Should I open a support ticket?

I have resolved the issue. It was a hardware issue and disattaching and reattaching the display cable fixed my issue. Never thought about that, but the support team considered it. Thank you all for the replies.

Delighted to hear this. Marking resolved.