[RESOLVED] AMD Ryzen 7040 Series - Blank screen in Fedora 39 KDE beta after reboot

Hey there,

I received my new Framework 13 with Ryzen 7. Now i am facing with some problems during the installation of Fedora 39 Beta. I have now tried Fedora KDE Spin and it worked out of the box except for a reboot. But after a reboot no login screen was displayed. I have tried with and without an update via software center. My installation is with encryption enabled. Should not be the problem becaus this still displayed correctly and continued after the first setup.

With the normal Fedora 39 beta installation, the welcome screen is briefly displayed and then the screen goes black. I have tried this several times as well.

Any ideas?

Best regards


I got the same thing right now with Fedora Kinoite… Installation was fine but first boot leads to black screen.

I’m gonna install the standard version since it’s the supported flavor. Despite being tagged “fedora” divers and kernel might be different at some point on Kinoite.

Please let me know if this works on your system. I had bad luck with the standard version, but I will try it again.

Hi @mopac,

Our testing was done with fully updated (meaning dnf is up to date at all times) release of Fedora 39 Workstation (GNOME).

Screen going black on KDE has me wondering if you might be able to duplicate this on a proper Fedora 39 Workstation GNOME?

I’m about to run my own updates again (I run them daily as this is a pre-release), to see if anything new has cropped up.

1 Like

Ok just to report back that the Workstation edition with Gnome is running fine after the initial reboot. I did not realize when I downloaded the ISO but I’m actually running the Fedora 40 pre release. Not the 39 one.
I’m gonna keep this installation for the next few days to decide if it is enough stable for my usage or not…


Hi Aurelien & Matt

thanks a lot for your feedback! I just tried again. This time I was able to install Fedora 39 Beta Workstation. This time I took another stick. Not sure if that had any effect on it. So far it fits for now. Waiting for the final release now and will then switch from 39 Beta to 39 Stable.

Seeing the same behavior on my FW13 AMD with F39 KDE Spin. Initial install worked out of the box. After first boot to desktop, sddm crashes every subsequent boot causing blank screen after boot logo (both before and after most recent updates). Switching over to tty2 after the screen goes black and restarting sddm.service allows full login to the desktop. Everything else seems to be working after logging in. Attempting to logout or switch users also seems to crash sddm.

dmesg shows a kwin_wayland segfault after a bunch of amdgpu and [drm] lines on boot. Guessing that has something to do with the known kernel/firmware issue(s).


Just adding that I am seeing the same issue with the F39 Beta / KDE spin. I’ve reinstalled and immediately rebooted as well as reinstalled, updated, and then rebooted. Same issue in both approaches. Was hoping to be able to use the KDE spin because Gnome isn’t making fractional scaling available to me… :frowning:

I think there are some ways to do troubleshooting in this case. Though I haven’t experienced KDE. So, below is my guess.

  1. Check the boot log: I think when you type the Escape key, you may be able to see the boot log n the booting process and the blank screen. Then when you type Escape key again, you may be able to change the log screen back to the blank screen again.

  2. Try console mode: If the problem happens in the process of launching the KDE boot manager, maybe you can type Ctrl+Alt+F2 to change to the console mode. Then you may run dmesg to check the boot log, and dnf upgrade to get the latest RPM packages. You can type Ctrl+Alt+F1 to change back to the GUI mode. This is a thread I opened to fix a similar error in another desktop manager GDM (Gnome Desktop Manager)

  3. Login with Singe user mode (rescue mode) by editing GRUB menu. - Working with the GRUB 2 Boot Loader :: Fedora Docs

1 Like

I’d echo above. We do not provide any official support for KDE at this time, but this is a good jumping off point.

  1. Downloaded the Fedora 39 Beta KDE Spin from Fedora KDE Plasma Desktop | The Fedora Project
  2. Wrote it to a flash drive
  3. Installed Fedora KDE following the Framework Fedora guide
    So far everything is good

Then I ran Discovery and installed the 3.8 GB of updates.
After rebooting, screen is blank. There’s no way to boot back to the DE.

I’ve tried hitting F12 on boot to select a different option but they all end up the same way.

Does anyone have the KDE spin working on a 7040 with the 3.03 bios? Just got a notification that batch 2 is getting ready to ship and it’d be nice to know if it’ll work; I really don’t like gnome.

Thank you, junaruga! I haven’t had time test that but will give it a shot

What I’ve done as a placeholder is install the Gnome version of the F39 beta, then installed the KDE desktop group. The Gnome login screen loads fine, and Plasma works great once you get to the login screen, so I use the Gnome login screen to get into a KDE session. Not the best, but it’s a great way to get fractional scaling in a visually pleasant way. :wink:

Hopefully this is a safe yet clunky workaround until the issue is resolved.



Not sure there is anything to resolve in this instance as it sounds like the method used to update was perhaps a contributor somehow.

Two things I need to disclose here.

  • We do not actively test against KDE, however, being a Fedora Spin, I tried it on 7040 with 3.03 BIOS.

  • BIOS releases are fast and furious right now for 7040, so folks reading this - it will not matter long term - this was merely a test.

  • Downloaded/USB setup a brand new ISO of Fedora KDE 39 Beta using mediawriter. Smooth install to the 7040.

  • Updated via the terminal, rebooted. Flawless.

  • Nothing attached except power. Running Wayland.


Thanks for sharing the workaround!

1 Like

Agreed, we do appreciate your experience with this @Shibusuke.

Hopefully my above test, update method and whatnot is also helpful for anyone else.

Based on their workaround, I’ll mark this as solved.

Thank you for testing this even though it’s not in official support scope - this gives me confidence I may be able to get it working with a later bios.

1 Like

Did I miss something ? So far, I coudn’t find the 3.03 Bios anywhere. It is still for internal tests only ? Any way to contribute before release even during alpha stages in order to give you guys some feedbacks maybe ?


Another data point here.

  • FW 13 AMD 7640u, 64GB RAM (g.skill), BIOS 3.02. Arrived today. Lovely machine.

  • Installed to encrypted SSD from Fedora KDE ISO.

  • First boot after install, login screen working. Logged in and updated via the terminal. Rebooted.

  • On boot after update (6.5.7-300 kernel), freezes at blank screen after unlocking encrypted disk. Manually switching to a console using Ctrl+Alt+F2, logging in, and entering sudo service sddm restart brings up a working graphical login screen.

  • Rebooting using the backup 6.5.2 kernel does not resolve the issue.

  • I have added an extract of the relevant dmesg output below, starting as soon as the GPU starts having issues.

[   17.335441] [drm:mes_v11_0_submit_pkt_and_poll_completion.constprop.0 [amdgpu]] *ERROR* MES failed to response msg=14
[   17.335726] [drm:amdgpu_mes_reg_write_reg_wait [amdgpu]] *ERROR* failed to reg_write_reg_wait
[   17.465188] [drm:mes_v11_0_submit_pkt_and_poll_completion.constprop.0 [amdgpu]] *ERROR* MES failed to response msg=14
[   17.465341] [drm:amdgpu_mes_reg_write_reg_wait [amdgpu]] *ERROR* failed to reg_write_reg_wait
[   17.605605] [drm:mes_v11_0_submit_pkt_and_poll_completion.constprop.0 [amdgpu]] *ERROR* MES failed to response msg=14
[   17.605858] [drm:amdgpu_mes_reg_write_reg_wait [amdgpu]] *ERROR* failed to reg_write_reg_wait
[   17.735282] [drm:mes_v11_0_submit_pkt_and_poll_completion.constprop.0 [amdgpu]] *ERROR* MES failed to response msg=14
[   17.735429] [drm:amdgpu_mes_reg_write_reg_wait [amdgpu]] *ERROR* failed to reg_write_reg_wait
[   27.270500] [drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring sdma0 timeout, signaled seq=37, emitted seq=39
[   27.271068] [drm:amdgpu_job_timedout [amdgpu]] *ERROR* Process information: process  pid 0 thread  pid 0
[   27.271566] amdgpu 0000:c1:00.0: amdgpu: GPU reset begin!
[   27.450991] [drm:mes_v11_0_submit_pkt_and_poll_completion.constprop.0 [amdgpu]] *ERROR* MES failed to response msg=3
[   27.451154] [drm:amdgpu_mes_unmap_legacy_queue [amdgpu]] *ERROR* failed to unmap legacy queue
[   27.580713] [drm:mes_v11_0_submit_pkt_and_poll_completion.constprop.0 [amdgpu]] *ERROR* MES failed to response msg=3
[   27.580861] [drm:amdgpu_mes_unmap_legacy_queue [amdgpu]] *ERROR* failed to unmap legacy queue
[   27.710285] [drm:mes_v11_0_submit_pkt_and_poll_completion.constprop.0 [amdgpu]] *ERROR* MES failed to response msg=3
[   27.710440] [drm:amdgpu_mes_unmap_legacy_queue [amdgpu]] *ERROR* failed to unmap legacy queue
[   27.839960] [drm:mes_v11_0_submit_pkt_and_poll_completion.constprop.0 [amdgpu]] *ERROR* MES failed to response msg=3
[   27.840108] [drm:amdgpu_mes_unmap_legacy_queue [amdgpu]] *ERROR* failed to unmap legacy queue
[   27.969633] [drm:mes_v11_0_submit_pkt_and_poll_completion.constprop.0 [amdgpu]] *ERROR* MES failed to response msg=3
[   27.969796] [drm:amdgpu_mes_unmap_legacy_queue [amdgpu]] *ERROR* failed to unmap legacy queue
[   28.099342] [drm:mes_v11_0_submit_pkt_and_poll_completion.constprop.0 [amdgpu]] *ERROR* MES failed to response msg=3
[   28.099496] [drm:amdgpu_mes_unmap_legacy_queue [amdgpu]] *ERROR* failed to unmap legacy queue
[   28.229010] [drm:mes_v11_0_submit_pkt_and_poll_completion.constprop.0 [amdgpu]] *ERROR* MES failed to response msg=3
[   28.229166] [drm:amdgpu_mes_unmap_legacy_queue [amdgpu]] *ERROR* failed to unmap legacy queue
[   28.358705] [drm:mes_v11_0_submit_pkt_and_poll_completion.constprop.0 [amdgpu]] *ERROR* MES failed to response msg=3
[   28.358855] [drm:amdgpu_mes_unmap_legacy_queue [amdgpu]] *ERROR* failed to unmap legacy queue
[   28.488417] [drm:mes_v11_0_submit_pkt_and_poll_completion.constprop.0 [amdgpu]] *ERROR* MES failed to response msg=3
[   28.488565] [drm:amdgpu_mes_unmap_legacy_queue [amdgpu]] *ERROR* failed to unmap legacy queue
[   28.490484] amdgpu 0000:c1:00.0: amdgpu: MODE2 reset
[   28.518860] amdgpu 0000:c1:00.0: amdgpu: GPU reset succeeded, trying to resume
[   28.519438] [drm] PCIE GART of 512M enabled (table at 0x000000801FD00000).
[   28.519629] amdgpu 0000:c1:00.0: amdgpu: SMU is resuming...
[   28.521271] amdgpu 0000:c1:00.0: amdgpu: SMU is resumed successfully!
[   28.523313] [drm] DMUB hardware initialized: version=0x08001E00
[   28.528020] [drm] REG_WAIT timeout 1us * 1000 tries - dcn314_dsc_pg_control line:264
[   28.530527] [drm] REG_WAIT timeout 1us * 1000 tries - dcn314_dsc_pg_control line:272
[   28.533027] [drm] REG_WAIT timeout 1us * 1000 tries - dcn314_dsc_pg_control line:280
[   28.535529] [drm] REG_WAIT timeout 1us * 1000 tries - dcn314_dsc_pg_control line:288
[   28.543362] [drm] REG_WAIT timeout 1us * 1000 tries - dcn314_dsc_pg_control line:264
[   28.545869] [drm] REG_WAIT timeout 1us * 1000 tries - dcn314_dsc_pg_control line:272
[   28.548371] [drm] REG_WAIT timeout 1us * 1000 tries - dcn314_dsc_pg_control line:280
[   28.550872] [drm] REG_WAIT timeout 1us * 1000 tries - dcn314_dsc_pg_control line:288
[   28.894278] [drm] kiq ring mec 3 pipe 1 q 0
[   28.896557] [drm] VCN decode and encode initialized successfully(under DPG Mode).
[   28.896700] amdgpu 0000:c1:00.0: [drm:jpeg_v4_0_hw_init [amdgpu]] JPEG decode initialized success
[   28.897413] amdgpu 0000:c1:00.0: amdgpu: ring gfx_0.0.0 uses VM inv eng 0 on hub 0
[   28.897416] amdgpu 0000:c1:00.0: amdgpu: ring comp_1.0.0 uses VM inv eng 1 on hub 0
[   28.897417] amdgpu 0000:c1:00.0: amdgpu: ring comp_1.1.0 uses VM inv eng 4 on hub 0
[   28.897418] amdgpu 0000:c1:00.0: amdgpu: ring comp_1.2.0 uses VM inv eng 6 on hub 0
[   28.897419] amdgpu 0000:c1:00.0: amdgpu: ring comp_1.3.0 uses VM inv eng 7 on hub 0
[   28.897421] amdgpu 0000:c1:00.0: amdgpu: ring comp_1.0.1 uses VM inv eng 8 on hub 0
[   28.897422] amdgpu 0000:c1:00.0: amdgpu: ring comp_1.1.1 uses VM inv eng 9 on hub 0
[   28.897423] amdgpu 0000:c1:00.0: amdgpu: ring comp_1.2.1 uses VM inv eng 10 on hub 0
[   28.897424] amdgpu 0000:c1:00.0: amdgpu: ring comp_1.3.1 uses VM inv eng 11 on hub 0
[   28.897425] amdgpu 0000:c1:00.0: amdgpu: ring sdma0 uses VM inv eng 12 on hub 0
[   28.897427] amdgpu 0000:c1:00.0: amdgpu: ring vcn_unified_0 uses VM inv eng 0 on hub 8
[   28.897428] amdgpu 0000:c1:00.0: amdgpu: ring jpeg_dec uses VM inv eng 1 on hub 8
[   28.897429] amdgpu 0000:c1:00.0: amdgpu: ring mes_kiq_3.1.0 uses VM inv eng 13 on hub 0
[   28.900151] amdgpu 0000:c1:00.0: amdgpu: recover vram bo from shadow start
[   28.900152] amdgpu 0000:c1:00.0: amdgpu: recover vram bo from shadow done
[   28.900196] [drm] Skip scheduling IBs!
[   28.900205] [drm] Skip scheduling IBs!
[   28.900210] [drm] Skip scheduling IBs!
[   28.900214] [drm] Skip scheduling IBs!
[   28.900218] [drm] Skip scheduling IBs!
[   28.900222] [drm] Skip scheduling IBs!
[   28.900227] [drm] Skip scheduling IBs!
[   28.900231] [drm] Skip scheduling IBs!
[   28.900235] [drm] Skip scheduling IBs!
[   28.900249] [drm] Skip scheduling IBs!
[   28.900253] [drm] Skip scheduling IBs!
[   28.900256] [drm] Skip scheduling IBs!
[   28.900260] [drm] Skip scheduling IBs!
[   28.900263] [drm] Skip scheduling IBs!
[   28.900269] [drm] Skip scheduling IBs!
[   28.900273] [drm] Skip scheduling IBs!
[   28.900276] [drm] Skip scheduling IBs!
[   28.900277] [drm] Skip scheduling IBs!
[   28.900283] [drm] Skip scheduling IBs!
[   28.900286] [drm] Skip scheduling IBs!
[   28.901248] [drm] ring gfx_32770.1.1 was added
[   28.902122] [drm] ring compute_32770.2.2 was added
[   28.902925] [drm] ring sdma_32770.3.3 was added
[   28.902952] [drm] ring gfx_32770.1.1 ib test pass
[   28.902979] [drm] ring compute_32770.2.2 ib test pass
[   28.903155] [drm] ring sdma_32770.3.3 ib test pass
[   28.904399] amdgpu 0000:c1:00.0: amdgpu: GPU reset(1) succeeded!
[   29.176697] [drm] Skip scheduling IBs!
[   29.182226] [drm] Skip scheduling IBs!
[   29.182594] [drm] Skip scheduling IBs!
[   29.182731] show_signal_msg: 59 callbacks suppressed
[   29.182734] kwin_wayland[1675]: segfault at 0 ip 00007fc921dd6750 sp 00007ffe4557cd98 error 6 in libkwineffects.so.5.27.8[7fc921dc4000+29000] likely on CPU 4 (core 2, socket 0)
[   29.182745] Code: d2 74 30 4c 8b 07 31 c0 4d 03 40 10 66 0f 1f 44 00 00 48 63 c8 48 89 c7 48 83 c0 01 48 c1 e1 04 48 c1 e7 04 f3 41 0f 6f 04 08 <0f> 11 04 3e 48 39 d0 75 df c3 66 0f 1f 44 00 00 f3 0f 1e fa 55 66
[   29.571405] [drm] Skip scheduling IBs!
[   29.571444] [drm] Skip scheduling IBs!
[   29.571464] [drm] Skip scheduling IBs!
[   29.571475] [drm] Skip scheduling IBs!
[   29.571487] [drm] Skip scheduling IBs!
[   29.571510] [drm] Skip scheduling IBs!
[   29.571525] [drm] Skip scheduling IBs!
[   29.571536] [drm] Skip scheduling IBs!
[   29.571743] [drm] Skip scheduling IBs!
[   29.571758] [drm] Skip scheduling IBs!
[   29.571769] [drm] Skip scheduling IBs!
[   29.571779] [drm] Skip scheduling IBs!

There is a segfault pointing at the kwin compositor’s graphical effects, as loaded by the sddm login manager - not sure if this is the cause of the GFX card reset or a symptom.

[ 29.182734] kwin_wayland[1675]: segfault at 0 ip 00007fc921dd6750 sp 00007ffe4557cd98 error 6 in libkwineffects.so.5.27.8[7fc921dc4000+29000] likely on CPU 4 (core 2, socket 0)

The suggestion by @Shibusuke of using the default Fedora ISO with GNOME, installing the KDE desktop, and using the GNOME login manager should be an effective workaround. There is still an underlying issue here though - (potentially) flawed user-mode software shouldn’t necessarily be able to cause a reset of the graphics card.

What has been shipped with is what we want folks on at the moment. This is super fluid and will evolve. So unless you see a thread for the new BIOS, you’re where you need to be at this moment.

1 Like