[RESOLVED] Fedora + vmware AMD

I am running Fedora 39
Batch 10 AMD Ryzen7

I have a licensed copy of Vmware Workstation Pro v17

My issue:
After booting a VM in Workstation my system starts to misbehave
fprintd stops working (fingerprint reader)
launching new applications that were not running before will fail; even opening a new tab in Chrome

The only way to rectify this is to reboot the system, closing vmware will not resolve this

this is NOT an issue with virtualbox - that works without any issues

im tasked with testing something and vmware is required - so i need to figure out why this is tanking my system in such a way.

any guidence is helpful. im not really sure where to start

in messages once the VM is running these come up (grep fprintd)

I also have VMware Workstation 17.5 and experience some odd behavior on Fedora 39 on my desktop (Ryzen 7 5800x, Radeon RX 6800XT and currently kernel 6.6). Even after recompiling the vmware modules manually I still have system hangs for some parts of the system when I launch a VM, and USB passthrough doesn’t work any more (passthrough devices don’t work).
I had Fedora 38 and it all worked perfectly, and even after upgrading to 39 everything worked fine up until about a month ago (up until kernel 6.5 maybe?). In seeing your screenshot I can see some USB issues reported so perhaps it’s also a USB passthrough problem that is causing your specific issue with the fingerprint reader?
My point is, I think the problem is the interaction between Fedora 39 and Workstation Pro (and possibly with Ryzen in particular but I haven’t tested Fedora 39 + VMware on Intel hardware). I will see if I can find an Intel machine I can put Fedora 39 + Workstation Pro on and see if it also has the USB/kernel module issue.

1 Like

We’ve seen a lot of issues with VMWare (I’ve seen it elsewhere, this is not a Framework exclusive thing in what I have seen).

That said, this will likely be best directed at a VMWare support forum as I lack the cycles to to dive too deep into this.

That said, with logs in hand, it may be worth filing bug reports with Fedora to make sure it’s on their radar.

1 Like

I didnt think it was, ill also reach out to VMWare

1 Like

You can find patches to update the modules to work with later kernels at https://github.com/mkubecek/vmware-host-modules.

I downloaded the workstation-17.5.0 patches, recompiled and installed the modules, rebooted, and device disconnect/reconnect worked fine (fedora 39, kernel 6.6.7-200). I’d suggest you give it a shot and see if it addresses the fingerprint reader issue.

1 Like

This DID fix that issue.

thank you


@Gary_S Amazing, appreciate this. :slight_smile:

Marking resolved.

1 Like