[RESOLVED] Fn lock makes both Fn+F# and F# trigger the media control keys

Is this on 11th gen by chance?

@Matt_Hartley no, mine is a 12th Gen, sry, i forgot to mention that, also running Ubuntu 23.04

Please try this and reboot, see if it surfaces again.

echo "blacklist cros_ec_lpcs" | sudo tee -a /etc/modprobe.d/no_cros_ec.conf

Rationale here: [TRACKING] Fn key stops working on PopOS after a while - #43 by Chris_Guidry

1 Like

I did as suggested… until now, the problem hasn’t happened again… I’ll update here if it does happen again :+1:

1 Like

Sounds promising! Keep us posted.


unfortunately, it just happened again … the Fn key is “broken” … i cannot do PgUp/PgDn/Home/End anymore, i do have Fn Lock enabled, so my Function Keys work, but i cannot use the media keys.
I checked if the cros_ec_lcps module wasnt loaded… and found out that it is indeed loaded:

# lsmod | grep cros_ec_lpcs
cros_ec_lpcs           16384  0
cros_ec                20480  1 cros_ec_lpcs

even though i do have:

# cat /etc/modprobe.d/blacklist-cros_ec_lpcs.conf 
blacklist cros_ec_lpcs

strange… can anything load that module and ignore the blacklist?

Anyway… i will now rmmod it and reboot to get my Fn Key back and then make sure it is not loaded.

In my experience, blacklisting it as a kernel parameter is sometimes has success over using blacklist-cros_ec_lpcs.conf. I’d consider trying that and see if that makes a difference.

For me, when this problem occurs the Function Keys work as function keys regardless of Fn Lock - I never have Fn Lock on, but when the problem occurs, the keys still always operate as function keys and not media keys.

On Ubuntu after modifying anything in /etc/modprobe.d you also need to run sudo update-initramfs -u for it to take effect at next reboot. Without this, the blocked modules might still be loaded during early boot.

Note that the modules are completely cleared and reloaded during a reboot, so doing rmmod just before a reboot is unlikely to have any effect.

Also, in my experience, a less disruptive way to clear the problem is to suspend and then resume the laptop (ie. close the lid, wait for it to sleep, then reopen the lid). Have you tried that, and does it work for you? Or do you have to reboot to fix it?

Echoing devkev’s suggestion, please do report back.

Just adding on @devkev suggestion, if you find closing the lid a hassle, for the purpose of short suspend the resume, you can also just invoke

sudo systemctl suspend

then press any key after it has suspended.

1 Like

Blacklisting cros_ec_lpcs did the trick for me too: no more Fn keys malfunction!

1 Like

For those wondering why we’re disabling cros_ec_lsps, it relates to this: LKML: "Dustin L. Howett": [PATCH 0/2] platform/chrome: Add support for the Framework Laptop

There were some hiccups with it though, so we have folks disabling it while it is sorted out.

1 Like

So which bios version is it expected to be solved. I am currently on Bios 3.06 on Fedora 39.

Blacklist as described, it’s a kernel thing.