[RESOLVED] Framework 13 ryzen-7040 Ubuntu 22.04 -- Keyboard keys?

This is a small bit - 2 questions and a request (maybe):

  • what is the intended function of the cycling of the “Monitor” (F9) key?

On Ubuntu, it seems to cycle thru 100%, 200%, monitor share, monitor mirror, external monitor off… I can’t fathom the intended operations, nor find any reasonable “utility” in this, so just asking: what is the intent here?

  • framework key (F12) - seems to open media. Is there some way to repurpose the top-row keys? In particular, I truly miss a simple “touchpad” off/on toggle when mobile (or when mouse connection lost w/ touch off!!!)

  • the “Windows” key (left lower, between “fn” and “alt”) seems to be the “SUPER” key on Ubuntu. Are there any other less-than-obvious key mappings I’m missing?

BTW - after a build/install the day that BIOS-3.03 was released (and I upgraded mid install), and fingerprint BIOS update, this thing has been keeping me really happy in many, many ways! Nice job, folks! I’ve been building (compiling), rsyncing, and working w/ it non-stop… my other 2 computers are likely to accumulate dust until I find how I intend to repurpose them.

BTW - I can turn the touchpad off/on w/o a mouse but it’s like this:

  • “Windows” key, search for “Touchpad” and [ENTER] on the settings’ touchpad page (you can [TAB] around, but not needed)
  • use [TAB] key to cycle down to the “touchpad on / off” line’s “toggle” GUI (10 [TAB] presses)
  • return to toggle it
  • [ALT-SPACE] to get the app’s menu, and 9x[TAB] to get to the “close” menu entry, then [ENTER]

Yeah… that’s why I’d like to assigne a key-press to this :wink:

1 Like

Cycling the behaviour of an external monitor/projector. The behaviour of of your Ubunty system seems to be expected.

Expected. You should be able to reassign keyboard shortcuts in system settings.

The Windows key is always the “Super” (or sometimes “Meta”) key on Linux.

For the keys, the answers above are correct.

Really appreciate this!

For me, this wasn’t immediately nor intuitively obvious - so for anyone else who wants to
convert the [F12]/ “Audio media” button (the “Framework” image) - for Ubuntu 22.04, this is readable, and clear (and easy to add as shell aliases too):

  • Touchpad On: ( I used “Audio media” button)
    gsettings set org.gnome.desktop.peripherals.touchpad send-events enabled

  • Touchpad Off: (I used “Shift+Audio media” button)
    gsettings set org.gnome.desktop.peripherals.touchpad send-events disabled

Unfortunately (I tried both logging off after changing custom keyboard shortcuts, and powering-down / powering back up): the “Audio media [F12/Framework-graphic]” key…
EDIT: this was operator error on my part. See reply, below.

…digging into this more…

I’ve edited this, to get rid of my “noise” - I must have made a command typo in the long command-line in Keyboard Shortcuts. Instead, this seems to work:

In settings > Keyboard > Keyboard Shortcuts:

  • [Shift+Audio media] set to disable touchpad … seems to work,
  • [Ctrl+Audio media] set to enable touchpad … works (I must have had a command typo), as does [Audio media], [Alt+Audio media]… anything else I’ve tried to date.

Interestingly, gsettings range... shows three settings for touchpad send-events:


Given that, here’s what I’ve done for a shell / bash function (alias):

# handy to add to your .bash_aliases

touchpad-status() {
	echo "touchpad: $(gsettings get $TOUCHPAD send-events)"
touchpad-or-mouse() {
	gsettings set $TOUCHPAD send-events disabled-on-external-mouse
toggle-touchpad() {
	if [[ "$(gsettings get $TOUCHPAD send-events)" != "'enabled'" ]]; then
		gsettings set $TOUCHPAD send-events enabled
		gsettings set $TOUCHPAD send-events disabled

1 Like

Update (bug report):

I am glad I made the shell-functions (above) - because today (and this is the first time I experienced this - in the past 5 days, I had not noticed this) the custom keyboard Frame-work-Gear key (called [Audio media] in the settings panel) ceased functioning, and worse: the touchpad spontaneously (“as if” in external-mouse mode, with a mouse connected) stopped working. Pulling up a shell, and re-enabling the touchpad resulted in the “Audio media” key pulling up … the factory-default “Audio media” panel… Checking the assigned custom key settings, it was still set to what I’d set it to, that is the command in the shell script … gsettings .... send-events enabled – it just didn’t have function.

This started with very delayed mouse action (when enabled), on the order of ~1-second from touchpad motion action, to actual cursor response… Using the keyboard, I powered down, and rebooted. Function appeared normal in response, but the custom key assignment of [Audio key] in settings continues to not be acted on. Notably, the other custom key assignment ([SHIFT-Audio key]) which I assigned to turn off touchpad function continues to be followed.

UPDATE: The following day, assigned [Audio key] function is again properly working. I also noticed a firmware update available from Ubuntu (firmware-sof-signed/jammy-updates,jammy-updates 2.0-1ubuntu4.2 all [upgradable from: 2.0-1ubuntu4.1]), but it is currently held-back (too new to install everywhere?).