[RESOLVED] Gentoo on FW16

Edit: I’ve created a FW16 page on the Gentoo wiki. I’ve tested just about everything except the dGPU, but that should work fine with the same drivers that the iGPU uses.

I’m in batch 4 so I should be getting my FW16 by the end of the month. Is anyone who’s received their FW16 installing Gentoo? There’s a gentoo wiki page for the FW13, but I don’t see anything about the 16 on there.


I’d imagine its the same/similar process. You won’t install the FW13 BIOS or fingerprint reader firmware obviously. You also won’t want to configure the kernel for Intel hardware obviously, but beyond that, its the typical Gentoo process and everything should be work fine.

Framework16 batch one here.

I’ve got gentoo with wayland/wayfire/waybar setup.

Im still in the finishing details to customize my desktop stuff and candy like that, but the underlying system seems stable and great except two issues i have come across.

One is that the wifi card doesnt seem to register with wpa_supplicant on a cold boot. It works ok on reatart. It says no interfaces found, but i think its some kind of race condition because i see the wireless interface after i login on console.

The second is that the keyboard was causing a kernel panic ever so rarely. I have re-seated the keyboard and so far no issues there. Im hoping it was me badly installing the hardware.

The third isn’t really a framework issue, but it would be very nice to be able to use all open source software and not need the redostributable binary firmware for the wifi card. I think the only deal there would be to hope framwork offers a different wifi card or swap it out myself if feeling adventerous.

Fourth there seem to be some minor settings that need to be configured correctly in the kernel but customizing the kernel is lhase two for me. For now just getting userspace the way i want it.

Overall gentoo is very strong on the framework16. Of course it requires research and patience… but thats linux for you. Haha

Ive given myself a challenge. My normal desktop is a debian/systemd/xorg and for the framework16 im going for gentoo/openRC/wayland. Its quite a bit of a headshift but gentoo use flags are clearing lots of dependency hell.

Ill proabbly end up putting this config in a repo once its happy. Id be thrilled to get a nice baselne together with the community


I’m also intending to install Gentoo when my later batch 16 shows up.

Posting here to follow.

I created a mostly placeholder page for the 16: Framework Laptop 16 - Gentoo wiki. I also moved the expansion cards to their own page since both models use the same cards.

1 Like

Glad to hear at least one person’s got it going. I dipped my toe in with the AMD FW13 motherboard (bare to the air, screwed to my wall on a 3D-printed bracket, my daily driver on Gentoo since September 2023), and haven’t had any major issues thus far – though I am still tweaking and optimizing. I’m way out in batch 14 for the FW16 (as a complete, actually-integrated laptop) though, so it’ll be a while yet before I’ve got my hooks seriously into it.

I’d have been really surprised if no one had gotten it to work (unless of course the reason was no one tried) given how Linux-friendly Framework is. But getting everything to work (all the various bits of hardware) can be a game of whack-a-mole.

1 Like

As an ex-gentoo-er, getting the FW16 to work on Gentoo should be easy.
(I am currently running fedora39 kde on my FW16 as I needed a new pc as by chance my old machine died on the same day. Maybe it was jealous?)

The CPU/GPU/Keyboard/Touchpad/Audio/Webcam use common interfaces, and should just work, the fingerprint reader is a new thing for me, so I don’t know, but it looks to be the same chipset as what’s in the 13, so the directions from that would probably work fine.

Some config I would guess:

  • The touchpad requires i2c, so ensure your kernel is built with i2c for AMD.
  • The keyboards are all just USB2 HID devices, so, bog standard stuff.
  • The input modules seem standard USB3.2/USB4 devices. You’d just need to ensure you have thunderbolt and full USB-C stack installed, then I suspect it will just work.
  • Ensure you use power-profiles-daemon 0.20 (which is installed by default if you use a desktop profile, so should just work again)
  • Suspend is s2idle only, so ignore s3-deep-sleep.
  • Speakers/Microphone is standard HD-Audio, so should just work. Please set the audio mode to “Linux” in the BIOS.
  • Webcam is a standard UVC one, so ensure that uvc module is available.
  • You would need to set some udev rules to use the keyboard customizer. (the same in Fedora/Ubuntu in any case) [RESPONDED] QMK keyboard setup not working under Linux?

Um… That’s about it?


Arch user here, I’m considering setting up a Gentoo install to explore on my FW 16. I’m curious if any prior-arch users here would be willing to chime in with their experience on Gentoo and what made them leave/stay.

Gentoo was fabulous. I actually was a part of a team for an offshoot of Gentoo, Sabayon. Sabayon was basically Gentoo backward compatible but with binary packages. We also worked directly with the Gentoo folks and reported upstream issues. I used Gentoo for years, but I got tired of having to build a system for a week to get it spun up.

I loved the Gentoo method because it wasn’t splitting hairs like debian to “save 5Kb”. Xorg wasn’t 40 packages with dependencies on 40 packages. If I download the source it was like 2 packages, but other package management systems split the hairs into crazy amounts of packages and god forbid you needed to find the broken one to repair the system. Creating ebuild scripts was simple enough and Gentoo worked very well, but having multiple systems I managed… Gentoo was a PAIN. Which is why I jumped on Sabayon. Basically it was a prebuilt Gentoo system that also had binary package management and the Gentoo portage tree was treated like Arch’s AUR repo. You could use it, but if you broke something, it was on you. Lots of freedom and stability.

Sabayon ended up undergoing some massive changes when Gentoo made some breaking changes. Sabayon evolved into Mocaccino. It was cool, but it no longer had the same amount of freedom in pulling from the Gentoo portage tree. The new package manager luet is SLICK! But with changing package managers, a lot of starting over begins and that includes limitations of options. The project is still alive and its cool, but many of my systems run Manjaro for the freedom of the AUR repo and the simplicity of a prebuilt system I can manage on multiple machines. I understand there are risks in breaking systems when so much freedom is involved, but it kind of bites to no longer have that freedom because a package manager limits that. I need packages for some of my systems that are non-standard non-basic. Not everyone needs NDI plugins in OBS and Blackmagic capture card drivers and software. So, i was forced to switch to Manjaro in an sense.

So Gentoo and Arch are amazing and powerful, but I wouldn’t want to build multiple systems at various places and manage them all with that. 2 personal machines, no problem. Multiple churches, family members machines, my own machines, my kids machines… No thanks. Manjaro keeps the power of Arch at my fingertips, while also keeping the noobs in the reasonably safe rolling release walled garden LOL.


Thanks for your input :slight_smile:
Yeah, I wouldn’t dream of using a system like that for mass deployment. I’m only interested in it for the context my my personal laptop. My server rack and gaming desktop run Mint and Windows respectively.

Gentoo is high maintenance. My friend who got me into Gentoo used it pretty much exclusively for years (more than a decade IIRC) but he’s since switched to Arch because he got tired of the maintenance burden. Personally the compile times aren’t a big deal for me, but I also have a powerful PC. I have a desktop running Gentoo, and I’m going to put Gentoo on my FW16. That’s it. I ran Gentoo on a home server once - I’ll never do that again.

You really need to update once a month or at least every other month. Otherwise you get into scenarios where you have to debug package dependencies. Most Gentoo packages are updated regularly and they generally only keep two, maybe three stable versions and anything older is removed. So if you’re using a frequently updated package like KDE Plasma, going too long between updates can cause serious headaches.

Personally, I manually configure the kernel and I have a custom initramfs. I’ve been doing that for years and it’s second nature at this point. genkernel is a thing and is supposed to be easy but I have no clue if that’s “easy for a noob” or “easy for an experienced Linux hacker” since I’ve never used it. The Gentoo Handbook is solid, but it’s a far cry from a one-and-done wizard like Ubuntu and friends. But I think Arch is the same?

If you’re feeling like installing and maintaining Arch isn’t enough of a challenge, try Gentoo. If any of the above sounds awful, maybe don’t. Getting Gentoo working is an experience and helps you understand Linux, especially if you make your own kernel and initramfs, but it can be challenging depending on your experience and maintaining it is its own challenge.

1 Like

I am planning on encrypting the drive on my FW16 - I don’t bother on my PC since it never leaves the house. My goal is to use the fingerprint sensor to decrypt the decryption key (with a password as a backup), and if that works it would be happening in the initramfs environment. I’ll post my config if I get it working.


Yeah, I’ve reached out on other channels as well and it’s sounding more and more like I should give it a try and only then will I know for sure if it’s a good fit. A lot of the pros interest me, and the con’s (for the moment) don’t seem like a big deal.

Arch is similar with updates, but from what I’ve seen so far a month is far too long to avoid updating on there. What I haven’t made sense of yet is why this behavior exists. Besides the occasional certificate/key that needs updating, I’m not sure what could be different in the update process that can break.

Here’s what happens on Gentoo:

  • I’m running KDE Plasma 5.1.2.
  • Plasma is now on 5.6.7.
  • It’s been so long since I updated that 5.1.2 has been removed from the package repository.
  • There’s some conflict, e.g some dependency changed or some old package finally got updated to Python 3.
  • When emerge tries to resolve the conflict, it can’t because 5.1.2 no longer exists in the package repository so it’s a total unknown to emerge.

At one point I had to manually download and restore an old snapshot of the package repository, the one right before my version of Plasma had been removed, and update to some intermediate version, then re-sync to the newest snapshot and update to the newest version. That was painful.

I honestly don’t remember the specifics of this kind of conflict. It’s never been one I actually cared about, it’s just some dependency of a dependency of a dependency. And I’ve never had a dependency resolution issue so bad that I actually remember the details. So I have to hand-wave the actual issues that occur.

Ah ok, that makes sense. Yeah, I’m not looking for a high fidelity failure analysis, what you’ve described is good enough to provide some clarity for me. Thanks :-).
It didn’t occur to me that the repositories and upstream itself could be changing that much.

I haven’t paid enough attention to know if other packages are like this, but currently the only stable version of plasma is 5.27.11, and there’s only one other version listed (6.0.2). Looking at the history, they remove the old version about once a month. 5.27.10 was dropped 2 hours ago and 5.27.11 was only marked stable a day ago and added a week ago.

I would like to counter that when I was using Arch, things just kept on breaking. When I went back to Gentoo, things was much more stable.
Biggest issue with Gentoo was that you will become a linux expert, and you really really really must upgrade your entire system at least every month. They don’t leave things around for very long.

Best thing about Gentoo is that you can mix & match “stable” and “testing” packages easily.
e.g. Stable system, but use latest Kernel/KDE packages. And because you’re busy helping upstream debug a gpu driver issue, you’re running git Mesa + custom patches.
And when you do a system upgrade, it keeps things that way.

I have a very soft spot for Gentoo, but yes, managing multiple machines on it, or if the machines are underpowered, doing gentoo updates is a pain.

You can do odd/interesting things quite easily: I had a remote cross-compile setup so that I could build packages for the one Atom netbook.

  1. It was too slow and had to little RAM to build things on it
  2. It really benefitted from having things compiled for the gen1 Atom cores, as those were fully in-order.
  3. I could only build the features that were useful for said slow netbook.

It was significantly more usable, but alas, that really was just an experiment to see how far I could push that underpowered thing.

(excuse my random tirade, sorry)

I can’t speak to the stability of Arch as I’ve never used it for more than a recovery system.

I will say I recommend against testing/non-stable packages. The more of those you have the less stable Gentoo is. If you know how to handle drivers, Gentoo is extremely stable if you update regularly and never unmask anything.

I’m happy to say I started installing Gentoo late last night. Unfortunately, I spent an hour troubleshooting why my ssd over usb was having I/O issues/crashes during large transfers before I decided to simply remove my internal Arch ssd and put the Gentoo drive in.

I installed Arch originally as a learning experience. I learned a lot through it… but not as much as I wanted. I’d like to be competent enough to contribute patches upstream, and from what I’ve seen Gentoo might make that easier.

1 Like