Gentoo Wiki guide

I’ve begun a Framework Laptop page on the Gentoo wiki to help with installation. I’m currently focused on kernel configuration since that’s what gave me the most grief, so much of the page it is still dummy text from the template.
I encourage you to contribute if you have some insights; I definitely don’t have everything figured out. For example, I don’t know how to build for the more recent Framework models with the Tempo audio codec, and I have no idea at all how to get the fingerprint reader to work.


Whoops!! we killed it! lol



I don’t have either my Framework yet nor a Gentoo install atm, so I can’t actually check anything, but according to some preliminary research I did, the Tempo’s driver should be either the Intel HDA one (since the Tempo is an HDA comaptible device) or it should be labelled under a section called IDT. The official page says “Please note that you may need to search for IDT.”, but I haven’t seen a section called that before… but I’ve never looked for it either, so that makes sense.

Once mine arrives, one of the first things I’m going to try to do is install Gentoo on it, so if I remember I’ll update the wiki page with my findings!

1 Like

Oh man, I keep trying Gentoo and aborting after I get sick of compiling rust or something. The notes about the touchpad are super helpful! I could never get it to recognize on an OpenRC-based system (I tried both Gentoo and Alpine…).

IME I haven’t needed the i965 USE flag, but intel and iris worked.

It definitely works without it. I don’t actually know the full implications, but the Intel wiki page says to use those three for VIDEO_CARDS for 9th Gen and newer: intel - Gentoo Wiki

1 Like

Does anyone know how the HDMI expansion card works? I just got mine, and it worked immediately out of the box, but I haven’t been able to glean from the xorg, syslogs, or lsusb what in my configuration is making it work. Kernel driver? Xorg driver?

Awesome and Thank you! This guide was very helpful for me to figure out what kernel settings I needed! I am having some power/keyboard/mouse issues however and was wondering if any of you guys have experienced the same thing?

I would do dmesg -w and insert the HDMI adapter and watch what output is being displayed. It should show what driver is being loaded up etc. I would do it myself to get you the answer, but I’m at work haha.

I know this is long after this thread was started but If you are still using gentoo did you figure out how the hdmi card worked

This is the output I just got:

[  575.606353] usb 3-3: new full-speed USB device number 10 using xhci_hcd
[  575.824081] usb 3-3: New USB device found, idVendor=32ac, idProduct=0002, bcdDevice= 0.00
[  575.824091] usb 3-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  575.824093] usb 3-3: Product: HDMI Expansion Card
[  575.824095] usb 3-3: Manufacturer: Framework
[  575.824097] usb 3-3: SerialNumber: 11AD1D00C9D73E07320B0B00
[  575.835253] hid-generic 0003:32AC:0002.0003: hiddev96,hidraw1: USB HID v1.11 Device [Framework HDMI Expansion Card] on usb-0000:00:14.0-3/input1

I can’t say I ever did. The device appears to load successfully with the hid-generic driver, and the i915 driver even visibly comes into play when I connect a screen, but it always fails with one of these:

[81314.87292] i915 0000:00:02.0: [drm] *ERROR* Link Training Unsuccessful

Disappointing, but I haven’t needed HDMI output enough to devote serious time to debugging.

Interesting, I mostly get that when my dock and this veeery long active TB4 cable don’t want to play nice.

I don’t recall if this was the solution, but I think I edited the kernel parameters line in /etc/default/grub to read:

GRUB_CMDLINE_LINUX="[other stuff here] i915.enable_dp_mst=0"

and regenerated grub.

Sadly the Steam Deck has the same issue with this specific setup, and I haven’t gotten around to dealing with it.