[RESOLVED] Is it normal that my 12th-gen laptop has a v3.05 BIOS?

The silence on the matter is a little telling. @Matt_Hartley since this is going to impact Linux users, any chance of an update regarding LVFS, or at least if it will be available directly as a cab file for local install without having to use a WIndows related workaround?

Hey everyone, it’s been a very busy Monday, so I appreciate everyone’s patience. Looks like this thread was created 14 hours ago, so anytime there is a weekend (PST time) - it will take me bit to catch up to any future Sat and Sunday posts. :slight_smile:

When it comes to rolling back BIOS to 3.04, I would ask you to create a support ticket as tracking this would be very helpful. If it came with 3.05 from the factory, then it means it was tested working with this and unless there is a clear reason to change this, I’d keep it there. But if you’re seeing issues relating to the BIOS, please open a ticket so we can better assist.

While we continue to dial in our LVFS support, the above linked guide has a method for Linux users in the near-term.

Now the guide is still marked as 3.04. I expect this to reflect any upcoming changes from the appropriate team.

Which distro, Wayland vs Xorg and have you run xandar to see what the Framework “sees”? I can tell you that each of things can affects the outcome. Additionally, we can have you open a support ticket and gather logs to see what is failing where as well.

2 Likes

I’ve reached out the appropriate members of the team for a deeper understanding on what is happening between 3.04 and 3.05 - 3.05 is shipping on new 12th Gen systems. However, no customer facing updates have been issued as of yet - this is why we still have 3.04 on existing systems.

Based on our internal testing there is no advantage to rolling back to 3.04, it is doable.

6 Likes

What is the difference between 3.04 and 3.05?
Did something change in the settings too?

Usually it offers some minor changes for Windows or related.
Mine all run 3.04 as there was no need to do anything else at this time.

2 Likes

This was all I wanted to know. Pretty sure my (minor) problems are related to Windows 11 rather than the BIOS.

Thank you @Matt_Hartley for even helping us Windows users :slight_smile:

1 Like

Ah yes, that could be. And I would be of little help with Windows as the Linux Support Lead.

That said, it’s worth opening up a ticket as we do have folks who can help outside of the Linux space (Windows, BIOS).

1 Like

@Matt_Hartley
Hi Matt, thank you very much for looking into this!!

I submitted a ticket to Support on my specific problem, which is the one that led me to suspect a BIOS issue.

An other FrameWork user with the same Linux kernel, the same CPU, and the same TB dock, (but with BIOS v3.04), reported that it worked flawlessly (except a minor issue for the power on button).

Moreover I tried a USB key with a live Linux on my previous 11th-gen, and the dock works on it, and with the same live Linux key and the 12th-gen it doesn’t work, so an OS issue is unlikely, which is why I started to think about hardware issues.

I would like to try to downgrade to the BIOS v3.04 to see if it changes anything, but right now there is no file at all to download for BIOS v3.04.

Would it be possible to get such file?

I also asked the same to the Support person in contact with me yesterday, so I am expecting a reply any time soon.

Edit: Got a reply! I’m continuing this with the Support staff by email.

Good news!! Now it works.

So, I followed the advice from Support and I booted one of the Linux distros the most supported on the FrameWork: Ubuntu 22.04.

I just used dd to copy the official ubuntu-22.04.1-desktop-amd64.iso on a USB stick, booted that, plugged-in my TB dock… and the RGB keyboard connected to it lightened up!! So, it was working!

Then, the real surprise: I rebooted on my normal distro on the SSD (Artix Linux), with the dock still plugged in. And again it worked!

So now the issue is solved, for any purpose of using the laptop with the dock!

However I am quite sure that I had tried before to boot (Artix) with the TB dock plugged-in, so something must have happened, maybe a forced reinstall of some Intel thunderbolt firmware during the Ubuntu boot?

It is also possible (even if doubtful) that I had not tried to boot while the TB plugged-in.

Right now, the TB dock works, but if I unplug and replug it, it doesn’t work anymore.

So, don’t worry anymore folks, I think that the BIOS v3.05 had nothing to do with my issue!

3 Likes

@nadb
Although now I have the same Power Delivery problem as yours.
All the other functions of the dock (i.e. except PD) work, and if I boot while the TB eGPU plugged its PD works, while if both are plugged-in nothing is charging the battery…

It took me some time to get aware that the battery was not charging, literally the time for the battery to discharge while the TB dock was functional!

Edit: Nevermind, it works as intended on Ubuntu 22.04.

The problem above was on Artix. It is on me to solve it as it is a non-officially supported distro.

Let me know if you have any instability with that power delivery. I know mine was working for a while, and then stopped working again a day or two later.

1 Like

@nadb
I will!!!

By the way, may I ask what distro you are using?

@Mapleleaf I am on Fedora 37. It is my go to distro at this point been on it since Fedora 28 with no distrohopping.

1 Like

@nadb
Okay! Maybe if you had exactly the same issue on Fedora 36, you could open a Support ticket and they would help you diagnostize the situation.

On their compatibility grid they mention Fedora 36 as having an excellent support, but no mention of Fedora 37.

@Mapleleaf based on my experience with a variety of docks I would be extremely surprised if this is an OS level issue. Most of thunderbolt is firmware controlled. Hence the possibility it is BIOS related.

1 Like

@nadb
Yeah but what I mean is that they would actually investigate the issue, even in the BIOS if that’s the case, if you are using the Fedora 36.
Meanwhile if you are on Fedora 37 it’s likely they will tell you that it’s terra incognita for them…

@Mapleleaf Fedora 37 is the new stable version, hence it is supported. Some of the docs on the Framework site may not have been updated yet. Likewise Fedora 35 is EOL.

Regardless I have a ticket open for this, will see where it goes.

1 Like

@nadb
Good!!

Yes you’re right then, they would probably consider Fedora 37 as a supported version.

I can’t wait to see if you find a root cause!!

By the way, my daily driver is Artix, so I might take some time before confirming or not that I have the same issue as yours (the instability), which is actually very likely. But I will make an effort to use Ubuntu more, so that I could oberve it!

1 Like

Yep, 37 is where we’re focused right now.
https://guides.frame.work/Guide/Fedora+37+Installation+on+the+Framework+Laptop/108?lang=en

2 Likes

We are still waiting for the first 12th gen bios update. Not normal either :smiley:
More than a year after I received my laptop :frowning: