[RESOLVED] openSUSE on the Framework Laptop

About openSUSE

openSUSE is very popular in Europe, and is developed by SUSE LLC which also makes the enterprise version SLES. Therefore, it gets very good backing and support, and undergoes rigorous testing before each release. It has native BtrFS support, and native KDE Plasma support.

openSUSE comes in two main flavors:

  1. openSUSE LEAP which is the stable release on a 3-year release cycle, and is aiming towards full binary compatibility with SLES.
  2. openSUSE Tumbleweed, which is a rolling release that undergoes rigorous automated testing and makes use of BtrFS snapshots to help maintain stability.

I’ve been using openSUSE Tumbleweed on my Framework and there are a few things not working:

  • Fingerprint reader doesn’t work with KDE, which is the de-facto standard on openSUSE. Tumbleweed does have libfprint 2.2 and fprintd, but KDE/SDDM (their display manager) doesn’t support fingerprint auth. However, there has been some progress in supporting it: [kcms/users] Add fingerprint manager (!149) · Merge requests · Plasma / Plasma Desktop · GitLab and with the advent of the PinePhone fingerprint case back, there may be more interest in future support.
  • There are issues with Wayland and Xe graphics. I don’t know if the issues are with KWin (I will try KWinFT and report back if that changes anything), or with Xe support in general. LibreOffice specifically has broken scaling, and various apps have graphical artifacts and rough scrolling.
  • My Intel H10 combination SSD + Optane drive is not showing the Optane portion. This may not be openSUSE related specifically, but could be a firmware level problem. On other openSUSE systems, it shows as two drives (one is the flash, the other is Optane). My plan was to use the Optane as swap because I do lots of memory intensive tasks.

Were you able to get the fingerprint scanner to work inside of Tumbleweed on Gnome? I am trying and cant’ figure it out. I have installed and enable the proper packages. I am able to enroll a fingerprint, but when I go to lock my screen or reboot, GDM just spams “Sorry, that didn’t work. Please try again” even when my finger is not on the sensor.

I haven’t tried GNOME yet, unfortunately.

GNOME should work provided libfprint is >1.92. The version on tumbleweed is 1.92.1, so it should work. I wouldn’t be too optimistic on adding fingerprints to KDE since the PR has been stalled for a year.

In an “Ask me anything” on Reddit, KDE developer Nate Graham did comment on fingerprint support:


I’m frustrated by the lack of progress here for something so important, and I hope to put some work into it soon.

On the topic of Wayland scaling - for LibreOffice 7, making an entry for LibreOffice in /etc/profile.d/ with the following:

export SAL_FORCEDPI=192

resolved my scaling issues.

Has anyone had issues with “click-to-click” behaviour with the touchpad? I can only tap to click, not click to click.

That sounds like a desktop issue. Which desktop are you using? It’s working fine for me on KDE.

@ccgauvin94 I am also using KDE Plasma. 5.23.2

Greetings, does the intel Wireless card work without issues in Opensuse?

Yes, it’s working fine for me on Tumbleweed with kernel 5.14.14-2

aa:00.0 Network controller [0280]: Intel Corporation Wi-Fi 6 AX210/AX211/AX411 160MHz [8086:2725] (rev 1a)
    Subsystem: Intel Corporation Wi-Fi 6 AX210 160MHz [8086:0024]
    Flags: bus master, fast devsel, latency 0, IRQ 17, IOMMU group 18
    Memory at 7a200000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [c8] Power Management version 3
    Capabilities: [d0] MSI: Enable- Count=1/1 Maskable- 64bit+
    Capabilities: [40] Express Endpoint, MSI 00
    Capabilities: [80] MSI-X: Enable+ Count=16 Masked-
    Capabilities: [100] Advanced Error Reporting
    Capabilities: [14c] Latency Tolerance Reporting
    Capabilities: [154] L1 PM Substates
    Kernel driver in use: iwlwifi
    Kernel modules: iwlwifi
1 Like

Nice, It looks like I will give Tumbleweed a try. I would prefer Opensuse Leap but apparently the Kernel is too old to work with this Intel wireless device.

In the end I went for Opensuse Tumbleweed. I am very impressed had zero issues. I downloaded the wifi driver and everything worked like a charm. Tumbleweed is very slick and works great with the framework laptop

Does the Tumbleweed netinstall ISO include the Intel AX210 firmware, or will I need to install the system with a wired connection first?

Hello @CybeatB ,

I don’t think the netinstall includes the firmware. I installed leap initially with the full Offline ISO on my usb key, and that driver was not included.

I had to fetch the firmware and download it to my usb key after installation, and then copy it to the /lib/firmware/ directory. After a reboot wifi worked immediately I was able to see wifi connections.

The framework Laptop does not have an ethernet port to a USB key was needed for me.

I installed Tumbleweed and Wifi worked out of the box for me, no issues. Added context, I installed it with KDE Plasma, if you use a different Desktop Environment, your Wifi issues could vary.

1 Like

That should be unlikely as it’s kernel firmware, though some DEs may have issues with NetworkManager or wicked

1 Like

I was more thinking the extreme example of you decided to install Sway or i3, and those, being Tiling WIndow Managers, absolutely seem to require customization to be able to connect to Wifi.

I installed MicroOS (which is like 200 mb?) and it had the WiFi driver available during the installation.


KDE 5.24 has added a GUI interface for fprint, however there seems to be a bug with the device and I’d like some help confirming. Enrolling a fingerprint for a user works, however to use sudo one must set a fingerprint for the root user and this clobbers the record for any other user. I’m not sure where to go at this point.

You can fix this using sudoers: