[RESOLVED] USB-A Expansion Card stops working until unplugged

12gen Framework (3rd batch i7-1280p).

Today I noticed that USB 3-3 (bottom right when viewed from above) wasn’t working. Only until I unplugged and reinserted the card did it start to work. After some time, I tried again and it wasn’t working again. Again, after unplugging and reinserting the card did it start to work.

The same behavior is observed while sitting in the BIOS.

I tried a different USB-A expansion card in the same slot, and the problem seems to be unique to the slot, not the card itself.

1 Like

Hey, I have the same problem! I thought I was going nuts or that the USB key (my yubikey!) was going bad, but I have the exact same situation.

Are you running TLP or power savings tuning by any chance?

It could also be a regression from the 3.06 upgrade… see 12th Gen Intel Core BIOS 3.06 Beta where i’ll post a followup comment linking here…

Update: actually, that post explicitely mentions this problem, and a workaround

So I guess I’ll try that next!

So I have just tried two things:

  1. a reboot
  2. turning off the laptop for two minutes

I naively thought a reboot would be enough but no, the above is correct and you need an actual full two minutes off to have the USB-A device return to life. It is not really a workaround: it’s much simpler to just remove and re-insert the expansion cards (and that works reliably)…

1 Like

also, I suspect that does not matter at all: i’ve witness the problem on the top and bottom left of the laptop, and I suspect it would similarly happen on the right side as well.

I reported the issue as well in 12th Gen Intel Core BIOS 3.06 Beta - #68 by anarcat.

1 Like

Ah yeah it doesn’t matter, both sides behave the same actually.

@Matt_Hartley is this BIOS 3.06 regression on your radar? I mentioned it in the 3.06 beta thread but i suspect it was lost in the noise… It’s quite a regression, and the workaround (unplugging the USB-A card and plugging it back in) works, but it’s quite annoying…

We sure TLP is not installed? It will produce this behavior unless the right setting is blacklist or changed. Went through it with my USB devices. Fixed it pretty quickly. Let me know.

Setting aside the behavior in BIOS for a minute as that would be another team.

TLP is not installed.

1 Like

Same here, I don’t have TLP installed.

TLP is definitely installed here, I wasn’t aware that an extra hack was required after the upgraed, what is it?

For those who do not have TLP installed, please try different expansion slots and some A/B testing with the installed distro vs a Live distro. It’s annoying, but it provides to environments from which to test from.

@anarcat For TLP, I’ve used this setting successfully with some devices. Not using with USB-C expansion myself, but am using for DP and HDMI.

Took the screenshot using TLPUI since it is more visual than TLP’s config. I’d locate the USB ID and exclude it from TLP’s USB suspending. Worth a shot to see if this helps. Then reboot.

1 Like

thanks @Matt_Hartley ! as it turns out, using another USB-C port seems to have fixed the issue… And anyways, I have switched to a dock now, so the issue is less pressing (or, rather, changed radically), see:

1 Like

Doing some catching up, thanks for the heads up. :slight_smile:

1 Like

For what it’s worth, I have since then replaced my YubiKey and the problem doesn’t seem to occur anymore.

To anyone else having such issues, make sure you can’t reproduce the problem on another computer first! I haven’t actually tried that, but it does look like the newer YubiKey doesn’t suffer from those issues…

2 Likes

Glad this was solved with a new YubiKey.

1 Like

Hi, Framework 16, Batch 4. My USB A also stopped working and the easiest fix was to remove and re-insert it. I am kind of sad how many issues are occurring with the framework. It is much more involved to use and care for this brand than I anticipated. You’d think proprietary hardware would work much better and after so long.

I’ve a Framework 16 myself, batch 14 - and this happens to me almost daily. I’ve got USB A cards in slots 4 and 5 into which I plug the two plugs of an Alienware 410k keyboard, passing through an old dell laser mouse on the data plug. I frequently switch those two to a work machine for about 9 hours a day, then plug them back into the Framework only to find that one of the two is unresponsive - won’t even read a flash drive - until I flip the latch, pull out the card, and shove it back in. I do hope some patch is coming down the pipe to stop this behaviour.

1 Like

I have a 13 AMD - got the same issue. Happens on Windows 11.
And also got some error about “port reset failed”