12th Gen Intel Core BIOS 3.06 Beta

Just reporting in my experience. I ran into the same issue as @Khilseith and powered off. Like @2disbetter I lost USB-PD. However, plugging in a USB-A to USB-C cable worked fine and got me past the power adapter check since it doesn’t use USB-PD. Then the update went fine. Used a flash drive and the UEFI shell method.

2 Likes

I had some issues with lvfs update:

the 2nd device “UEFI ESRT device” did not update on several tries, I finally managed to get it to update properly by unplugging all expansion cards besides a single usb-c for power.

I reported the failures/successes via fwupdmgr report-history

Greetings
Klaas

1 Like

Not sure if it’s related but the USB-A card in my front right expansion card randomly dies. Nothing in dmesg. I have to pull the card our and reinsert it for devices to work again.

I’ve tried different cards, but the slot behaves the same.

Edit: Actually it seems to only be triggered when plugging in USB 3 devices. My USB2 devices can be unplugged, replugged, over and over without any issues. But when plugging in any of my USB 3 devices, the first insertion is usually fine, but if I unplug and replug a USB 3 device in, the USB A card dies and has to be physically reseated.

Actually it is both front left and front right slots (I have USB-C cards in the back left and back right slots, will try those next)

2 Likes

I have yet to make a summary of the idle power usage, but the standby results are up here:

4 Likes

So I am not sure what DP alt mode is here, but I can confirm a regression with the 3.06 beta upgrade that I have witnessed on my 12th gen laptop. The symptom is that a USB-A card stops working after suspend (deep or idle, Linux 6.0 on Debian bookworm). Unplugging the card and plugging it back in fixes the problem.

I am not the only one with this problem, first reported in USB-A Expansion Card stops working until unplugged. I am not sure it’s the same problem as the one describe in the original post here, because the post talks about Windows and a USB-C port, while I’m on Linux and, well, technically it’s both a USB-C port and a USB-A port (because it’s a USB-A card plugged in a USB-C port), but anyways, I figured it was worth mentioning the thread here.

I have tried the suggested method: shutting down the computer for two minutes and booting back up does bring the USB-A port, but that is a poor consolation as the problem, I suspect will just return later on (although I have yet to confirm that). It’s a much easier workaround to yank the card out and put it back in, that brings it back online reliably.

3 Likes

DisplayPort can be embedded in a USB signal, DP alt-mode refers to that.

2 Likes

Same problem, but now now of the usb-c ports work, so it doesnt detect the charger and will not continue. Theres no lights on the usb-c modules with the charger plugged in either side, completely dead.

@AMoonRabbit Did you try a non USB-PD charger? Like a USBC cable that terminates in USB-A? I had that same problem and non PD charged the laptop for me.

I saw the post above mine after I quoted the last one and just leaving it off and disconnected for some time cleared whatever it was as reconnecting everything then showed lights on the usb-c expansion port. I’ve managed to complete the bios update now, all stages complete so back up and running.

1 Like

Unfortunately still only getting 3 to 4 hours here on linux.

1 Like

Are you using TLP or anything like that?

1 Like

No, System76 say not to use TLP with Pop_OS! so I just have Auto-cpufreq and powertop. Though Powertop wasn’t actually applying anything at the time because it wasn’t set to run as a service.

1 Like

Calling @Matt_Hartley! This is definitely your area of expertise! This conversation should be moved to PM or another thread to avoid derailing this thread.

2 Likes

This is correct. Also worked for System76 previously. Their docs on Pop should be followed for Pop related stuff like system76-power vs tlp.

Bios should be set to defaults. system76-power is likely going to produce different results than highly configured tlp.

3 to 4 hours to me indicates attached items like displays or video viewing. If not, what is your brightness setting?

3 Likes

I keep brightness at 20-30%
image

Generally, the device is without connected peripherals bar the expansion slots. At this point I am using 2x USB-C in the rear slots, a HDMI expansion card, and a USB-A expansion. I did the BIOS update to 3.06 so hopefully HDMI card will be less power hungry in disconnected state. I haven’t played with the BIOS power settings other than setting a charge cap of 85%.

In terms of load, I’ve mostly been browsing and playing music, over bluetooth which will also skew battery life. I think when I was looking at powertop, idle consumption is around 9-11W.

Edited to answer screen brightness Q

3 Likes

I had to deal with the line 97 issue as well. Just to be safe, I rebooted two time the laptop before starting to use it normally

I’m having the same issue with the USB-A ports mentioned in this post.

I recently got my frame.work and updated the bios on the same day so I don’t know how it used to behave in v3.05. I have 2 USB-A cards, one with my webcam and the other connected to UGREEN USB 3.0 Switch Selector.
Happens only with the one connected to the USB hub, unplugging the card and putting it back in does the trick but I’m concerned if that could eventually damage my card or the motherboard itself.

2 Likes

I ran the bios installer for 3.06 on Windows, waited for the system to reboot, and in the end, the update didn’t take. System Information still shows it on 3.04. So, I tried to re-run the installer, and it just went super fast and rebooted. Still, System Information still shows 3.06.

Any ideas what I might be doing wrong?

In case anyone else experiences this… As mentioned above, you have to be connected to power to run this update. However, if you are not connected to power when you try to run it the first time, it reboots without telling you that it didn’t succeed. And then, re-running the MSI does not do anything, even if you are plugged in, unless you right click and run “repair install”. After that, the install worked just fine.

3 Likes