[RESOLVED] USB Ports Report Overcurrent and Cannot Recognize Any Connected Device

So just like the title says. I got the message from journalctl -rp3 and it says specifically
Nov 08 19:34:54 my-fw kernel: usb usb3-port6: over-current condition
Nov 08 19:34:54 my-fw kernel: usb usb3-port4: over-current condition
Nov 08 19:34:54 my-fw kernel: usb usb3-port3: over-current condition
Nov 08 19:34:54 my-fw kernel: usb usb3-port1: over-current condition
I tried to take out all the expansion cards, reboot, and the message is still there once it boots. I have also tried to boot from a USB device because maybe the driver is borked, but even the bios cannot recognize the usb device. So I think it’s a hardware issue.

Hardware-wise, I opened the chasis and lightly brushed the area around the ports on the inside, and blew on the ports themselves. That’s the best I could do with the knowledge and skills I have in this area.

Now the main problem is that I cannot use any device connected to the ports. Once I do that, it either completely ignores it or dmesg -w reports
[ 1262.943823] usb usb2-port2: attempt power cycle
[ 1271.380575] usb usb2-port2: unable to enumerate USB device
Notice how the actual port that is attempting the power cycle is not one of those that report an overcurrent. However, when I connect the camera, everything is alright and dmesg says
[ 1363.257849] usb 3-7: new high-speed USB device number 4 using xhci_hcd
[ 1363.426458] usb 3-7: New USB device found, idVendor=0bda,idProduct=5634, bcdDevice= 0.21
[ 1363.426469] usb 3-7: New USB device strings: Mfr=3, Product=1, SerialNumber=2
[ 1363.426473] usb 3-7: Product: Laptop Camera
[ 1363.426475] usb 3-7: Manufacturer: Generic
[ 1363.426478] usb 3-7: SerialNumber: 200901010001
[ 1364.102317] usb 3-7: Found UVC 1.00 device Laptop Camera (0bda:5634)
[ 1364.107148] usbcore: registered new interface driver uvcvideo

What can I do to further diagnose?

What board is it?

Things you could try are:

  • a cold boot - power off the machine, unplug power, let sit for two minutes, plug back in, and restart

  • Mainboard reset - if you have to remove the RTC battery be careful as the holder is extremely fragile. Follow the directions in the knowledgebase

  • Reset the BIOS to defaults

Good luck, hopefully one of the above steps resolves the issue for you.

1 Like

Sorry for the delay. I tried these steps but none of them seem to work. I still get the issue.

Just to be sure, setting the BIOS to the default means pressing f9 right?


In the body of your post, please include those following details.

  • Which OS (Operating System)?
  • Which release of your OS (Operating System / Windows 10, 11, Distribution of Linux)?
  • Which Framework laptop (11th, 12th or 13th generation Framework laptop) are you asking for support with?
  • If this is a Linux issue, please use the Linux tag or at least put Linux in the title.
  • If there is no information pertaining to your issue or question, please let us know here: Framework | Support Framework | Support

My bad.

OS: Manjaro Linux
Kernel: 6.4.16-5-MANJARO
Variant: 11th Gen Intel i5-1135G7

I don’t think this is linux specific since the BIOS also cannot detect USB storage devices.

No worries, just saves us a lot of time going back and forth as it allows me to match stuff. :slight_smile:

Please give this a try and report back.

I was able to test just leaving the computer unplugged (from the charger) and powered off for 2 minutes and it ended up working btw.

1 Like

OK, now this is incredibly weird. I remember before this happened, my RTC battery was toast the same as many others with the 11th gen intel boards. So I assumed that the RTC was not working at all and didn’t bother to remove the button battery. However, now that I actually did remove the button battery, the RTC is working with no issue. The PC is shut down, I checked that the battery that I removed is indeed the RTC battery, I left the laptop without it for 30 minutes and it still boots up without needing to connect the charger at all.

Then I tried to disconnect the proper laptop battery, left it for 5 minutes and it’s alright now. The message does not show anymore. I’ll update ASAP when I check if the RTC still works with the button battery not there.

Update: RTC stops a few minutes after shutdown like normal.

P.S. How do I mark this as resolved?

1 Like

Great to hear, marked as resolved.