[RESPONDED] AMD Framework : Portable Monitor won't work

Yes it’s a direct USB-C to USB-C connection to a USB-C Monitor

I am also seeing issues with the AMD Framework and USB-C portable monitors on 3.03.

I have the Asus 15.6" ZenScreen which works perfectly. It’s a single usb-c cord device.

However, I also have a UPERFECT 18.5 inch Portable Monitor which doesn’t work so well on USB-C.

The UPERFECT monitor has 2 USB-C ports allowing one of the two USB-C ports to be used for power if the input device is unable to fully power it alone.

Said monitor works with only a single cable on other laptops that can deliver power/input via USB-C. It also works with a Nintendo Switch if the monitor is powered via the extra USB-C port.

On the AMD Framework, however, it never works with a single cable on any port (powers monitor / gives no signal message / powers off monitor after a bit) and only works sometimes on the rear left port provided the monitor is powered already. It is finicky and requires the monitor to be powered by a dedicated power cable and then plugged into the Framework for video input with a second cable (like the Switch). Unfortunately, this works only 30% of the time and requires me to unplug everything and try again until it works—but when it works, it will work fine until unplugged.

It’s worth noting that the monitor does pass-through USB-C charging to the Framework so I only need 2 USB-C cables (one to power the monitor, and one from the monitor to the Framework) to power both devices (when it works).

Ideally, the Framework would power and provide input to the monitor on a single cable.

I’m having a similar issue on Intel 11th gen:

I don’t know if this helps at all, but with my issue, it seems that the monitor properly connects more often when it charges the laptop. If the laptop is above the charging threshold, the pass-through charging USB-C cable that also serves as the video input cable does not get detected on the Framework nearly as often.

This is affecting me as well. I’ve tried two portable monitors these past few weeks and neither of them would work with a single USB-C data/power connection.

However, when I connect an unpowered USBC hub to my framework and run 2 cables from that into the monitor, it will work fine. Since I am only powering the hub through the laptop, I think I can rule out insufficient power delivery from the USBC port.

Looking forward to whenever the next BIOS release will be which will hopefully address this.

Monitors I’ve tried:


Just chiming in that my Framework 13 AMD also seems problematic with USB-C portable monitors. I’ve tried 4 and only one briefly worked with a single cable, but it would only work for a bit before shutting off. I thought it was a problem w/ the monitor but now I’m wondering if it’s the Framework. Otherwise connecting to usb-c hubs that have hdmi/display port generally works well.

The latest one I got in (1 was from bestbuy marketplace and 2 were from aliexpress) worked yesterday, as long as I plugged in a power cord to the monitor first and then the framework, but today I can’t get it to work at all. These monitors all work flawlessly with a single usb c cable with the other devices I own (laptops and tablets and phones).

I noticed in one case I tried running two cables from my Framework, one USB-C for power and then HDMI for display, and that did work, so in a sense it seems like the framework CAN provide enough power, but for some reason doing both power and display is what’s faulty. I have tried various usb c cables that either came with the unit or some USB4 cables I purchased which should in theory support pd + dp. Would be thrilled if a bios update could fix it given my framework is the primary device I’m intending on using for travel w/ a monitor.

I also have this issue. Using the MNN portable 15.6" monitor I got off amazon. Single USB Type C cable works with my old laptop but when connecting to my AMD Framework, it powers the monitor up for a second but then displays no signal. This cable is USB 3.1 Gen 2. I saw someone in another thread say that a USB4 specified cable worked for them. Has anyone else confirmed if their cable is USB4 or not? Tempted to buy one to try.

I have a whole bunch of USB4 cables, same problems.

I had it working earlier today…no idea how. Can’t replicate it to save my life now.

Yeah it made no difference unfortunately.

Interesting observation I noticed today. I am powering my portable monitor with a USB-C to USB-C cable and 65 watt wall charger. Then I connected my laptop to the display with another USB-C to USB-C cable. The display works and is actually also charging the laptop.

So its like my portable monitor is passing power through to the laptop while simultaneously accepting the video signal on the same cable. Hadn’t seen a connection setup like this before.

1 Like

Hello! Same problem here.

But I tried to power the monitor with a non-Displayport USB-C cable, and use a HDMI at the same time, and it actually works! (EVICIV 17,3", supposed to consume 7w)
It’s still 2 cables instead of one, but at least it removes a power adapter :slight_smile:

@Matt_Hartley, any news about the investigations? :slight_smile:

For portable displays, no, I have one that pushes USB-C and am not seeing this issue, but it’s some oddball off-brand.

1 Like

And with 2 USB-C cables is works fine for me (one with DP, one without). Very dependant of the monitor, indeed!

I just found that my AMD FW13 has the same issue. In my case, it’s an ‘Arzopa S1’ portable monitor that will not work with only 1 cable.

Any chance there have been any updates regarding this issue?

I wonder if this requires a firmware update… and if so if Frameworks recent commitment to better supporting their devices with software/firmware updates gives me hope this could get addressed at some point. That would be awesome, it’s frustrating not being able to use my portable monitors as easily as I would like. I’m not sure if this issue is on Framework’s radar though and whether it’s prioritized at all…

Doesn’t seem like it… They put out new drivers/BIOS a few weeks ago and didn’t address it at all even though this thread was started back in November of 2023. Getting really frustrated with this issue along with all the other problems I’ve had with this laptop.

I just updated to the most recent BIOS (3.05) and accompanying driver bundle. Unfortunately, the issue still persists as described above.

@Matt_Hartley have there been any (internal) updates regarding this issue?

We test extensively against HDMI to HDMI expansion card and DP to DP expansion card. We do not test as heavily with USB-C displays. As indicated previously, best course of action is to make sure you are using the guides below:

FW 13 AMD, I’d test against slots 1 and 3.

FW 16, I’d test against slots 1 and 4.

After a bunch of testing it seems to be an odd issue with powering & displaying. If I plug in power to the display first via it’s other USB-C port, then plug it into the FW, the FW will send display signal to the monitor and the monitor will pass through power to the FW. If I disconnect the power from the monitor, the FW will power the display, but not send signal.

I can also connect any combination of ports using 2 USB-C ports from the FW and it seems like the external monitor just changes which port is providing power, no display output at all. I even tried powering monitor first with port 2 (no display output) and then connecting ports 1/3 for display.

I wonder if this is at all related (or just a coincidence) to the power negotiating oddities with connecting devices that can send and receive power. Connecting a current generation iPhone with USB-C using a C to C cable causes the phone and the FW to get stuck in a connection loop.


I am having this same issue, support is offering to take my laptop for diagnostics. Should I do that or just leave it for now and see if it fixes with updates?