[RESPONDED] AMD Framework : Portable Monitor won't work

Greetings all!
I have the (brilliant) AMD framework laptop and I couldn’t be happier with it … except my portable monitor isn’t working.
It’s an Ali Express purchased no-name brand 14-inch model with USB-C input for power and signal. The screen works perfectly fine with my Lenovo laptop, but only powers using the framework and states “no signal”.
I’ve tried swapping cables (USB-C on both ends), swapping ports on the laptop, Ubuntu and Windows, connected to wall outlets, nothing seems to work.
I’m on the latest 3.03 BIOS.

Appreciate any insights you could give.

Cheers,

Have you tried all ports on the laptop? The fron left won’t work, but the other ones (especially the ones towards the back (screen) should workl.

1 Like

Hi Jonathan, thanks for the suggestion. Yes I’ve tried top left, top right and bottom right ports.
I figured bottom left wouldn’t work so didn’t try that one.

Hrmm good to know it “should” work. Not sure what else I can try. I doubt I could find a firmware update for the monitor

okay so update. I plugged the screen into a phone charger for power, and into the laptop for signal (display has 2x usb inputs for this purpose) and it did register as a display. It works as expected.

I expect the laptop should be capable of powering the display. I tried it on my partners HP and again it works via single USB-C cable. So that’s two different laptops working on a single cable.

I tried using two usb cables from the framework, one for power and the other for signal and it won’t drive it.
Strange behaviour. I wonder why it’s not working

There have been some reports in the Forums that the USB ports on the Framework don’t provide as much power as other laptops and have a pretty sensitive over current protection. It’s also possible that the screen might not be completely USB-C compliant and may be e.g. trying to take the power before doing the proper negotiation with the laptop. The Framework provides up to 3A / 15W I believe, but it requires proper USB-PD negotiation before that happens.

2 Likes

Thanks Jonathan, sounds reasonable. The interesting thing about it is that the display does power on, states that there’s no signal, then turns itself off

It’s not the end of the world, I’ll most likely always use it with a powerbrick and since it provides power back through the USB-C, I’ll plug power to the monitor and have it feed the laptop.

Thanks again for your input.
Cheers

This is an area were actively working on. But at this time, your experience with this may be best left to see if we improve this with the next BIOS release.

2 Likes

Thanks Matt.
I’ve played around a little more and can confirm that if I plug USB-A into the power input of the monitor, then USB-C to display it does work. Note it doesn’t work using separate USB-C for power. All pointing to what you and Jonathan above describe.
Appreciate the response and am happy with my work-around.
I’ll circle back with my finding when the next BIOS revision is released.
Cheers
George

Appreciate you digging into this.

Sounds good, yes, let’s revisit this then for sure.

My Batch 10 13" AMD Framework arrived today and i have a similiar issue. I have both upper slots with USB-C and i currently can only attach a 4K144Hz Monitor over USB-C to the port on the right side. The left connects but doesn’t send a signal (on Windows 11 with newest drivers and BIOS).

EDIT: Now, after a reboot, both ports don’t work for display anymore

Is this a direct connection USB-C to USB-C? We actively test with HDMI and DP expansion cards as that is what our displays here at my home office use.

Yes it’s a direct USB-C to USB-C connection to a USB-C Monitor

I am also seeing issues with the AMD Framework and USB-C portable monitors on 3.03.

I have the Asus 15.6" ZenScreen which works perfectly. It’s a single usb-c cord device.

However, I also have a UPERFECT 18.5 inch Portable Monitor which doesn’t work so well on USB-C.

The UPERFECT monitor has 2 USB-C ports allowing one of the two USB-C ports to be used for power if the input device is unable to fully power it alone.

Said monitor works with only a single cable on other laptops that can deliver power/input via USB-C. It also works with a Nintendo Switch if the monitor is powered via the extra USB-C port.

On the AMD Framework, however, it never works with a single cable on any port (powers monitor / gives no signal message / powers off monitor after a bit) and only works sometimes on the rear left port provided the monitor is powered already. It is finicky and requires the monitor to be powered by a dedicated power cable and then plugged into the Framework for video input with a second cable (like the Switch). Unfortunately, this works only 30% of the time and requires me to unplug everything and try again until it works—but when it works, it will work fine until unplugged.

It’s worth noting that the monitor does pass-through USB-C charging to the Framework so I only need 2 USB-C cables (one to power the monitor, and one from the monitor to the Framework) to power both devices (when it works).

Ideally, the Framework would power and provide input to the monitor on a single cable.

I’m having a similar issue on Intel 11th gen:

I don’t know if this helps at all, but with my issue, it seems that the monitor properly connects more often when it charges the laptop. If the laptop is above the charging threshold, the pass-through charging USB-C cable that also serves as the video input cable does not get detected on the Framework nearly as often.

This is affecting me as well. I’ve tried two portable monitors these past few weeks and neither of them would work with a single USB-C data/power connection.

However, when I connect an unpowered USBC hub to my framework and run 2 cables from that into the monitor, it will work fine. Since I am only powering the hub through the laptop, I think I can rule out insufficient power delivery from the USBC port.

Looking forward to whenever the next BIOS release will be which will hopefully address this.

Monitors I’ve tried:

https://a.co/d/gPcEiL6
https://a.co/d/cvScrP7

Just chiming in that my Framework 13 AMD also seems problematic with USB-C portable monitors. I’ve tried 4 and only one briefly worked with a single cable, but it would only work for a bit before shutting off. I thought it was a problem w/ the monitor but now I’m wondering if it’s the Framework. Otherwise connecting to usb-c hubs that have hdmi/display port generally works well.

The latest one I got in (1 was from bestbuy marketplace and 2 were from aliexpress) worked yesterday, as long as I plugged in a power cord to the monitor first and then the framework, but today I can’t get it to work at all. These monitors all work flawlessly with a single usb c cable with the other devices I own (laptops and tablets and phones).

I noticed in one case I tried running two cables from my Framework, one USB-C for power and then HDMI for display, and that did work, so in a sense it seems like the framework CAN provide enough power, but for some reason doing both power and display is what’s faulty. I have tried various usb c cables that either came with the unit or some USB4 cables I purchased which should in theory support pd + dp. Would be thrilled if a bios update could fix it given my framework is the primary device I’m intending on using for travel w/ a monitor.

I also have this issue. Using the MNN portable 15.6" monitor I got off amazon. Single USB Type C cable works with my old laptop but when connecting to my AMD Framework, it powers the monitor up for a second but then displays no signal. This cable is USB 3.1 Gen 2. I saw someone in another thread say that a USB4 specified cable worked for them. Has anyone else confirmed if their cable is USB4 or not? Tempted to buy one to try.