[RESPONDED] AMD Framework : Portable Monitor won't work

Interesting observation I noticed today. I am powering my portable monitor with a USB-C to USB-C cable and 65 watt wall charger. Then I connected my laptop to the display with another USB-C to USB-C cable. The display works and is actually also charging the laptop.

So its like my portable monitor is passing power through to the laptop while simultaneously accepting the video signal on the same cable. Hadn’t seen a connection setup like this before.

1 Like

Hello! Same problem here.

But I tried to power the monitor with a non-Displayport USB-C cable, and use a HDMI at the same time, and it actually works! (EVICIV 17,3", supposed to consume 7w)
It’s still 2 cables instead of one, but at least it removes a power adapter :slight_smile:

@Matt_Hartley, any news about the investigations? :slight_smile:

For portable displays, no, I have one that pushes USB-C and am not seeing this issue, but it’s some oddball off-brand.

1 Like

And with 2 USB-C cables is works fine for me (one with DP, one without). Very dependant of the monitor, indeed!

I just found that my AMD FW13 has the same issue. In my case, it’s an ‘Arzopa S1’ portable monitor that will not work with only 1 cable.

Any chance there have been any updates regarding this issue?

I wonder if this requires a firmware update… and if so if Frameworks recent commitment to better supporting their devices with software/firmware updates gives me hope this could get addressed at some point. That would be awesome, it’s frustrating not being able to use my portable monitors as easily as I would like. I’m not sure if this issue is on Framework’s radar though and whether it’s prioritized at all…

Doesn’t seem like it… They put out new drivers/BIOS a few weeks ago and didn’t address it at all even though this thread was started back in November of 2023. Getting really frustrated with this issue along with all the other problems I’ve had with this laptop.

I just updated to the most recent BIOS (3.05) and accompanying driver bundle. Unfortunately, the issue still persists as described above.

@Matt_Hartley have there been any (internal) updates regarding this issue?

We test extensively against HDMI to HDMI expansion card and DP to DP expansion card. We do not test as heavily with USB-C displays. As indicated previously, best course of action is to make sure you are using the guides below:

FW 13 AMD, I’d test against slots 1 and 3.

FW 16, I’d test against slots 1 and 4.

After a bunch of testing it seems to be an odd issue with powering & displaying. If I plug in power to the display first via it’s other USB-C port, then plug it into the FW, the FW will send display signal to the monitor and the monitor will pass through power to the FW. If I disconnect the power from the monitor, the FW will power the display, but not send signal.

I can also connect any combination of ports using 2 USB-C ports from the FW and it seems like the external monitor just changes which port is providing power, no display output at all. I even tried powering monitor first with port 2 (no display output) and then connecting ports 1/3 for display.

I wonder if this is at all related (or just a coincidence) to the power negotiating oddities with connecting devices that can send and receive power. Connecting a current generation iPhone with USB-C using a C to C cable causes the phone and the FW to get stuck in a connection loop.