[RESPONDED] Battery life troubleshooting

I’m running Pop!_OS 22.04 and trying to figure out why my battery life isn’t very good.

The only apps I had open were Firefox and Terminal, and my screen at the lowest brightness.

❯ sudo tlp-stat -b
--- TLP 1.5.0 --------------------------------------------

+++ Battery Care
Plugin: generic
Supported features: none available

+++ Battery Status: BAT1
/sys/class/power_supply/BAT1/manufacturer                   = NVT
/sys/class/power_supply/BAT1/model_name                     = Framewo
/sys/class/power_supply/BAT1/cycle_count                    =     16
/sys/class/power_supply/BAT1/charge_full_design             =   3572 [mAh]
/sys/class/power_supply/BAT1/charge_full                    =   3195 [mAh]
/sys/class/power_supply/BAT1/charge_now                     =    404 [mAh]
/sys/class/power_supply/BAT1/current_now                    =    567 [mA]
/sys/class/power_supply/BAT1/status                         = Discharging

/sys/class/power_supply/BAT1/charge_control_start_threshold = (not available) 
/sys/class/power_supply/BAT1/charge_control_end_threshold   = (not available) 

Charge                                                      =   12.6 [%]
Capacity                                                    =   89.4 [%]

How can I figure out if there’s a background process causing this or what?

With a capacity of 89.5% i.e. a wear of 10.5% after only 16 cycles you may want to try a full discharge until power of, power on again after an hour and discharge. Then do a 100% to a) loosen up the battery ions and b) give the analysis tool a full range to measure.

Your graph is really vague.

It says it has Data Points for 6 hours, with a cell discharge from 95% approx to 12.6%.

So if you got 6 hours that is good. I have the same use, Firefox and screen on 7% most of the time and I’d be lucky to get 6 hours.

For details on how I worked in my early days when I had 7% wear see


I think my graph is misleading. For example this morning I have been using it for ~2.5 hours and the battery has dropped from 95% to ~25%

What are you running to generate the graph in your post?

Also, is there a way to see what applications or services are using the most power?

I’ll try depleting and recharging to see if that helps.

First off your graph shows two things,

  • A six hour set of data over half a window
  • If the window, not the data is six hours then you have 3 hours of use from what may be 95 to 25.

My graph is home made over repeated manual measurements using WHinfo on Windows or Power Statistics in Ubuntu 22.10 and so shows data over a long period. Most of the time I am using it with mains and am measuring battery wear a few times a day for the graph.

My graph doesn’t show Cell charge history, only Wear compared to Cycles

My Power Statistics has a more 'reasonable graph grid

@Travis If you’re running TLP on Pop OS, you’re going to be in for a bad time. It uses system76-power and it is not compatible with TLP. They may even cancel each other out. Uninstall it and reboot, try Battery Life setting from the Pop OS pull down menu on the right.

Once tlp is removed, rebooted, then:

…is correct and a good standard to use.


OK, TLP uninstalled, thanks for the tip!

I think powertop should be useful in trying to figure out if there is something else going on.

Hi @Matt_Hartley, can I confirm something here as I believe you have worked with Pop OS before. In the Battery Optimisation guides, we mask the existing power-daemons to make way for TLP. Can we not do the same for com.system76.powerdaemon.service?

I am experimenting with this myself, and setup TLP with the guide. Fully understand that I am on my own here but just looking for an answer as to whether it’s possible.

It may work, but, honestly for Pop OS, you’re going to best suited to use their power profile tool and service on Pop itself. It’s pretty deep into the distro and merely disabling the service on Pop is untested.