[RESPONDED] CPU frequency mostly stuck at 2.10 GHz

Hello there,

I’m currently using an Arch Linux installation on my Framework Laptop 13 with an i5-1240 Intel CPU.

My problem is that my CPU frequency is mostly stuck at 2.10 GHz.

I’ve already tried to set the CPU power governor to “powersave” in the background also runs a powertop-daemon that autotunes the system every time it boots.

Above that, I’ve set the BIOS option “Boot performance mode” to “Max Battery”, but this also doesn’t help.

Is there something I can do against it? I’ve read about people having a 400 MHz idle frequency with a 12th gen Intel CPU on other Linux distributions, but I don’t want to distro hop, because I’m very satisfied with my Arch Linux installation.

Best regards,

I have the same experience.

Maybe we could tune the base clock speed… let me read about it.

is power-profiles-daemon installed? If so, it’s probably that as I believe when it’s in power-save mode it turns off turbo-boosting for the CPU.

I’ve tried installing power-profiles-daemon and setting it to “Power Save”.

It’s a bit better, but not yet there where I want to be…

@Chris_J & @Anachron: Thank you, for your support

@Juuze sorry for confusing you. I believe that setting power-profiles-daemon to power-save mode will disable turbo-boost on the CPU which may cause it to max out at a low frequency like 2.1 GHz. tlp could also be doing this and any other power management tool installed could be doing this also. But, it can also be related to firmware or hardware. Anyway, without your machine in-front of me all I can do is just speculate :person_shrugging:

Hi Chris,

Best things to start with:

  • Stop/Disable TLP service in systemctl.
  • Do not run TLP and power-profiles-daemon (not sure if you are, but this will lead to issues)
1 Like

Doesn’t look like this was the reason :face_with_diagonal_mouth:

hi @Juuze ,

can we make sure that tlp service isn’t running? can we status?

sudo systemctl status tlp.service

Sure, here is my command line output:

[XXX@XXX ~]$ sudo systemctl status tlp.service
Place your right index finger on the fingerprint reader
Unit tlp.service could not be found.