[RESPONDED] Edges of touchpad not registering tap to click Fedora 35/6

Fresh installs of Fedora 35/6 gnome 41/42 have (for just me??) this region where mouse taps to click or movements are not working.

This would appear to be the regions meant for edge scrolling.

This can be most simply observed by trying a “tap to click” anywhere along the outer left or right edges of the touchpad. Cursor movements are also ignored if the touch starts from either of these regions however you can use these areas if you move into them.

I have tested in Windows 10 no issues but fresh installs of F35 and F36 exhibit this behaviour so I think this a software bug.

Does anyone have any ideas/advice I’m likely not the only one to have noticed :slight_smile:

Thank you

Have you installed any specific driver or done any custom settings for Fedora? I don’t own the Framework Laptop, but all my other laptops with Fedora Workstation (regardless of version) use two finger scrolling by default and no edge scrolling at all. I’m not even sure where you’ve disabled edge scrolling.

No customisations, this occurs on fresh installs of F35/6 at least with gnome. Edge scrolling is disabled and two finger scrolling is functioning as expected besides this behaviour.

Calling out to the Framework Fedora userbase, do any of your read me?


I’ve noticed the same behaviour: a movement starting from the edges inward doesn’t register, from the center towards the edges does (all the way to the edge).
I’m running up-to-date F36, no special drivers. My touchpad.conf has this:

Section "InputClass"
	Identifier "touchpad"
	#MatchProduct "PIXA3854:00 093A:0274 Touchpad"
	MatchIsTouchpad "on"
	Driver "libinput"
	Option "ClickMethod" "clickfinger"
	Option "Tapping" "true"
	Option "NaturalScrolling" "true"
	Option "TappingDragLock" "true"

Hi thanks for the reply, that sounds exactly the same.

I’m using libinput too (Gnome+Wayland) but have no idea how to fix the issue… I’m still quite new to Linux.

I’m thinking to try KDE and the old synaptic driver.

So I actually think this has been covered before and turned out to be palm rejection zones in libinput. Touchpad Deadzones in Linux

They linked this Palm detection — libinput 1.21.0 documentation.

It states that movement from these red zones would be ignored unless it is fast movement. “A” represents slow (ignored) and “B” fast (accepted). I confirmed fast movement does indeed work where slow movement doesn’t.

From what I understand tap-to-clicks are meant to work in the brighter red areas where “D” is but not above “C”. however this doesn’t seem to be working, tap-to-clicks are ignored in light and dark regions. Is this a libinput bug that should be reported?

I’m not aware of any user configurable options outside of the what is exposed in the settings GUI and for gnome DE specifically “gnome tweaks”. So no other way to configure these setting? Happy to be educated.

I also found an ambitious project that could use more attention Sponsor @gitclear on GitHub Sponsors · GitHub

"Since 2018, GitClear CEO/Developer Bill Harding has been hatching plans to improve the satisfaction experienced by users of Linux touchpads. Bill’s odyssey began in 2018 with the blog post “Linux touchpad like a Macbook: Goal worth pursuing?” continued with “Linux touchpad like a Macbook: progress and a call for help” and most recently, “Linux touchpad like a Macbook Pro, May 2020 update.”

1 Like

I assume you haven’t found anything extra on this? Just found this issue myself and would love to be able to tap-to-click on the edges of the touchpad

Looks like that is how libinput works, but I wonder if you guys would settle for ps2 mouse emulation of the touchpad? it will loose palm rejection, but I think all areas of the touchpad is usable.

1 Like