[RESPONDED] Framework and PopOS

Thank you. Before I try this, can you tell me how to undo it if it doesn’t work right? Thanks!

1 Like

If it doesn’t seem to work, you can try using the argument -m with -m 0.2 as an example. Here’s a complete argument example with this alternative:
syndaemon -i 1 -m 0.2 -K -t

If that still doesn’t work, here’s how to undo/remove:

Easiest way:
Remove the entry from POP!_OS autostart list and reboot

Harder way:
Remove the entry from POP!_OS autostart list and execute killall syndaemon

3 Likes

Thank you very much!!!

I experience this as well. While I don’t have a direct solution for you, I’m investigating several layers of the stack and reported my current findings here: Subpar touchpad - #25 by Duane_Johnson

2 Likes

Thanks Duane! I will keep an eye on your progress.

Since this is the main thread for Pop_OS!, I thought I might add a link to a script I wrote to get the finger print reader working.

Script

Apologies if this is not allow.

8 Likes

Thanks a ton - I also was not getting results, and copying the mem_sleep inquiry you listed showed mine was also still in s2idle. Copying the command you listed to change the default to [deep] seems to have done the trick. Will be taking note of battery level tonight when I close the laptop to see how it does compared to last night.

Thanks again!

1 Like

Anyone else having this issue? Any fixes? Not system-breaking just pretty annoying.

Hey,
My laptop running PopOS does not want to display on second monitor, connected thru USB C docking station. I used before the same docking station (and monitor), same PopOS version and DisplayLink drivers (same exact ver) and it worked fine on my 11yo laptop with USC A to C adapter… If I use HDMI - works fine. Docking station HDMI - nope. Technically it is the same “architecture” of connection, but it does not work.
Docking station is HP (USB A/C in the name) with DisplayLink 4k.

BTW. Every other function works just fine - High speed USB, charging, and Eth. PopOS even was able to find an update to internal firmware…

1 Like

Have you messed with the HiPDI/LoDPI settings at all?
On a second/external monitor?

Can someone help please. Not really good at Linux, but installed POP os and I’ve liked it. But the latest upgrade didn’t load properly. This is the message I get…

The following packages have unmet dependencies:
network-manager: Depends: libnm0 (= 1.30.0-1ubuntu3) but 1.32.12-0ubuntu1 is installed
Breaks: ppp (>= 2.4.7-3~) but 2.4.9-1+1ubuntu1 is installed
network-manager-pptp: Depends: ppp (< 2.4.7-3~) but 2.4.9-1+1ubuntu1 is installed

This may help:

The commands would be:
sudo apt-get install -f network-manager
and
sudo apt-get install -f network-manager-pptp

I am running pop 21.10, this is the info from running apt list -qq network-manager network-manager-pptp:
network-manager-pptp/impish,now 1.2.8-3build1 amd64 [installed,automatic]
network-manager/impish,now 1.32.12-0ubuntu1 amd64 [installed,automatic]

For what it’s worth, I personally I didn’t find the TearFree option to fix the tearing issue I was experiencing. I ended up having to disable fractional scaling in Settings->Display in order to get the tearing to stop.

I’m running PopOS 21.10 impish and 5.15.8-76051508-generic

@apnea oh gee I never expected a reply, I am about 50 distro hops away from that at this point haha. The issue on popos for me seemed to be hardware acceleration at first. Then switching to wayland helped immensely. I think it was just older versions of Firefox being more finicky even with the Arch wiki’s suggestions. Then at the same time after a couple of reinstalls the problems just went away even on xorg so I am just really confused about how the whole thing happened.

1 Like

6 hours ago my laptop was at 70% battery, woke up today and it wouldn’t turn on without the adapter plugged in. 1% battery.

when I cat mem_power it shows [s2idle] deep.

Aside from hopping to a different distro I’m not sure what to do.

My solution was to set it up to use suspend-then-hibernate. I have it configured to switch to hibernate after 15 or 30 minutes of suspend. I don’t mind it taking a little bit longer to come bask as the battery drain is only a percent or two. I also have sleep set to deep vs s2idle.

@lbkNhubert Can you explain how you did that?

@DAE - certainly. My setup is a little complicated as I have it set up to multiboot, with btrfs and full disk encryption. Essentially you will need to make sure that your swap partition is larger than the ram on your machine. For hibernation setup, I followed these guides, with some modifications:

To default to deep sleep, run sudo kernelstub -a “mem_sleep_default=deep” in the terminal.

Let me know if you run into any issues, I’ll be happy to help if I can. It’s working very well for me.

2 Likes

@lbkNhubert Thank you!!! I much appreciate it.

Any update on the finger print reader and out of the box optimizations for the battery?

1 Like