[RESPONDED] Framework and PopOS

Hey all, I’m just starting a topic for things I’m learning as I run PopOS 21.04 on my Framework.

You’re gonna need to disable secure boot. Until you do the default installer image will give you a kernel signature error. Do that by spamming F2 during power up and then disabling SecureBoot entirely in Bios

My Framework is defaulting to S2Idle which is burning through battery like crazy during sleep. you can enable deep sleep by adding a kernel boot option in


Just add


At the end of the options line. Waking up from sleep will take a little bit longer, but you won’t be chewing up battery while you rest.

Screen tearing when scrolling
Nothing new here, Linux and Intel video loves to tear when you scroll or watch youtube etc. Fix it by creating


and inside of that file put

Section "Device"
  Identifier "Intel Graphics"
  Driver "intel"
  Option "TearFree" "true"

Auto screen dimming, wifi, bluetooth all work out of the box. Fingerprint scanner isn’t recognized but I hear a rumor that a guide is coming soon.


Have you tried the mesa driver? That’s the recommendation I usually see for Intel.

1 Like

Not yet. just plowing through stuff at the moment but I’ll give that a try.

err edit, it’s installed by default evidently on Pop.

1 Like

I was curious to test out PopOS when I get mine. If you don’t mind me asking, who will be providing the guide to install it on the Framework laptop?

@Scratch glad to hear it mostly works out of the box, and thanks for giving instructions for folks who want to use PopOS!

For fingerprint, support is in libfprint 1.92.0 and newer. We haven’t gotten a chance to write a guide on compiling it from source, but I suspect that is something you know how to do!


@zmk5 The fine folks at Framework are producing a guide, but as @nrp said I imagine it comes down to removing 1.90, compiling 1.92 and then doing a PAM update. I’ll probably give it a go later on today.

Well the good news is I got the fingerprint reader working on PopOS, the bad news is that while it works I’m not able to log into my machine with password or fingerprint now in X. CLI still works fine for password. I used 1.92.1 which shouldn’t have any regressions against 1.92.0, but I’m gonna nuke the machine and start over to see. I’m gonna hold posting what I did until I get this sorted.

Update: I tried from scratch and while I can get the fingerprint reader to work and register to my user, when I am taken out to the main login screen password no longer works and the fingerprint reader acts like it’s constantly in use. I’ll try again another day.


Curious if the screen tearing is an issue when running a Wayland session?


@Scratch I had the same issue with deep sleep on Ubuntu 21.04, what kind of battery drain when sleeping are you seeing now?

@jeshikat I’ll need to run a test tonight and see for sure, but I would expect around 15% per day. deep sleep is awesome but it’s not hibernation.

Speaking of hibernation, does anyone know if it works well on the Framework laptop?

I’ve seen conflicting opinions on deep sleep…but glad that @Scratch seems to have gotten it to work (Pop is my preferred distro as well).

I need one or the other to work reliably in order for this laptop to be feasible for me!

@steve Hibernate has been flakey at best. Deep sleep seems to be working well, but sleep to hibernate or straight to hibernate has resulted in a few frozen machines for me in both Pop and Fedora.

1 Like

@Scratch do you have any syslogs or other logging from the Fedora freezes? We have folks at Fedora we’re working with who have a Framework Laptop currently, and we can see if they can determine what is happening.


@nrp I’ve been rebuilding the OS a lot as I experiment and didn’t capture logs, but it’s fairly reproducible so I’ll grab them next round. messages, dmesg, ps and any core drops I assume?


Yes, that would be great. Thanks for all the experiments and feedback!


Another happy Pop!_OS 21.04 user reporting in – the only piece I’m still waiting on is the fingerprint reader, mainly to see if anyone figures out a smoother path forward with it before embarking.

1 Like

I was noticing high power use when in sleep, even after making changes suggested by @Scratch I ran the following command:
cat /sys/power/mem_sleep
I appeared to be in s2idle, I then ran the following command:
sudo kernelstub -a "mem_sleep_default=deep"
and then after a restart I appear to be in deep sleep. I am not a linux or popOs expert, I will let you guys know how it works out.


With Pop!OS I’m getting MUCH better performance when I use Wayland instead of X. In order to try Wayland, you need to edit /etc/gdm3/custom.conf and comment out the line that says WaylandEnable=false. After rebooting, you will be able to click a gear icon after selecting your user that will let you select a Wayland session instead.

For some reason, fractional scaling will not be available under Wayland until you run this command:

gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']"

I had a small issue with the window tiling feature- There was an invisible window called “gjs” (?) that was being tiled. I was able to add this window as an exclusion and now tiling works correctly.

@2disbetter I see no tearing at all on Wayland.


It’s funny- I was about to ask if you’ve sent a Framework to the developers of PopOS so they can ensure compatibility…and then I remember it’s System76, a laptop seller. LOL


I’ve posted around the forum with battery life being my main concern. Right now I’m pretty torn between the System76 Lemur Pro and the Framework.

Pop_OS! is the way I’d prefer to go (maybe Fedora) but I’m curious if anyone has feedback on real world battery performance excluding the idle power drain. Basically, assuming moderate use, do you have to plug in after 5 hours?

And I’m not assuming great out of the box performance, just thinking best case scenario.