[RESPONDED] Headphone jack intermittent noise?

For Windows, I would open a ticket.

Spoke to the hardware team, this is a known issue with the Tempo codec described here. It’s been something we have been working to solve and found the best approach is to use the new audio expansion card instead.

While it can be minimized to a degree, it’s not really a great experience and we are recommending the expansion card for those needing crystal clear audio (which I get and it does sound great). Not an ideal solution out of the box, but it’s what we have to offer with the Tempo codec being the contributing force here.

3 Likes

Wow has the time flown by! I just wanted to chime in and say that, since posting, I changed OS to Manjaro and started using Pipewire. I haven’t had the static issue with the headphone jack in a long time. This is confusing as the best explanation here seems to be hardware related. I don’t know if the changes I made to my OS made a difference or not but wanted to post here in case it was useful to anyone else.

If this consistently appears to be resolved, there may have been an issue with the release of Pipewire in Pop and Manjaro may have had a patch or newer release, difficult to say without comparing it against Fedora for example.

1 Like

I too am having audio issues. I hear a pop when I plug in my headphones, and when audio stops playing I also hear a pop. While audio plays, there is a consistent static sound that I can hear through my headphones.

I’m on Linux with pipewire/wireplumber, and the issue occurs regardless of if I am connected to AC or not, or if I have anything (besides headphones) plugged in.

I’ve been dealing with this problem for over a year now, so any kind of fix would be amazing.

I tried some of the earlier suggestions in this thread such as the lua script for wireplumber, local config in /etc/modprobe.d, etc. but nothing seems to have worked so far.

Which distro and which release?

Just a heads up folks, Tempo DAC, which is the only DAC ever used on Intel Core 12th Gen and later. This can create some odd behavior with noise, clicking, etc. The why it happened this was can be found here in this article: Framework | Solving for Silicon Shortages

Two best options for those on Intel Core 12th Gen and later are:

Arch Linux

Appreciate it. If your board is Intel Core 12th or 13th gen, this applies:

If it’s an AMD board however:

I’m on an 11th gen Intel board

$ grep -m1 'model name' /proc/cpuinfo
model name	: 11th Gen Intel(R) Core(TM) i5-1135G7 @ 2.40GHz

Just confirmed, 11th Gen manufactured after August 2021 to 13th Gen all used Tempo.

If you want to use the audio jack over USB or Bluetooth/wireless, the the audio expansion card would be the best bet.

Now, it is likely possible to try and fight with it by tweaking allowed rates, default rate, etc. But I’d need more information on which distro and release.

On Fedora for example, we could try disabling power saving. Will it help? Probably not, but it’s worth a try. Just changes a 1 to a 0.

sudo echo 0 | sudo tee /sys/module/snd_hda_intel/parameters/power_save

If this worked, you can make this survive reboot:

echo "options snd_hda_intel power_save=0" | sudo tee /etc/modprobe.d/snd_hda_intel.conf

But this again, may not help.

That would be nice seeing as I don’t actually have wireless/bluetooth/USB headphones, only the 3.5 mm ones for my phone.

I also can’t get a audio expansion card unless I buy a laptop is what the site tells me. Show me how to put a second battery in the back and I’ll get one with a Framework 16 :wink:

I did try writing 0 to the power_save file, but alas, no effect. (Also that first sudo is redundant :P)

Well I’m on Arch, just the latest stuff of everything as is the Arch way I suppose. uname -r gives me 6.5.9-arch2-1.

Appreciate the details. At this stage, the best bet will fall onto this:

This is due to the use of Tempo and it not being ideal for 3.5mm usage in some situations.

1 Like

@Matt_Hartley does this issue exist when upgrading to the AMD board?

I upgraded mine, and had the same issues that I was having with my Gen 11 still persist, i.e. headphone jack almost not usable because of static. (using Fedora 39) … I switched back to the Gen 11 board because I had all kinds of weird display issues that some others have experienced, but will test again if and when I swap back.

@Matt_Hartley I tested Ubuntu 22.04.3, Fedora 38, NixOS 23.05 on my gen 12 Framework.
Got the same headphone jack intermittent noise on all 3 distros, making the audio jack unusable.
Can the audio expansion card solve this problem ?

Yes, it provides a better overall audio experience.

Thank you !
Do you think replacing the audio board would resolve the audio issue or it is unrelated ?
I am planning to buy the audio expansion card but since it takes one expansion slot, i would prefer to replace
the audio board instead Framework | Audio Board Kit

I’d recommend the expansion card.

1 Like

Is it possible to fix this on a later mainboard revision?
I’m hard pressed to find a laptop with worse noise isolation (even my X200 has a better built in jack!)

I’m completely fine with using a dongle, but it would definitely be a nice sell if a future mainboard had better signalling for audio.

Sure, they’ve already replaced the audio chip once (and back), however the signal on the mainboard is likely always noisier than a separate assembly outside of the main computer, as there are a lot of different signals on the mainboard, which can disturb an audio signal or add noise. You can obviously add shields or route the audio signals only close to the edge (as my computer mainboard does), but there are obviously space constraints inside laptops.