[RESPONDED] How do I enable "Run with dedicated GPU" to automatically run with certain apps?

I am running LMDE 6, and it is working well. However, to use my browser, I have to select “Run with dedicated GPU” for it to run properly. How do I automatically enable this function so I won’t have to select it every time I use my browser?

We do not test against LMDE. That said, assuming everything from kernel age to other libraries match what we have with our Ubuntu 22.04.4 (OEM D kernel) and Fedora 39 recommendations, you would enable hardware acceleration within the browser settings. But that will enable iGPU.

We recommend the dGPU using stuff like Steam games. Running DRI_PRIME with the browser is not recommended and will likely lead to artifacting.