[RESPONDED] Need help fixing HDMI audio issues on Linux

Disclaimer: I have no idea whether this is an issue with the framework, the TV, the OS, or configuration. For no particular reason, I decided to ask here first.


I am having trouble consistently getting audio out via HDMI to my TV and it has me stumped. By consistently I mean that I seem to get audio working on rare occasions, maybe every 1/10 boots.

What has me stumped is that I have tried several things to diagnose the issue and I still can’t tell whether it comes from the framework, TV, OS, or configuration. Here’s a short list of the things I have tried and there results in parenthesis:

  1. Changed HDMI cable (No change)
  2. Factory Reset the TV (No change)
  3. Plugged the Framework into a different HDMI device (Audio worked)
  4. Plugged a different HDMI device into the TV (Audio worked)

(3) and (4) are what confuse me the most. (3) tells me that the issue is likely the TV or the audio configuration within the TV or Framework. On the other hand (4) tells me that the issue is with the Framework or the configuration. Knowing that (2) resulted in no change, this leads me to believe that the issue is likely the audio configuration on the Framework…

However, I have no idea what the issue could possibly be on what should be a fairly simple configuration in pipewire/pulse. I’ve even disconnected the audio board for now to make things even easier.

I’ve made a short video to help visualize what my issue is (which you can find it here). It is split into two parts, with the first being a video I recorded with my phone and a second an OBS capture. Each was made in roughly the same time frame.

Notice how I get TV sounds but no actual audio coming from the framework in the phone video? Notice how I do get audio from the framework in the OBS capture?

Details about my setup:

  • 1st gen Framework (in Coolermaster case)
  • NixOS 23.05
  • Pipewire (with pipewire-pulse)
  • Sony Bravia XBR-65X900F


Hi @smkuehnhold , welcome back to the forums.

By the way have you first latest Ubuntu or Fedora and see if you’re having the same issue with your HDMI?


1 Like


Just got back to this, so apologies for the delay. Thanks for the response!

To answer your question, I hadn’t tried booting into a supported distro until now (woops). So to rectify that, I just booted into a Ubuntu 22.04 live cd.

Interestingly enough it seems I have the same problem (no hdmi audio), but it manifests in a different way. It seems like on Ubuntu (at least in the live CD), the HDMI is not even detected as an audio sink? In settings I can only select analog out.

On NixOS, the HDMI sink always appears, but rarely actually produces audio.


Hi @smkuehnhold,
sometimes it helped to switch to “Pro Audio” in the configuration tab, when I had no audio output. If you try this, go back to the Playback tab. Now you should get several choices named something like “Pro Audio”, “Pro Audio 3” etc. One of them might send audio to your TV.

1 Like

Sorry. Are you referring to the TV or the Framework? I’m not sure what you mean by “Pro Audio”


I meant the configuration tab of pavucontrol (PulseAudio volume control).


Interesting possible fix @Viandant , Let us know if that is showing on your pavcontrol @smkuehnhold


So I am able to setup Pro Audio, and the multiple sinks do show up as @Viandant describes, but I still don’t get any sound out my TV after selecting any of them :frowning:.