HDMI over Framework dongle not working?

Ubuntu 20.04.4 LTS

Framework official HDMI port isn’t showing up with my old(er) TV. The cable works, and the HDMI card shows in lsusb so I don’t think it’s hardware, but I don’t know what drivers I need.

I’ve tried plugging into the top-right (under the power button / fingerprint sensor) and the bottom left (under the CapsLock key) so it isn’t ports.

Is it trying to drive the TV at a resolution the TV doesn’t support?

It isn’t driving the TV at all - lsusb picks up the HDMI dongle, but xrandr never picks up the HDMI signal attempts by the TV. It’s a 1080p compatible panel so I would think the TV could handle whatever the Framework is trying to hand out (unless it’s trying to hand out the weird not-quite-1440p 4:3 that is the native on the monitor).

So through my eGPU duplication causes scaling to occur on my 1080p TV. So it is possible that Ubuntu is choking on how to scale, etc. What you could try just to see, is set your Framework resolution to 1080p, and then see if you have the same issue.

Not very scientific I know, but perhaps it’ll shed some light.

I seem to have fixed it by running this script:

Which, among other things, updated the kernel from the old 5.4.somethingsomething to 5.13, which if I had to guess is the change that fixed the issue with the HDMI dongle.

1 Like