[RESPONDED] Notification at login: An important OS update has been installed ... will not go away

This is a low-stakes question but I’m hoping someone less noob than me might have an idea or two. I’m running Ubuntu 23.10 on a 12th gen core i5 FW 13. After what I think was a firmware update, I get the message “An important OS update has been installed” on every log in.

Clicking on the notification brings me to an app called “Updates” which lists UEFI-dbx update 371. If I click on that for more details I get a window that says “Downloading change information …” that, well, never downloads any information.

Everything in the OS appears to be working properly. I’ve not had any crashes or problems and it’s been like this for months at this point. My guess is that whatever process is supposed to flag this notification as “read” is just not doing its job.

Has anybody who uses Ubuntu encountered anything similar? Again, this is very low stakes - it’s only a very mild annoyance. But as a newer Linux user I would love a chance to learn more about what’s going on here.

Welcome to the community!

Sounds like you have an update via LVFS.

In a terminal run the following. We’re not going to update anything, I just want to see what your output is.

fwupdmgr refresh --force


fwupdmgr get-updates

I suspect it is in this ballbark. But don’t do anything until we see the output of the above commands first.

Sure thing! And thanks in advance for helping here.

Here’s the output from the first command:

Updating lvfs
Downloading…             [   -                                   ]
Successfully downloaded new metadata: 1 local device supported

And the second:

Devices with no available firmware updates: 
 • Fingerprint Sensor
 • System Firmware
 • UEFI Device Firmware
 • UEFI Device Firmware
 • WDS500G1X0E-00AFY0
Devices with the latest available firmware version:
 • UEFI dbx
Devices that have been updated successfully:
 • UEFI dbx (217 → 371)
Uploading firmware reports helps hardware vendors to quickly identify failing and successful updates on real devices.
Upload report now? (Requires internet connection) [Y|n]: Y
Target:                  https://fwupd.org/lvfs/firmware/report
Payload:                 {
                           "ReportVersion" : 2,
                           "MachineId" : "d679bf7f14f96b69f5a155c83b7a49fe0c2446cd54b73daf739cce35b6f03a62",
                           "Metadata" : {
                             "DistroId" : "ubuntu",
                             "DistroVersion" : "23.10"
                           "Reports" : [
                               "Checksum" : "bc6a604b29918d67d5fef745ad4375ca3d43d05e",
                               "ReleaseId" : null,
                               "Protocol" : "org.uefi.dbx",
                               "UpdateState" : 2,
                               "Guid" : [
                               "Plugin" : "uefi_dbx",
                               "VersionOld" : "217",
                               "VersionNew" : "371",
                               "Flags" : 149534122443043,
                               "Created" : 1699307602,
                               "Modified" : 1699307625,
                               "Metadata" : {
                                 "HostEnclosureKind" : "a",
                                 "HostSku" : "FRANDACP04",
                                 "DistroVersion" : "23.10",
                                 "RuntimeVersion(org.freedesktop.fwupd)" : "1.9.5",
                                 "RuntimeVersion(org.kernel)" : "6.5.0-10-generic",
                                 "UEFIUXCapsule" : "Enabled",
                                 "CpuArchitecture" : "x86_64",
                                 "SecureBoot" : "Enabled",
                                 "HostFamily" : "13in Laptop",
                                 "HostBiosVersion" : "3.05",
                                 "HostVendor" : "Framework",
                                 "RuntimeVersion(org.freedesktop.gusb)" : "0.4.5",
                                 "KernelName" : "Linux",
                                 "DistroPrettyName" : "Ubuntu 23.10",
                                 "RuntimeVersion(com.dell.libsmbios)" : "2.4",
                                 "DistroName" : "Ubuntu",
                                 "FwupdSupported" : "True",
                                 "KernelVersion" : "6.5.0-10-generic",
                                 "CompileVersion(org.freedesktop.gusb)" : "0.4.5",
                                 "HostFirmwareMajorRelease" : "ff",
                                 "HostProduct" : "Laptop (12th Gen Intel Core)",
                                 "BootTime" : "1699307554",
                                 "RuntimeVersion(org.freedesktop.fwupd-efi)" : "1.4",
                                 "CpuModel" : "Intel 12th Gen Intel Core™ i5-1240P",
                                 "HostBaseboardManufacturer" : "Framework",
                                 "HostBiosMajorRelease" : "03",
                                 "HostBiosVendor" : "INSYDE Corp.",
                                 "CompileVersion(com.hughsie.libjcat)" : "0.1.9",
                                 "CompileVersion(com.hughsie.libxmlb)" : "0.3.10",
                                 "EfivarNvramUsed" : "67923",
                                 "HostBaseboardProduct" : "FRANMACP04",
                                 "DistroId" : "ubuntu",
                                 "HostFirmwareMinorRelease" : "ff",
                                 "CompileVersion(org.freedesktop.fwupd)" : "1.9.5",
                                 "HostBiosMinorRelease" : "05"
Proceed with upload? [Y|n]: Y
Successfully uploaded 1 report
Do you want to upload reports automatically for future updates? [y|N]: N
No updates available

EDIT: Also, checking on that link you provided, if it helps I’m not dual-booting - only Ubuntu is installed.

At this point, it is worth making sure everything is current. So we’d run:

fwupdmgr update --force

You likely are already good to go, but, this will hopefully resolve it without getting into messing with efi territory.

Yup - got the same result. Everything is up to date, but the notification shows up at every login. I’m pretty well convinced at this point this isn’t an issue with the firmware or with the updates themselves. I think the only thing that’s actually going wrong is that the notification isn’t being marked as “read.”

I’ve had the same issue on Fedora 39 Workstation for several months now with version 317 of UEFI dbx (according to fwupd). For me it shows up as recently updated in GNOME Software whenever I update anything. What I also find interesting is that the date of when I last updated is stuck at the one of UEFI dbx (I last updated today).

I also tried running the suggested fwupdmgr commands with no significant improvements.

At this stage as I am not able to repro it here, I’d file a bug report with Fedora so they can look into it. They are very friendly about new bug reports, just use the provided template.