[RESPONDED] Preparing for Void Linux

Hi Everyone,
I’m interested in using Void Linux on the Framework 16, using KDE Plasma.

The Void Linux community is pretty small, and Void isn’t as easy to get into as Ubuntu or Fedora.

I was wondering if people had scripts for installing the distro.
I want to see what other people have done, and how, and tweak it to my Framework, I want to have full disk encryption which might add another headache.

What other scripts have people made for preparing there desktops for a new install.

I use Manjaro with KDE on my desktop, and I want to learn how to automate my usual installs, and know if there are any void hickups I might run into, when using it with the framework hardware.

Phoenix LandPirate

1 Like

Have a look at voidvault, haven’t used it personally but seems to do FDE.


Thank you, I’m taking a look at it now :slight_smile:

HI @PhoenixLandPirate,

Like the VOID community, our Linux team here is very small. So we have not had a chance to test VOID on any of the Framework laptops due. This is why we have specific Linux distros listed on the Linux page.

On a personal note, VOID is awesome (I heart their init system) and we want folks to run the distro they want to use. But I want to make sure you understand that because VOID and other non-tested distros are, untested, there may be some tweaks and things you will want to coordinate with the community.


Hi @Matt_Hartley,

Lovely to hear from you, I used to listen to you when you were on Jupiter broadcasting.

I’m aware of the fact that Ubuntu and Fedora are the ones that are supported, if I have to many issues I’ll try and see how kinonite will go, thats based on Fedora.

How much of the work that goes into getting Ubuntu and Fedora running well on Linux? Does a lot of it go upstream? I guess part of the issue might be that since VOID’s community is small, might mean it might take a bit longer to get those patches, but if it works well enough, but just needs a few things tweaking for wifi, or having to edit a config file for the trackpad, then I think VOID would be lovely to experiment with on the FrameWork!

Thank you,


Just for clarity, I am running the 12th gen Framework Laptop 13 on Void Linux for 8 months and barely any issues remain.

In fact I’d say they are negletable and nothing to worry about.

I will eventually get to make a new post, but there is quite a bit more testing I have to do as I switched to wayland and modified my configs quite a bit since my original statement.

I would say that unless your NVME is faulty Void is a perfect fit to run on your Framework.

If you need any help setting it up, dont forget to visit our IRC channel on libera.


Fantastic clarification @Anachron, appreciate it!

@PhoenixLandPirate it’s been my experience when Anachron indicates something works well, they’re spot on. So you should be good.

Appreciate it! :slight_smile:

Be sure to add this to your to test out list if looking into Kinonite.

Jorge’s project is really, really shaping up nicely.

Fedora specifically is likely pushing stuff upstream, but because of the components we select for Framework laptops, Linux as a whole just does well for the most part. Tweaks are usually kernel parameters used for little snippets that crop up from time to time.


Any ides how to get the installer to launch on an amd framework 13? It fails every attempt.

@Adorno I think the latest void iso is from july and might not have the drivers necessary.

I had secure boot enabled. That was my bad. Once disabled it worked flawlessly.

1 Like

Very cool, is that with the iso from summer? Please let me know how well its working for you!

1 Like

Update: Crashed three times this morning. Unsure what the deal is. I’m still on 3.0.2 for firmware, computer refuses to update to 3.0.3; at this time I’m not too miffed, but it seems outputting scaled video may have something to do with it. Will report more if resolved/relevant.

@PhoenixLandPirate tl;dr if you use void now, you’ll love how it just works on here, if you want me to test something specific just give me a holler.

I wanted to give this a couple weeks before I responded so I could give a better answer than just “good.” And aside from Void the only other Linux I run is Solus and Solus had issues on here and I dislike the init so I’m glad Void is happy here.

It is working well, incredibly stable. Running the stock XFCE4 setup that comes with the installer now. Some things I had to do to get the laptop doing what I wanted it to included adjusting touchpad scrolling, dropping the scaling to .6, and adding bluetooth for that one time I used a bluetooth keyboard. All in all, it’s very happy.

Occasionally, I ask it to do a minor task and the entire laptop crashes the GUI. Not sure why. When this happens it brings me back to the login page. I log in and 90% of what I’m working on is up still. This happens most when I run games that I should not be running on a laptop.

Updates, wifi, things of that nature just work, so you don’t have a lot of back and forth. If you’ve been using XBPS/Void/Runit already, you will appreciate that the new AMD platform plays nice with it. My only complaints hardware wise is my hand sits a little too close to the touchpad and I occasionally tap elsewhere when trying to type so I had to set the disable timer to .8 seconds to not annoy me. Also, I have 64gb RAM and the power management seems to hate me. Hibernation works, but it seems to drain barely any less battery than the regular sleep. I am unable to close the laptop and leave it unplugged all night as I will wake up and have a dead laptop. Having to remember to power it off isn’t too annoying, as I previously had a MacBook from work running Void and if the screen locked it would brick the machine so I had to remember to power it off every night.

This probably isn’t as helpful as I’d like, I’m not the kind of user that does fancy things. If there’s anything specific you’d like me to touch I’d be open to trying it. I’ll stop here, a bit verbose.

1 Like

I’ve seen a few people have issues with white screens on the FW 13, depending on the distro, if the computer has been idling to long, or plugged into an external monitor, have you had any issue with those, are the crashes still happening given the time it’s had to mature and if you had to fix any of those issues yourself, how did you do so?


Sorry for not updating.

“White screen due to idling/external monitor?”
Yes, these things still happen. The problem is once they happen the remedy typically takes me a solid 15 minutes to correct by adjusting settings, rebooting, and flipping back and forth between battery and charging power. I can’t give you any more details than that, I’ve been avoiding external monitors which is okay, I have a different computer I use for docked work. Well, “computer” as in I use a Steam Deck for my day to day work at a desk, the laptop floats more.

“Are the crashes still happening?”
No, actually, I haven’t had a crash in over a month now. Not sure what is different there. But I did get the BIO’s updated and have been keeping the system updated regularly ( pretty much daily).