@Michael_Wu You are demonstrating true grit here! :slight_smile:



Chiming in to say that the replacement mainboard has seemed to fix all my weird USB issues, so it may indeed be a hardware issue.

Took a while as the second replacement mainboard was also damaged upon arrival (bent heatsink/board, yikes!) but support sent out another replacement shortly after (next day IIRC). The third replacement arrived undamaged and worked.

Also, the new one came with the Tempo audio chip (my previous was Realtek). It worked out of the box in Linux (Fedora), but I couldn’t get it to work in Windows until I found and uninstalled conflicting Realtek software, then re-installed the Framework driver bundle.

I’d say overall incredible support, so if anyone from the team is reading this, thanks again and please keep it up!


That’s great news!

I probably won’t replace my mainboard since I have an easy workaround, although maybe I should because the same issue could be responsible for the 1TB Expansion Disconnect problem. And it could also be a warranty issue?

Oddly enough, even though I love Framework’s mission of empowering users to repair and modify their laptops, I myself am completely inept at this sort of thing and the 34-step replacement guide looks very intimidating to me!

Ah, I could’ve tested with my prior mainboard and 1TB SSD (in a 3rd party enclosure) plugged into the quirky USB port, too late though :grimacing:

From what I can recall, I used to have my 1TB SSD plugged into a non-issue port seeding files for an extended period (~a few days), and I don’t think it ever disconnected when it shouldn’t have (in Fedora Linux, not sure about Windows).

I’d say if it works perfectly in some USB ports and not others, it might be a hardware issue.

I have a suspicion that the faulty port I was plugging my monitor into (power, data, USB, etc.) would “crash” causing my laptop to freeze, because those random freezes no longer occur with the new mainboard. That could’ve been fixed from a Linux kernel update though.

As for replacing the mainboard – it was much easier than I anticipated, though I do have a lot of prior experience building desktops and tweaking laptops – so my view may be warped. But it’s basically just unplugging connectors and ribbon cables (which are definitely fragile and it’s good to be overly cautious, but really not that frightening). Then replugging/screwing everything back in. The mainboard only has 5 screws to hold it in place. Once I got the process down, it took like 5 minutes total.

I hope you/y’all get your issue(s) resolved!


One more piece of info… I just discovered that when my Framework reboots, if I have the USB drive plugged in and recognized, then it stays accessible after the reboot. However, if it’s plugged in and not accessible (i.e. I didn’t do the halfway plugin trick before fully plugging it in), then it’s still inaccessible after reboot. Finally, if it’s accessible, and then I shutdown the computer, it becomes inaccessible when the computer boots up again.

Even though this particular quirky USB port problem wasn’t bothering me too much since I had the workaround, I started experiencing more and more problems with my 1 TB storage expansion card disconnecting almost every day.

After some back and forth with Framework support (including opening the laptop and sending them some pictures), they decided I needed to replace the mainboard. They quickly sent me a replacement (which I installed mostly myself, with a little moral support and supervision from a friend), and now I can plug my USB drives normally. No halfway trickery needed!

Many thanks to Framework support! You guys are great!


The problem has returned for me. At least the workaround still works.

I’m just wondering if this oddity is related to the problem of external USB drives randomly disconnecting, which is my real problem. Just today, for instance, I was in the middle of backing up my computer when the USB drive disconnected. This has happened a couple of times, though this morning it happened in a non-quirky port. (And in fact, I switched to the quirky port and the backup succeeded).

Just to clarify, both my 1 TB expansion card and a different USB drive disconnect randomly. The 1 TB disconnect problem is well known and discussed at length in another thread. However, I don’t think there’s a problem with the 1 TB drive itself. I think it’s related to some more fundamental USB port problem.

I think I know why the flaky behavior and disconnects are happening though I don’t know how to fix it. The problem has to do with USB 2 vs USB 3 connections.

When an external drive negotiates a USB 3 connection, it uses more power.
USBDeview reports 896 mA for a USB 3.0 connection vs 300 mA for a USB 2.0 connection with my 2 TB Seagate drive.

When I plug in the drive in halfway, it negotiates a USB 2.0 speed connection which uses less power. This connection is very stable for me.

When I plug the drive in all the way to begin with, there’s not always enough power to get the 3.0 connection to work so the drive doesn’t appear. However sometimes there is enough power so the drive appears, but the 3.0 connection is less stable on my Framework and can disconnect.

This is the same with my 1 TB expansion card drive which disconnects often. I eventually started experimenting by connecting the 1 TB drive via a USB-C male-to-female adapter connected to a USB-C to USB-C cable into a USB-C slot in the Framework. I noticed that using a charging USB-C cable with only USB 2.0 data speeds would stay solidly connected. However, when I used a USB 3.2 speed cable to connect it, I would have disconnect problems. This is, in fact, what led me to figure out this important difference in connection types and stability.

Now if anybody can tell me why this should cause problems and how to fix it, that would be the final piece of the puzzle. Shouldn’t the Framework be able to handle these power requirements. Say 900 mA per USB port?


Unless you show us some kernel logs (dmesg on linux, Event Viewer on Windows) there is quite less we can do to help you here.

When I plug the drive in all the way to begin with, there’s not always enough power to get the 3.0 connection to work so the drive doesn’t appear. However sometimes there is enough power so the drive appears, but the 3.0 connection is less stable on my Framework and can disconnect.

Why is there not enough power? Which part is providing insufficient power supply?

I can connect external SSDs via USB A (USB 3.0) just fine. Which drive do you use exactly?

This should be a ticket, if you haven’t done so already.

Thanks for the reply. Yeah I guess I’ve mostly been posting event logs in the other 1 TB expansion card disconnect thread, though I’ve always had the suspicion that these two problems are related. These are the only sorts of Windows event log messages that seem relevant:

Log Name: System
Source: disk
Date: 3/12/2023 11:24:32 AM
Event ID: 157
Task Category: None
Level: Warning
Keywords: Classic
User: N/A
Computer: WorkBrian
Disk 3 has been surprise removed.

Log Name: System
Source: Microsoft-Windows-USB-USBHUB3
Date: 3/13/2023 6:07:48 AM
Event ID: 196
Task Category: Surprise Removal
Level: Warning
Keywords: (1)
Computer: WorkBrian
USB device draining system power when system is idle.

USB Device: VID: 0x13FE PID: 0x6500 REV: 0x110
Removal action failed: SkippedAsDisabledInSettingsPanel

Also when the a USB drive fails to appear in the list of drives after plugging it in, it will sometimes show up in the Device Manager as Unknown USB Device (Port Reset Failed) with the following device status:

Windows has stopped this device because it has reported problems. (Code 43)

A USB port reset request failed.

If anybody knows of any other messages or diagnostics that I should check for on Windows, let me know!

The disconnect problems happen with the 1 TB Framework expansion card as well as a Seagate 2 TB external drive and a Seagate 4 TB drive. I’ve only seen the quirky connect problems happen with the Seagate drives. I don’t know for sure that it’s a power thing. It’s just a theory trying to unify all of the mysterious behavior.

Oh yes, I also have a ticket going. I just thought I’d post here because I was excited to have found a sort-of grand unified theory behind the 1 TB expansion card disconnect and the Quirky USB port. Those following along know that I’ve been on a quest to unite these two problems into a single explanatory framework :slight_smile:

[quote=“brianshmrian, post:22, topic:9427”]
Oh yes, I also have a ticket going. I just thought I’d post here because I was excited to have found a sort-of grand unified theory behind the 1 TB expansion card disconnect and the Quirky USB port. [/quote]

Sounds good, appreciate that. Keep us posted how the ticket goes, it may be a bit as troubleshooting stuff like this is a bit of back and forth. Please do all things suggested (even if you don’t think it’s relevant), that way if is needs to be escalated, all the basic stuff is already done.

1 Like

Ive had similar issues now that ive posted about twice, with malfunctioning USB ports. Even in the boot menu sometimes it wont find the USB devices. I noticed this very early on but just assumed this was an issue with the USB devices itself. Ill try what Brainshmrain did with resetting the mainboard state, but honestly ive been trying to resolve this for about half a year with no resolve.

Im using the 1135G7 on windows 10

I haven’t resolved the problem either. My best work around has been to use this powered USB-C hub. My devices connect and are stable when I plug them into the hub.

1 Like

Is your battery charge limit set below 100%? A couple of us have had random disconnects which go away by setting the battery charge limit to 100%: External display loses signal when charging via docking station

Interesting. Yeah, it happens to me both at full 100% charge limit and 80% charge limit. I only recently turned on charge limiting.

Hello @brianshmrian,

Thanks for pursuing this USB port problem to the logical conclusion. My USB A doesn’t recognize or display any brand of external memory sticks but I can feel it working when I plugged the memory stick in and felt the laptop.

Please see two attachments below. They are screenshots of error messages that came on my laptop screen immediately after I inserted the memory stick in the USB A. I hope these screenshots would help you figure out the real problem and way to fix it permanently.

I called framework support and asked if they had USB A port higher than what they currently offer. No, they said.

Screenshots of error message

Thank you

@Libhero Yes this does seem like another sign that the Framework USB problems are power related (assuming your sticks work fine in another computer).

To review the evidence:

USB 2.x connections work fine. It’s the USB 3.x connections that have a problem. If I force a problematic device to connect via USB 2.x either by using a USB 2.x speed cable or by doing the halfway plugin trick, the problems go away.

(The halfway plugin trick doesn’t work for all USB-A devices, though, so the only way I know to guarantee a USB 2.x connection is to use a USB extender cable or dongle that’s only rated for USB 2.x speeds.)

If I use a powered USB-C hub, the problems go away. If I don’t power the powered USB-C hub, the problems come back.

Evidence of other people with the problem:

Unfortunately, this 1 TB drive disconnect megathread was closed before I figured out the USB 3 vs 2 angle so I wasn’t able to ask people to try it. I guess I could create a new thread that’s like “Hey everybody with framework storage expansion card disconnect problems, try forcing them to connect at USB 2 speeds.” And maybe even give a link to this cheap USB 2 speed dongle to test with. And a link to the powered hub for those who are willing to pay more for the test. The hub is useful, though, and even has a 1 Gbps ethernet port.

I found this thread when looking for fixes for my buggy ports can I can report a similar issue. When I plugged any peripherals into my usb-A expansion slots they would work, turn off, then maybe the LEDs would turn back on but for example no input would be recognized from either the keyboard or the mouse. I tried rebooting but the devices wouldn’t even register on the device manager. I also tried all 4 of my ports and eventually none of them worked for USB-A peripherals. I should note, however, they always would work for a thumb drive.

I tried your idea of only plugging the usb in part of the way and that worked. Once they are recognized I can then get the mouse and keyboard to continue working for the rest of the session.

Let me know if you end up finding a better solution, but for now I did send a ticket to framework support before I found this thread.

My current solution is to use a powered USB-C hub. Forcing USB 2 connections (via a USB 2 cable or the halfway plugin trick) continues to work, but I like having USB 3 speed for my external drives.

By the way, on Windows the best way to see whether your devices are connected as USB 2 or 3 is either to look in the “Bluetooth and other devices” system settings or for even more info run USBTreeView.

1 Like