[TRACKING] USB-A an ongoing problem?

Just a reminder, if you have symptoms of a device that is not working to spec, please open a ticket as it will not likely be resolved in the forums if it’s a potential hardware issue.

I’m curious. How many people have had these sorts of USB problems?

  • USB devices not connecting or showing up
  • USB devices disconnecting
  • USB devices only connecting at USB 2.x speeds
  • USB devices only showing up when plugged in halfway
  • Generally flaky USB behavior

And how many people who have had these problems have managed to fix them? If so, how?

I’ll start. I have all of the above problems and have not fixed them through my customer support ticket.

However, I do have two workarounds. The best is to use a powered USB-C hub which results in stable and fast connections. Another workaround is to force devices to connect at USB 2.x speeds (by using USB 2.x dongles or cables) which results in stable connections at the cost of slower data speed.

Fair question - is on a percentage basis of overall units, the numbers are small. However, as those sales grow, we do see folks dealing stuff that doesn’t work as it is supposed to. Previous support roles, same.

Definitely get a ticket opened up. You will be asked to go through the support process, please do so and if it’s something that is determined to be a hardware issue by support, this will be addressed as well.


Thanks, Matt. The thing that concerns me is that I don’t really see people posting here that their problems have been resolved or what the resolutions were. That would definitely be helpful.

For instance, are people getting new mainboards which resolve their USB problems? Did I just get unlucky to have 2 mainboards with the same problem? Or are there software fixes that resolve the problem?

At least I have the workarounds, but I’m curious to see how other people have resolved their issues. I probably should start a more generic USB problem thread since the problem isn’t confined to USB-A.

1 Like

Depends, it’s either the device connected or the expansion card itself. There are of course other situations where it may be something different. But this is why we have a ticketing system, many things are best solved through extensive troubleshooting with that user only.

Here are two cases which seem to have been resolved by mainboard replacements (including embarrassingly an instance in my own Quirky USB thread which I forgot about):

I wonder how often it’s the case that the weirdness is due to the hardware? Also, since I did do a mainboard replacement and still have the problem, does that disqualify me from getting another mainboard replacement? They indicated this in my support ticket. Anyway, what I’m really interested in is software fixes. That’s the holy grail here. Given all of the quirks, though, it really does seem like a hardware problem. Just to clarify on my old ticket, I’m currently waiting on Framework to release an 11th gen BIOS update which support said maybe would fix the problem. That would be awesome for everybody obviously.

1 Like

Hey again @brianshmrian! I only skimmed the thread and a bit coincidental I got tagged in this as about 2 weeks ago I plugged an old but reliable Sandisk 64gb USB flash drive into a USB-A expansion card on the left side (don’t remember if it was top or bottom).

For some reason the drive wasn’t showing up unless I did the “insert-halfway” trick.

Did some minor troubleshooting and it did all work correctly in a USB slot on the right side (I don’t remember if top or bottom).

Oddly, the drive worked being plugged into a Google USB-C to USB-A dongle directly into the laptop’s USB-C port. I remember this being the case way back when was I ran into these issues as well.

So I’m not sure if the issue finally resurfaced on my mainboard replacement, or if it’s the USB-A expansion card (I only have 1 to test with), or if it’s some weird incompatibility issue between the USB-A, specific USB drive, and mainboard. I tested a USB mouse and it worked correctly.

Just leaving this info here in case it helps because this is a very minor issue that I can work around and everything else has been working very well (the mainboard in general with USB-C ports and HDMI). My previous mainboard had a flaky USB-C port issue connecting to my monitor which affected my daily workflow, but that was solved with the replacement.

FWIW I had a first gen Dell XPS 15 (9550) where a USB 3 ethernet adapter didn’t work on the right side USB-A port. I went to a Microsoft store, talked to some reps, and tested it on a display model where it didn’t work as well. So I figured it was an issue on that model and bought another adapter that ended up working.

shrugs I have an AMD mainboard preorder, hopefully I don’t run into any first gen issues there lol

A bit rushed typing this on my phone/scatterbrained – please feel free to ask for more details/I can run some tests on my device if it helps get to the bottom of this.

Hey good to hear from you again @Michael_Wu. It feels like the old days. Haha.

The thing I would be curious about is when you get the drive to appear in the wonky port, does it connect as USB 3? In Windows 10 you can go to the Bluetooth & other devices settings in order to see if it says “Connected to USB 3.0”. I’ve found that my problems all seem to be related to unstable USB 3 connections.

What the halfway plugin trick does for me is that it forces a drive to connect at slower USB 2.0 speeds. When a port is having trouble, forcing a drive to connect as USB 2.0 allows it to appear (or stay connected, if it can connect as USB 3.0 but then has problems with disconnections). A dongle or cable can also force this USB 2.0 connection if it’s not rated for USB 3.0 speeds.

Another thing I’ve recently discovered is that HDMI doesn’t work in one of these messed up ports (at least through my Anker 555 hub… see here for details).

I feel like there could be a grand unified theory of USB problems with drives, hubs, and monitors that is related to this USB 3 problem.

1 Like

Just adding in my own daily experiences.

I use USB-A daily, mostly on my 13th and 13th gen boards without issues. That said, I do not use my docks very often. When I do, I use limited USB-C/A connections with it for data driven stuff (webcam testing, USB headsets, dongles).

All external display pushing for myself is done through DP and HDMI expansion card(s).

1 Like

@brianshmrian the old days…yeah! :dotted_line_face:

Haha sorry for the late response and thanks for the info – with that I managed to pinpoint some things on my end:

So on my current 11th gen mainboard which I’ve been rocking for probably over a year, my Dell monitor with built-in KVM switch/USB3 hub has been plugged into the top left port most of the time. Single USB-C port for power/video/USB hub has been working fine (though I haven’t tested its USB hub is operating at 2.0 or 3.x). When it’s first plugged in, sometimes it will need an unplug and replug, though. That also seems to be the case with the bottom left port, which I rarely use.

It appears that the left 2 ports are the “wonkiest”. The right 2 seem to work perfectly with the devices I own. I focused on my bottom left port for most of this testing as that is my “free” port. I’ve tested this with the top left port occupied with my monitor and without (so nothing else plugged into the laptop).

This is the behavior of my bottom left port (also somewhat with my top left port):

  • USB 2.0 devices all seem to work flawlessly:

    • A Sandisk Cruzer Blade USB 2.0 4GB drive (from ~2009! wow yikes).
    • Through a Framework USB-A expansion card, doing the “halfway-plug-in” trick forces devices to negotiate as USB2, which works every time. Tested with:
    • Plugging those devices into a Google Pixel USB-C to USB-A dongle negotiates them as USB 2.0 and work.
  • Plugging into the Framework USB-A expansion card fully (normally, without the “halfway trick”) with the USB 3.x Sandisk or plugable SSD enclosure with its USB-C to USB-A cable very very rarely works. I have gotten it to work but I’m entirely unsure as to how or why. Basically “it doesn’t work unless the light is shining the correct way” :person_shrugging:

  • Plugging the plugable SSD enclosure with its USB-C to USB-C cable directly into the USB-C port or through a Framework USB-C expansion card results in the same behavior. Rarely it will negotiate as 3.x, sometimes it negotiates as USB 2.0, and most of the time it just isn’t recognized.

I can confirm that this happens on both Linux (Fedora 38) and Windows 10 (thanks for the tip @brianshmrian!). Windows does say Device can perform faster when connected to USB 3.0 when a device is recognized but connected as USB 2.0 or Unknown USB Device (Port Reset Failed) when a device is not recognized.

For those on Linux, there’s probably an easier way, but here’s what I followed (note this is a direct link, because the marked solution is apparently misleading):
Also, when a device fails to negotiate, the journald logs will say usb usb2-port3: Cannot enable. Maybe the USB cable is bad?.

In summary, it seems that my bottom left port works/negotiates with USB 2.0 devices every time. USB 3.x devices rarely work. And similarly (less tested) with my top left port.
It’s interesting this is happening on the same side, as my two ports on the right side both seem to work perfectly.

I’ve also taken the Framework USB-A card out of its enclosure to test if it worked plugged into the USB-C “upside down”. That made no difference.

So it does seem that my (i7-1165G7) mainboard (and prior ones) have some USB 3.x flakiness regarding a subset of its direct/onboard USB-C ports, and by extension devices that are connected to them, like the Framework USB-A expansion card.

For me, with my Framework HDMI expansion card (1st gen), HDMI does seem to work perfectly. So maybe your wonky USB-C port is causing the Anker hub’s HDMI capability to fail?

Yes! Good call, this matches my findings as well. Nice to know I’m not the only one, at least haha :slight_smile:

Thanks @Matt_Hartley, glad to know this might not be a problem on the later gen Intel boards. I’ll be thoroughly testing my AMD board when it arrives (and am aware of the current state of its ports – I very much appreciate the transparency!)

1 Like

@Michael_Wu Thanks, as always, for the detailed testing and report! It’s good to know that the same USB 3 problems happen on Linux as well as Windows, just so we know it’s not some Windows-specific problem.

1 Like

Intel 12th gen does have the same problems with USB … Shouldn’t there be an firmware update for full thunderbolt compatibility for intel 12th gen? Is there any update about it?

No updates at this time. The moment we have an update, it’ll be posted to the forums and pinned.

1 Like

I just got my Batch 5 Ryzen 7040 laptop the other day, and the first thing I immediately noticed before installing any OS was that the USB-A expansion cards I installed on the bottom-left and bottom-right would not work with a USB 3.0 thumbdrive and show up in the boot list.

Found this thread, and the half-way plugged in trick allowed me to finally boot an Arch Linux ISO. After installation, I played around with those USB-A ports a bit more, and got some errors to show up in the journal.

The bottom-left USB-A port was repeating this error when the USB 3.0 drive was fully plugged in:

kernel: xhci_hcd 0000:c1:00.3: Refused to change power state from D0 to D3hot
kernel: xhci_hcd 0000:c1:00.3: Refused to change power state from D0 to D3hot
kernel: xhci_hcd 0000:c1:00.3: Refused to change power state from D0 to D3hot
kernel: xhci_hcd 0000:c1:00.3: Refused to change power state from D0 to D3hot

Pluggin in the USB 3.0 drive fully into the bottom-right USB-A port is showing a different error:

kernel: usb 1-1: new high-speed USB device number 33 using xhci_hcd
kernel: usb usb1-port1: Cannot enable. Maybe the USB cable is bad?
kernel: usb 1-1: new high-speed USB device number 34 using xhci_hcd
kernel: usb usb1-port1: Cannot enable. Maybe the USB cable is bad?
kernel: usb usb1-port1: attempt power cycle
kernel: usb usb1-port1: Cannot enable. Maybe the USB cable is bad?
kernel: usb 1-1: new high-speed USB device number 36 using xhci_hcd
kernel: usb 1-1: Device not responding to setup address.
kernel: usb 1-1: Device not responding to setup address.
kernel: usb 1-1: device not accepting address 36, error -71
kernel: usb usb1-port1: unable to enumerate USB device
kernel: usb 1-1: new high-speed USB device number 37 using xhci_hcd
kernel: usb usb1-port1: Cannot enable. Maybe the USB cable is bad?
kernel: usb 1-1: new high-speed USB device number 38 using xhci_hcd
kernel: usb usb1-port1: Cannot enable. Maybe the USB cable is bad?
kernel: usb usb1-port1: attempt power cycle
kernel: usb usb1-port1: Cannot enable. Maybe the USB cable is bad?
kernel: usb 1-1: new high-speed USB device number 40 using xhci_hcd
kernel: usb 1-1: Device not responding to setup address.
kernel: usb 1-1: Device not responding to setup address.
kernel: usb 1-1: device not accepting address 40, error -71
kernel: usb usb1-port1: unable to enumerate USB device

When I replace the USB-A expansion with a USB-C one and use a USB-C to USB-A adapter, the drive works without issue.

Now here’s where it get strange. I swapped back in the USB-A expansions on both sides, and now the USB 3.0 drive works without issue.

This is definitely a weird problem

1 Like

I’ve also found the problem to be intermittent, though when a device does manage to connect as USB-3 it can end up disconnecting later. The fact that it’s so random and that some people have the problem and others don’t makes me think that it is a hardware thing.

I’ve updated my 11th gen framework to the 3.19 BIOS but still have the problem. I just live with it. My powered USB hub works pretty well. When devices connect as USB-3 through it they’re pretty stable. Sometimes the hub can only connect as USB-2, but in this case everything’s also stable since USB-2 seems to be solid in general on my Framework.

Sounds rather like a race condition between the software and hardware, with the relevant USB hub chips being just on the edge of timing limits, and then production variations in the chips cause failures under some specific temperature/voltage/IO operation (through USB) makes the thing loose track of the USB A.

All effected:

Three questions:

  • AMD or Intel (11th, 12th or 13th Gen - please be clear on this)

  • Does this card repeat this behavior in other expansion slots?

  • Has this card been tested on a non-Framework computer to see if it happens there as well?

  • Are we basing this on attached hub behavior or just a proper connection to USB-A to device?

  • Have you opened a ticket?

  • Intel 11th gen
  • All slots are affected (i.e. there are no consistently reliable slots or expansion cards… this includes skipping the expansion cards and plugging directly into the framework mainboard slots).
  • Doesn’t happen on non-framework computers (tested on MacBook Pro USB-C)
  • Happens without the powered hub (the hub actually makes things a bit better)
  • I have a ticket but haven’t engaged with it in a while. They told me to get back to them when the new 3.19 bios came out, but I haven’t replied yet now that it’s out.

To clarify, I don’t think this is specifically a USB-A problem. It can manifest with USB-A slots and USB-A slots do have the added benefit of being able to do the halfway plugin trick to force a stable USB-2 connection, but the problem happens on USB-C connections as well. I observed it quite a bit with the 1 TB expansion card which is what sort of sucked me into this whole debugging process in the first place (even though I’d already observed the weird USB-A behavior and discovered the halfway-plugin trick earlier).

Thanks for the details. This is helpful.

I located your ticket, am I safe in assuming you’re on the 3.17 BIOS? Based on the ticket thread.

If you are, you will want to update to 3.19 BIOS as it’s out now.

Oops… Sorry, Matt, I should have said that I did upgrade to the 3.19 BIOS but I still have the problem.