(I originally posted this in a thread on display output problems, though I now think it’s unrelated. It might be related to this other post on USB-A Yubikey problems…)

I’ve had a problem with a couple of external USB hard drives when plugging them into one of the laptop’s USB ports. The drives get power but no data. At least, the drive doesn’t appear in the list of drives, but its light stays on.

I’ve tried swapping the USB-A framework expansion cards (I have two), but the problem only happens on the left-front USB port of the laptop regardless of the expansion card that’s plugged into it. I tried plugging into my own USB-A to USB-C dongle and straight into the flaky port, and this worked once but otherwise has the same problem.

Additionally, while 2 of my Seagate external drives have trouble (a 2TB and 4TB model: STGX2000400 and STEA4000400), I have an older Seagate external drive (ST903203FAA2E1) which always shows up even when the other two don’t. Also, a SanDisk thumb drive (SDCZ36-032G-B35) always works fine.

I eventually discovered that I can get the drive to show up if I plug in the drive’s USB-A plug only partway. Then it always works in the flaky port. After the drive shows up, I can then plug the USB-A cable in all the way.

I want to reiterate that the drive always shows up in the other three ports regardless of how far I plug it in. It’s only the left-front port where it has problems, and the problems happen regardless of which of the 2 USB-A expansion modules I plug into (i.e. when I swap the expansion module in the flaky port).

This is on a batch 3 Windows 10 Pro system.


See also Found a USB device that won't work, what feedback do you folks need? which describes a couple similar situations.


I have the same issue with a Seagate SRD00F1 drive. The light powers on, but no connection whatsoever.

Mine is DIY Batch 5 laptop, with a dual Windows/Ubuntu setup.

Did you get a solution besides sliding it out and it?

1 Like

@Mike_Bopf No, unfortunately, I still have to use the trick where I put the connection in halfway, wait a few seconds for the drive to show up, and then slide it in all the way.

Just curious… Does that solution work for you as well?

1 Like

Nope. I get absolutely nothing, at least while using Ubuntu Linux. It works fine when I boot using Windows, although these drives work fine on my old Linux box. (running Mint).

1 Like

@brianshmrian I’m experiencing the exact same thing as you. Using a USB thumb drive, acts up on the front-left port only and partial-plug-in-then-wait works for me too. Very strange…

It happens in the boot menu too (accessed on boot by F12) so I’m fairly sure this is a firmware issue.


Chiming in here – I have the same or a very similar issue. This has been ongoing for a while and I’ve just been dealing with using different ports. I finally got around to trying to pinpoint the issue. It seems to be with USB3 devices – below are my findings.

System specs:

  • Batch 1
  • i7-1165G7.
  • BIOS version 3.07
  • Both Windows 10 and Fedora 35/36 Beta

There’s something funky going on with my left top/bottom ports, with the left top port affected the most. The right top/bottom ports seem to work perfectly.

USB3 Devices

With a Sandisk Extreme 64GB USB 3.0 drive → Framework USB-A expansion card:

  • Does not work in either of the left slots (top/bottom), unless doing the insert halfway trick.
  • Works in either of the right slots (top/bottom).

With a Plugable USB 3.1 Gen 2 NVME SSD enclosure [1] → USB-C to USB-A cable (USB 3.0) → Framework USB-A expansion card:

  • Does not work in the the left top slot, unless doing the insert halfway trick.
  • Works in all other slots.

With a Plugable USB 3.1 Gen 2 NVME SSD enclosure [1] → USB-C to USB-C cable (USB 3.0) → Framework USB-C expansion card or direct to laptop without card:

  • Does not work in top left slot, even with all other slots empty. And strangely, when music is playing, I can hear slight static/noise/interference when it’s plugged in. Right when I unplug it, the interference goes away. Can’t really do halfway insert trick with USB-C.
  • Works in all other slots without any static/noise/interference.


Plugable SSD enclosure/cable image

USB2 Devices

With a more-than-a-decade-old Sandisk Cruzer Blade 4GB USB 2.0 → Framework USB-A expansion card:

  • Works in all slots.

With a Plugable USB 3.1 Gen 2 NVME SSD enclosure [1] → USB-C to USB-C cable (USB 2.0) → Framework USB-C expansion card or direct to laptop without card:

  • Works in all slots without any static/noise/interference.

Connecting any of the above USB devices → USB-C to USB-A (2.0) dongle [2]:

  • Works in all slots.


Dongle image/details

I have two separate ones that came with different generation Pixel phones, they look like this:

So it seems like:

  • USB 3.0+ devices don’t work/have issues in my left top/bottom ports
  • USB 2.0 devices seem to work in all ports

According to this post: USB Controllers - #4 by Kieran_Levin

USB3 signals all ports → USB controller 1
USB2 signals all ports → USB controller 2

Maybe there’s something up with that USB controller 1? since there are issues with USB3 but not USB2.

Monitor issues

My initial issue with more cluing details and led me to try to debug this:

I connect my Framework laptop to a Dell U3421WE via a single USB-C to USB-C cable. This provides video over DisplayPort Alt, audio, ethernet, 90W power delivery, and some devices connected to the monitor’s built-in USB hub.

When I connect with a USB3 USB-C to USB-C cable to the left top port (with a USB-C expansion card or direct, doesn’t matter), with nothing connected to the left bottom slot, it works.

However, if the left bottom port is occupied with anything (USB3 or USB2) other than just a Framework USB-C expansion card, such as:

  • Framework USB-A expansion card
  • Framework HDMI expansion card
  • Directly connecting a USB-C storage device
  • USB 2.0 USB-C to USB-A dongle [2]

Upon plugging the top left port into my monitor via USB-C to USB-C, the monitor will repeatedly connect/disconnect until it either connects with no video (audio works) or an incorrect-lower-than-native resolution. Rarely, it works correctly and usually after a ton of disconnect/reconnects.

All the other ports (left bottom, right top, right bottom) work correctly, no matter what’s connected to the other ports.

Error messages

In Linux, sometimes I get these error messages:

Linux errors
kernel: usb usb2-port4: Cannot enable. Maybe the USB cable is bad?
kernel: usb usb2-port4: Cannot enable. Maybe the USB cable is bad?
kernel: usb usb2-port4: attempt power cycle
kernel: usb usb2-port4: Cannot enable. Maybe the USB cable is bad?

In Windows, this error message:

Windows errors

Screenshot 2022-03-28 071531

It seems like with the above errors, the USB device/port repeatedly connects/disconnects.

The issues happens with the same results in both Linux and Windows, which leads me to believe that this is either a hardware or firmware issue.

I’ve re-adjusted the EMI stickers as well without any improvements/success.

BIOS is on the latest (3.07), so the unfortunately USB fixes from 3.06 didn’t seem to apply here. (I can’t seem to find that post, it’s somewhere in this forum).


Seems like @Matt_Clark got a replacement motherboard and hasn’t had any issues since.

I’m going to contact support and will update here. Ping me if I forget!

1 Like

I experimented with this problem again and still find the left-front port to have the hardest time seeing my external USB-A drive if I don’t do the halfway plugin trick.

However, this time around I also found the drive to be flaky in the right-front port. Sometimes it would appear immediately, but sometimes it would appear after ~15 seconds, and sometimes it wouldn’t appear at all. This happened (though never consistently) as I kept swapping which of the 2 USB-A expansion cards I was using. It was even the case that the drive sometimes appeared without problems (or halfway plugin trick) in the left-front port. Unfortunately, I’m no Charles Darwin, so I didn’t write down all of my observations as I was experimenting. At one point I had a theory that if I sort of pushed up on the USB-A plug as I was inserting it, then it would work. However, this failed to bring the cargo consistently. My current unscientific determination is that the interaction of the drive with the ports is flaky.

Also, I wonder if we could change the tag on this post from “Framework Laptop” to “Community Support”? I’m not sure how to do that :slight_smile:



I reached out to support and they sent me this at first:

Given the information you’ve provided, you will likely need to perform a full mainboard reset as it may have problems with detecting your hardware after following the EMI Shield Fix. We have a step-by-step guide located here: Fully Resetting the Mainboard State - Framework Guides that will walk you through the steps to have the laptop goes into its initial state and will reset the hardware detection of your motherboard.

Which I performed. After doing that, my left bottom port seemed to work perfectly, but I still had the same issue with the left top port. I performed the reset again, and then tried the EMI sticker fix for that port again with another reset. Unfortunately that didn’t help.

They then escalated the ticket and long story short, I’m getting a replacement mainboard that should arrive this Tuesday. I’ll be thoroughly testing the replacement and will report back here! That should hopefully give some insight into if this is a hardware issue.


@Michael_Wu Thanks for going the extra mile, both in trying to figure out this problem and sharing your results! :slight_smile:


@brianshmrian so the replacement mainboard I received had a part that seemed to have broken off in the ESD bag that it came in.

I installed it anyways, but it wouldn’t turn on, so I reinstalled my old mainboard.

Emailed support back – I’m assuming I’ll be sending it back and then waiting for another replacement.

Stay tuned, I guess🍿 haha

1 Like

@Michael_Wu You are demonstrating true grit here! :slight_smile:



Chiming in to say that the replacement mainboard has seemed to fix all my weird USB issues, so it may indeed be a hardware issue.

Took a while as the second replacement mainboard was also damaged upon arrival (bent heatsink/board, yikes!) but support sent out another replacement shortly after (next day IIRC). The third replacement arrived undamaged and worked.

Also, the new one came with the Tempo audio chip (my previous was Realtek). It worked out of the box in Linux (Fedora), but I couldn’t get it to work in Windows until I found and uninstalled conflicting Realtek software, then re-installed the Framework driver bundle.

I’d say overall incredible support, so if anyone from the team is reading this, thanks again and please keep it up!


That’s great news!

I probably won’t replace my mainboard since I have an easy workaround, although maybe I should because the same issue could be responsible for the 1TB Expansion Disconnect problem. And it could also be a warranty issue?

Oddly enough, even though I love Framework’s mission of empowering users to repair and modify their laptops, I myself am completely inept at this sort of thing and the 34-step replacement guide looks very intimidating to me!

Ah, I could’ve tested with my prior mainboard and 1TB SSD (in a 3rd party enclosure) plugged into the quirky USB port, too late though :grimacing:

From what I can recall, I used to have my 1TB SSD plugged into a non-issue port seeding files for an extended period (~a few days), and I don’t think it ever disconnected when it shouldn’t have (in Fedora Linux, not sure about Windows).

I’d say if it works perfectly in some USB ports and not others, it might be a hardware issue.

I have a suspicion that the faulty port I was plugging my monitor into (power, data, USB, etc.) would “crash” causing my laptop to freeze, because those random freezes no longer occur with the new mainboard. That could’ve been fixed from a Linux kernel update though.

As for replacing the mainboard – it was much easier than I anticipated, though I do have a lot of prior experience building desktops and tweaking laptops – so my view may be warped. But it’s basically just unplugging connectors and ribbon cables (which are definitely fragile and it’s good to be overly cautious, but really not that frightening). Then replugging/screwing everything back in. The mainboard only has 5 screws to hold it in place. Once I got the process down, it took like 5 minutes total.

I hope you/y’all get your issue(s) resolved!


One more piece of info… I just discovered that when my Framework reboots, if I have the USB drive plugged in and recognized, then it stays accessible after the reboot. However, if it’s plugged in and not accessible (i.e. I didn’t do the halfway plugin trick before fully plugging it in), then it’s still inaccessible after reboot. Finally, if it’s accessible, and then I shutdown the computer, it becomes inaccessible when the computer boots up again.

Even though this particular quirky USB port problem wasn’t bothering me too much since I had the workaround, I started experiencing more and more problems with my 1 TB storage expansion card disconnecting almost every day.

After some back and forth with Framework support (including opening the laptop and sending them some pictures), they decided I needed to replace the mainboard. They quickly sent me a replacement (which I installed mostly myself, with a little moral support and supervision from a friend), and now I can plug my USB drives normally. No halfway trickery needed!

Many thanks to Framework support! You guys are great!


The problem has returned for me. At least the workaround still works.

I’m just wondering if this oddity is related to the problem of external USB drives randomly disconnecting, which is my real problem. Just today, for instance, I was in the middle of backing up my computer when the USB drive disconnected. This has happened a couple of times, though this morning it happened in a non-quirky port. (And in fact, I switched to the quirky port and the backup succeeded).

Just to clarify, both my 1 TB expansion card and a different USB drive disconnect randomly. The 1 TB disconnect problem is well known and discussed at length in another thread. However, I don’t think there’s a problem with the 1 TB drive itself. I think it’s related to some more fundamental USB port problem.

I think I know why the flaky behavior and disconnects are happening though I don’t know how to fix it. The problem has to do with USB 2 vs USB 3 connections.

When an external drive negotiates a USB 3 connection, it uses more power.
USBDeview reports 896 mA for a USB 3.0 connection vs 300 mA for a USB 2.0 connection with my 2 TB Seagate drive.

When I plug in the drive in halfway, it negotiates a USB 2.0 speed connection which uses less power. This connection is very stable for me.

When I plug the drive in all the way to begin with, there’s not always enough power to get the 3.0 connection to work so the drive doesn’t appear. However sometimes there is enough power so the drive appears, but the 3.0 connection is less stable on my Framework and can disconnect.

This is the same with my 1 TB expansion card drive which disconnects often. I eventually started experimenting by connecting the 1 TB drive via a USB-C male-to-female adapter connected to a USB-C to USB-C cable into a USB-C slot in the Framework. I noticed that using a charging USB-C cable with only USB 2.0 data speeds would stay solidly connected. However, when I used a USB 3.2 speed cable to connect it, I would have disconnect problems. This is, in fact, what led me to figure out this important difference in connection types and stability.

Now if anybody can tell me why this should cause problems and how to fix it, that would be the final piece of the puzzle. Shouldn’t the Framework be able to handle these power requirements. Say 900 mA per USB port?


Unless you show us some kernel logs (dmesg on linux, Event Viewer on Windows) there is quite less we can do to help you here.

When I plug the drive in all the way to begin with, there’s not always enough power to get the 3.0 connection to work so the drive doesn’t appear. However sometimes there is enough power so the drive appears, but the 3.0 connection is less stable on my Framework and can disconnect.

Why is there not enough power? Which part is providing insufficient power supply?

I can connect external SSDs via USB A (USB 3.0) just fine. Which drive do you use exactly?