[RESPONDED] Really bad errors trying deep sleep

s2idle works perfectly fine for me. It drains a lot of battery though.

However, trying to set deep sleep with

echo deep | sudo tee -a /sys/power/mem_sleep

results in the system completely going wild and lots of I/O errors after resuming from sleep. Anyone seen this before?

Running Ubuntu 22.04.

What SSD are you using? I can’t help with troubleshooting but I imagine whoever can will want to know.

That’s a faulty NVME (or behavior) for sure.

Did you enable some kernel options for the NVME like

options nvme_core default_ps_max_latency_us=6000
options nvme noacpi=1

? If not, I think it would be worth to give them a try.


I’m using a Samsung SSD 980 PRO 2TB (PCIe)

My kernel options are currently already GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash i915.enable_psr=0 nvme.noacpi=1”

I’ll try the max latency thing.

1 Like

hi @Dheera_Venkatraman ,

Do let us know when you have applied the two kernel nvme option suggested by @Anachron, and see if it works in your case. thank you. :slight_smile:

Hi @Loell_Framework I tried those two options. Still the same errors.
Is this an issue of NVMe brand? I’m using a Samsung 980 PRO 2TB which I thought was a pretty reliable brand. If so can anyone suggest brands that do work?

maybe it’s just your specific ssd that has issues in general? i don’t know what to recommend to debug but i’m using a samsung 980 on linux and i don’t have those issues.

It could only be this specific SSD, just snooping around with this ssd make, isn’t it that it has some firmware update? let us know if you’ve already look into that, thanks.