[RESPONDED] Screen issues on Fedora

So I’m running Fedora 38, as a bit of a traditionalist, installed the cinnamon spin, and again, as a bit of a conservative type, I tend to wait a bit before upgrading to the latest version. I received my FW13 AMD a couple of weeks ago, and have been using it at work, so almost exclusively hooked up to an external display. Yesterday I noticed that, when the screen is mostly dark (e.g. dark mode UI, terminal, or the boot splash screen even), the blacks of the screen appear noisy. On closer examination, the noise turned out to be random pixels (or clusters of pixels) flashing up in red, green, blue, sometimes white. Sometimes changing the resolution stops the flickering, sometimes it doesn’t. I also noticed that lowering the refresh rate at native resolution to 48hz didn’t work at all.

I’ve done some searching, but couldn’t find any known issues on lkml, or anywhere else that seemed to describe, or explain my issue. I submitted a bug report, and literally as I was typing that up, the backlight just gave out (something that I did some threads about here, but on rebooting, the shutdown splash screen restored the backlight, and it’s been back up since).

Some more digging through journalctl logs doesn’t give me any clue as to what could be going on either. Maybe I’m not looking in the right place, maybe someone else had the same issue, and managed what I couldn’t (ie fix the problem). After work, I’ll take some time, upgrading, checking logs, and report back if I managed to fix the problem.

I did notice something: the noise seems to quiet down when I have a terminal open in full screen and the CPU is idling. When opening a large-ish file in Vim, for example, the noise flares up until my LSP has loaded, and everything is set up/loaded, and then it all settles down to almost nothing again. Every time I’m doing some work, it’s quick to return, though. Even moving my cursor around causes the noise to increase significantly. Basically, it seems to related to CPU or RAM utilisation, causing some noise in the signal, perhaps?

The kernel in f38 has known bugs ; upgrade to f39 or rawhide kernel

1 Like

That doesn’t explain why I can see the noise on boot, during BIOS upgrade, etc… I’m pretty sure it’s a hardware issue

Hi @EVODelavega .

Do try F39 live, see if it exhibits same behavior, if it still persist then kindly file ticket.


Update: The issue decided to fix itself after a few days. The noise just stopped being a thing for a day or so, then it came back. I opened the unit up yet again and noticed that the screen cable had decided to go off on a little stroll. Next to the left hinge, there are some bits to route the cable through, and the cable itself has a little bit of tape on it to fix it in place. It looks like that came undone, and may have caused a bit of interference or pressure on the bottom of the display. Once I put everything back in place, the noise went away again.
I’m not sure if it’s related, but seeing as I’m working on the go at the moment, I also figured I might as well swap out the HDMi module. For now, everything is working just fine, and I do believe that the travelling (albeit properly seated) cable was the culprit. It certainly made more sense to me than a kernel issue (I’ve seen the videos and pics, it looks nothing like what I had, and a kernel issue wouldn’t be visible in in bios, before the kernel is loaded). Just thought I’d mention it in case someone else stumbled across this because they’re having similar issues

1 Like

Thanks for the update @EVODelavega , it’s tempting to label this as resolved, but perhaps there’s more info we could collect and unravel, do update us again in the coming days/weeks, see if issue will resurface or not.

Cheers. :slight_smile:

1 Like

That sounds like the grounding tape. Insufficient grounding could result in noisy video signals, I suppose.

1 Like

OK, so since I’ve been on the move for the past week, I’ve seen the issue reappear once for a minute or so. I removed the bezel and pushed the cable down into the routing channel, and things were fine. I’ve since double-checked the grounding cable, which is still properly stuck to the hings, so I’m absolutely certain that wasn’t the issue. IMHO, the only plausible explanation was indeed the display cable not properly routed.

That being said, the grounding tape did make me think: the point where the display cable connects to the actual panel seems to have some grounding tape around there, too. As far as I’m concerned, the issue has been resolved, and I for one find EMI to be a reasonable explanation, and would argue that ensuring the display cable is correctly routed a valid diagnostic/debugging step. It’s rather hard to accurately describe the observed behaviour, but I’ve gone ahead and uploaded a couple of seconds of video captured on my phone showing the screen during a bios update. I’ll link it here for reference:

You’ve applied the BIOS UMA GAME OPTIMIZED VRAM setting in BIOS and added amdgpu.graphics.sg=0 kernel cli required at the moment right?

Hey there, I’m running F39 and I’m facing the same issue (little colored pixels poping up here and there).
It happens also at boot time.
I didn’t reopen the laptop yet but I did apply amdgpu.graphics.sg=0.

Yes, I did. That’s something that was required in general (sort of). Unplugging my second monitor, or some games would result in a mostly white screen, often flickering or showing some very strange artefacting that render your display utterly unusable. I’m not sure if the UMA_GAME_OPTIMIZED_VRAM is strictly necessary, but I enabled it anyway.

Like I said, though, after pushing the display cable firmly into its cable routing channel, I’m not having the issue too much. I’ve seen it once or twice briefly during boot, but just pusing the screen back to 180 degrees and back it’s gone. I think this is because I’m a bit hesitant to glue the bezel on (ie using the bits of tape on the bottom) because of this problem. I can imagine though that sticking the bezel on would in fact help keep the display cable in place though, so at some point in the near future I’ll be sticking that down, I just want to be sure things are fine. I specifically want to see the issue re-emerge at some point, and just apply gentle pressure on the bottom of the bezel to see if that makes a difference.

I did create an issue with FW, and I’ve since upgraded to F39. Like I said: I’m pretty much convinced that this is a hardware issue, specifically related to the display cable causing some interference. Do you have the issue all the time? Is it intermittent? Does folding the screen back change anything?

I’d strongly recommend just removing the bezel, and pushing the display cable down in the routing channel at the very least, maybe post some pictures of it here, for completeness sake? My whole reason for sharing the video here was in case someone else had the same issue (which you seem to have), so let’s document as much as we can, diagnose and resolve in a way that others can use, too.

So as you can see from the rest of this thread: someone else has since reported the same issue, but I’m 99% certain the display cable routing was the cause of the problem. I’d quite like to know if Damien can “replicate” my “fix” by re-routing the cable itself, in which case my 99% certainty would tick over to 100%, and we can mark this as resolved.

I’ve included that small clip just so ppl can see what the issue looks like exactly and, if needed, this could be added to some kind of FAQ or known issues with known (and simple) solutions somewhere.

Either way, as far as I’m concerned, my issue is resolved, and I hope Damien can see things fixed soon, too.

1 Like

Thanks for the follow up update @EVODelavega, hoping your tip would resolve others similar issue, appreciate it. :slight_smile:


I also have the same issue, running on AMD Ryzen 7 / Debian 12 with a 6.5 kernel. It appears as soon as CPU is intensively used even on a short time. It does not looks like a software / kernel issue.
I’ll try your workaround today ant i’ll keep you in touch.


Perhaps a silly question, but did you fix the bezel in place with the double-sided tape bits at the bottom? In my over-eagerness to set my new laptop up, I have to admit to skipping that step in the assembly, which I now believe may have contributed to the display cable getting pushed up to press up against the bottom of the actual panel. If I were you, I’d try removing the bezel, push the display cable down in its routing channel, and fold open the laptop 180 degrees on boot. That cleared the problem for me. Make sure to check the 2 bits of black tape are attached to the hinge still, because I’m all but certain this is some kind of interference issue

I don’t get double-sided tape, could you send me a picture of it?
I tried to remove the bezel and put the display cable in its routing channel but I still get the problem.
Picture of left and right side before putting back the bezel

The double sided tape are the white rectangles on the bottom of the bezel itself, as shown on the guides here: Bezel Replacement Guide - Framework Guides.
Note that one of the comments on that guide actually mentions an issue with the screen (in this case backlight not working) being related to pressure or incorrect fitting at the bottom left corner, ie where the display cable and hinge are located.

The cable that caused issues for me is the one on the left. It does look like it’s routed properly, but just above the hinge, there’s a little lip on the cable, which IIRC should be a sticky and make contact with the metal of the hinge. If you remove the bezel with your laptop on, and even gently touch the bottom of the panel (something you really should try to avoid, though) you’ll see the screen flicker (as per the comment below the guide linked above). My suspicion therefore still is that the bit of the display cable that routes over the hinge might just be the root cause of this issue. In my case that lip on the cable, for example, had wrapped around the cable, and the cable itself wasn’t pushed under those little clips/routing channel bits. Once I fixed the cable to the hinge, and pushed it under the metal bits, the issue was fixed…

Well, bad news: the issue is back for me, and more over: it’s worse than before. Not only do I get the noise, from time to time, the screen just doesn’t work. The backlight switches on, but nothing actually shows on the screen. After tapping the left hinge a couple of times, folding the display back and forth, and power-cycling the machine a handful of times, I get a (often noisy) screen again. I’ve contacted support about this, but just wanted to update this thread

On my side I’m still having the issue, none of your recommended action works for me so I’ll have to contact the support also.
Thanks for the update.