[RESPONDED] System hanging after disk decryption

I just started having this issue and am not really sure how to fix it as I have tried booting from different kernels. Other than that I am Linux novice and some solutions online make no sense to me and I don’t know how to implement them.

Edit: Fedora 39 Gnome

Try recovery mode at the grub boot prompt.

I have tried that and unfortunately it doesn’t work.

I had a similar issue one week after I got my FW13 AMD and had also Fedora 39 (Silverblue) installed with disk encryption.

I tried some btrfs repair tools with dracut but nothing helped.
There was no partition detected (after successful encryption).

Then I re-installed Fedora without disk encryption. It is now working for about 4 weeks)

Yeah. I tend to use KDE Neon (currently Ubuntu 22.04.x + newest KDE plasma), and on the laptops with full disk encryption using the ext4 file system. Never had an issue for years.
BTRFS is usable, but not as “solid” (tested) as ext4fs. Hence me sticking with that for mission critical stuff.

Yeah I will be switching to Ubuntu, I was able to copy my files from a live USB so I will just be getting rid of fedora.

I tend to have - on my home non movable systems - the OS partition to be non encrypted, and have /home partition encrypted. This way, if something happens, I can go into single-user mode and troubleshoot the live system.
At least, using luks, I know how I can access the partition afterwards.

Welcome to the community!

Confirming this is Fedora 39 Workstation, fully updated?

Can you walk me through the process of when this went from working to not working? After updates or any ownership changes to the drive? This was LUKS during the installation, correct?

Triple verifying this is LUKS encryption and not unsupported/untested disk encryption from BIOS?

Yes it is Fedora 39 workstation fully updated and the only thing I did was watching a Youtube stream and firefox crashed and then the whole screen froze and had a graphical glitch so I shut the system down. Then it started hanging. This is LUKS from when you first install Fedora.

However I already installed Ubuntu instead so I won’t be able to further test to try and fix it.

1 Like


While I can see this happening one time, after a second or third attempt it should have sorted itself out to let you login. Sounds like Firefox’s handling of the video was the trigger.