[RESPONDED] Testing Kernel 6.0 with 11th gen

There’s a thread for kernel 6.0 with 12th gen, so I figured there should be one for 11th gen as well.

I’m on Manjaro with 6.0.6-1. All seems to be working normally, except that power usage is running 4-5W higher than the same tasks and environment on 5.15.76-1.

I’m using TLP with Powertop, same as I’m been doing for half a year.

Anyone find anything different?

1 Like

6.0.7 on EndeavourOS (arch derivative), psr on, nvme.noacpi on, tlp and powertop tuneables all on, i5-1135G7. 4.5-7W according to powertop with 50% brightness, X11 and KDE desktop, a pretty ridiculous number of Vivaldi tabs open, etc. This is very comparable to what I was seeing in the 5.18 and 5.19 kernels.

1 Like

I have an 1165g7.

$ uname -r

Here are some relevant numbers from turbostat -S on Fedora 37 (beta) that I took last night.

PkgWatt  CorWatt  GFXWatt
2.23      0.45      0.08
2.16      0.41      0.11
2.26      0.43      0.12
2.26      0.47      0.11
2.10      0.38      0.11
2.29      0.49      0.11
2.60      0.72      0.11
2.17      0.41      0.11 

Things have improved slightly. I definitely have not seen a cpu drain as low 380mW on 5.19.
I firmly believe that when/if framework can resolve the chipset ACPI issues the package wattage will also get much lower improving s0ix and idle battery life.

Unfortunately on Fedora 37 beta there are regressions elsewhere, as I am seeing high power drain from the AX210 now so I’m still sitting at ~4.8w total usage which is slightly worse than the 4.5w I was seeing on my old Dell.

Didn’t know about turbostat. Very cool. Just installed in from the Manjaro repository.

$ turbostat -s PkgWatt,CorWatt,GFXWatt   

kgWatt	CorWatt	GFXWatt
3.56	1.75	0.27
3.56	1.75	0.27
0.53	0.08	0.02
0.53	0.08	0.02
0.35	0.05	0.02
0.35	0.05	0.02
0.96	0.15	0.09
0.96	0.15	0.09
5.09	2.63	0.44
5.09	2.63	0.44

UPDATE: After a month I’ve reverted to kernel 5.15.85 due to apparent ACPI issues.

  • Hybrid sleep consistently crashed on waking.
  • Laptop ran down battery on suspend (just like to bad old days).
  • Hibernate didn’t.

Hibernate is working again with 5.15.85, though suspend and hybrid-sleep don’t seem to be. Need to get some time to jump into the system logs.

UPDATE AGAIN: I’ve been on kernel 6.1.7 for a few weeks and all previous issues are gone.

Fedora 37 on 6.0.16-300 here on a i5-1135G7. I can’t say I’ve noticed any crazy rundown on suspend (S3), but I haven’t been paying much attention. Just have been able to, while on vacation, use the laptop unplugged daily, and also leave it on S3 sleep often, without it running down before I had another chance to plug it in again.

What kind of rates are you seeing (that are a regression from the 5.x series)?

I’m on BIOS 3.17 with extension slots configured as: 1x USB-A, 1xUSB-C, 1xHDMI, 1xMicroSD.

(edited to fix the BIOS version - I’m on the latest, 3.17)

As I am doing power testing and documentation this week (and into next), I am following this thread closely.

1 Like

In my looking out for improvements in 6.0.x and 6.1.x, aside from what the community has discovered with the expansion cards

It seems the next two targets are on locking down what nvme drives can handle what in terms of alpm. And how to minimize power consumption of the nic (AX210 here).

SSD (Samsung 980 pro)

When looking into the ssd I am noticing that my ssd is quirking to simplle suspend regardless to the nvme.noacpi=1 or not.
I did mess with some of the debugging steps found for other laptops.

After finding this in my kernel logs

dmesg | grep nvme
[    2.861076] nvme 0000:01:00.0: platform quirk: setting simple suspend

Arch wiki also had some useful tool recommendations to get information on what power states my ssd (Samsung 980 pro) supports.

# nvme get-feature /dev/nvme0 -f 0x0c -H
get-feature:0x0c (Autonomous Power State Transition), Current value:0x00000001
	Autonomous Power State Transition Enable (APSTE): Enabled
$ sudo smartctl -c /dev/nvme0
smartctl 7.3 2022-02-28 r5338 [x86_64-linux-6.1.7-200.fc37.x86_64] (local build)
Copyright (C) 2002-22, Bruce Allen, Christian Franke, www.smartmontools.org

Firmware Updates (0x16):            3 Slots, no Reset required
Optional Admin Commands (0x0017):   Security Format Frmw_DL Self_Test
Optional NVM Commands (0x0057):     Comp Wr_Unc DS_Mngmt Sav/Sel_Feat Timestmp
Log Page Attributes (0x0f):         S/H_per_NS Cmd_Eff_Lg Ext_Get_Lg Telmtry_Lg
Maximum Data Transfer Size:         128 Pages
Warning  Comp. Temp. Threshold:     82 Celsius
Critical Comp. Temp. Threshold:     85 Celsius

Supported Power States
St Op     Max   Active     Idle   RL RT WL WT  Ent_Lat  Ex_Lat
 0 +     8.49W       -        -    0  0  0  0        0       0
 1 +     4.48W       -        -    1  1  1  1        0     200
 2 +     3.18W       -        -    2  2  2  2        0    1000
 3 -   0.0400W       -        -    3  3  3  3     2000    1200
 4 -   0.0050W       -        -    4  4  4  4      500    9500

NIC (Intel AX210)

In regards to the AX210, I have added the following kernel parameters in /etc/default/grub

iwlwifi.power_save=Y iwldvm.force_cam=N

Strangely, enabling the power saving features for this card dramatically increased my throughput. I’m talking triple the uplink speeds and 20% faster downlink speeds.

@mikeymop on Fedora 37 here, with the same hardware (11 gen and AX210), I see iwlmvm, not iwldvm, being loaded.

$ lsmod |grep iwl
iwlmvm                528384  0
mac80211             1298432  1 iwlmvm
iwlwifi               413696  1 iwlmvm
cfg80211             1101824  3 iwlmvm,iwlwifi,mac80211
rfkill                 36864  9 iwlmvm,bluetooth,cfg80211

I haven’t done anything special with module configuration, that just seems to be the default (using the new shinier driver). Running kernel 6.1.8-200.fc37.x86_64.

Following for updates.