[SOLVED] High power consumption 1340p on idle (KDE Neon)

I am very very disappointed after upgrading to 13th gen from 11th gen. Not only the cooler can’t handle this beast on load (it gets to 100 degrees very often on full fan), but idle consumption is just awful.

The 11th gen could do 7W easily (and that’s with 2 active expansion cards), while the 13th gen can’t go below ~10W (with the same cards).

I tried everything, pls help meeeeee…

I contacted the support and they told me it’s my fault because I don’t use Ubuntu, even though I’ve proven to them that I have the same problem on Ubuntu Live as on my Neon and they are almost the same thing.

I did this:
Optimizing Ubuntu Battery Life

No change. I also did this:

It reduced consumption on use, but not on idle, which makes sense.

I checked other interrupts, and can’t find anything.

I also turned my laptop into dual-core.

Still no change, so locked those cores to 400Mhz.

Still nothing. I don’t know where to look anymore. I have nvme.noacpi in grub and C states look good, I also had to ignore acpi wakeups because the laptop was waking up itself from sleep, but idk whether this is related.

echo "XHCI" > /proc/acpi/wakeup
echo "TDM0" > /proc/acpi/wakeup
echo "TDM1" > /proc/acpi/wakeup
echo "TXHC" > /proc/acpi/wakeup

At this point, I expect some sort of hardware or firmware bug. This really looks bad. There is sooo many issues with those laptops. I am not going to buy anything for it in the future. The main reasons I’ve chosen it were the nice display and lack of Windows preinstalled, but my experience with everything else is terrible so far (including expansion modules that cause more trouble than they are useful).

Right now I just want to get it to not eat so much power. If anyone knows anything, pls help.

Could you check the package power draw using intel_gpu_top? I’m sorry you’ve had such a bad experience!

intel_gpu_top doesn’t show power, just as if this was not a supported metrics on this platform

Wow, I reinstalled intel-gpu-tools package and now apparently intel_gpu_top is not even in there. Intel made a cool overlay now.

Package is about 2W with occasional spikes to 3W ~ 4W.
(Powertop is wrong about SD Card reader, it’s 1W. I unplugged it and checked)

For what it’s worth, I have a 1340p and my power usage averages 6-7W with occasional dips to 4W (granted, with 25% brightness, but still).

I don’t know what to tell you. I looked at your powertop screenshots and I don’t see anything obviously wrong with them (other than the overall power consumption, that is). I feel like we need more info to narrow it down…

I would reenable all cores as disabling them doesn’t seem to help you yet it results in a very unusual config.

What’s your power draw when you remove all the expansion cards?

Do you have TLP installed? If so, can you provide the output of tlp-stat?

Have you tried turbostat? It’s part of the linux kernel sources (under tools/power/x86/turbostat) if you can’t find a recent version packaged up (kernel 6.4 includes version 2023.03.17). It spits up too much info by default for a regular human being to process but maybe you’ll spot something there. For me on idle PkgWatt is around 1W with occasional 2W spikes. What’s your package C state? Are you at least in pc8 much of the time? I saw a suspiciously low graphics RC6 percentage in your last screenshot; is that how it usually is? For me turbostat consistently shows >99%…

I believe it shows power in the upper right corner, at least last time I used it, it did!

Also a which version of the Linux Kernel are you on? Only newer Kernels support Intel’s 12th/13th gen proccessors task manager, and also contain some power managing features iirc!

Good point about the kernel version. intel_gpu_top definitely does show power for me on this platform. That’s with igt-gpu-tools version 1.27.1, which appears to be the latest official release (Tags · drm / igt-gpu-tools · GitLab). I’m on kernel 6.4.7.

I disabled the cores only for testing, I don’t use it like that, however, it tames the best, ie it always stays at that 11W and it doesn’t heat up to 100 degrees under load.

Expansion cards draw only less than 1W each, so removing them reduces the power draw to ~9W.

I did the tutorial from the link in the first post, so yes, I do have tlp. Tlp-stats below.

I didn’t show power for me.

I am at the 6.2.0-26-generic, but I had the same issue on 5.19 and 5.15.

--- TLP 1.5.0 --------------------------------------------

+++ Configured Settings:
defaults.conf L0004: TLP_ENABLE="1"
defaults.conf L0005: TLP_WARN_LEVEL="3"
defaults.conf L0006: TLP_PERSISTENT_DEFAULT="0"
defaults.conf L0007: DISK_IDLE_SECS_ON_AC="0"
defaults.conf L0008: DISK_IDLE_SECS_ON_BAT="2"
defaults.conf L0009: MAX_LOST_WORK_SECS_ON_AC="15"
defaults.conf L0010: MAX_LOST_WORK_SECS_ON_BAT="60"
/etc/tlp.conf L0124: CPU_ENERGY_PERF_POLICY_ON_AC="performance"
/etc/tlp.conf L0125: CPU_ENERGY_PERF_POLICY_ON_BAT="power"
defaults.conf L0013: SCHED_POWERSAVE_ON_AC="0"
defaults.conf L0014: SCHED_POWERSAVE_ON_BAT="1"
defaults.conf L0015: NMI_WATCHDOG="0"
defaults.conf L0016: DISK_DEVICES="nvme0n1 sda"
defaults.conf L0017: DISK_APM_LEVEL_ON_AC="254 254"
defaults.conf L0018: DISK_APM_LEVEL_ON_BAT="128 128"
defaults.conf L0019: DISK_APM_CLASS_DENYLIST="usb ieee1394"
defaults.conf L0020: DISK_IOSCHED="keep keep"
defaults.conf L0021: SATA_LINKPWR_ON_AC="med_power_with_dipm max_performance"
defaults.conf L0022: SATA_LINKPWR_ON_BAT="med_power_with_dipm min_power"
defaults.conf L0023: AHCI_RUNTIME_PM_ON_AC="on"
defaults.conf L0024: AHCI_RUNTIME_PM_ON_BAT="auto"
defaults.conf L0025: AHCI_RUNTIME_PM_TIMEOUT="15"
defaults.conf L0026: PCIE_ASPM_ON_AC="default"
/etc/tlp.conf L0364: PCIE_ASPM_ON_BAT="powersupersave"
/etc/tlp.conf L0314: RADEON_DPM_PERF_LEVEL_ON_AC=""
/etc/tlp.conf L0315: RADEON_DPM_PERF_LEVEL_ON_BAT=""
/etc/tlp.conf L0329: RADEON_POWER_PROFILE_ON_AC=""
/etc/tlp.conf L0330: RADEON_POWER_PROFILE_ON_BAT=""
defaults.conf L0032: WIFI_PWR_ON_AC="off"
/etc/tlp.conf L0336: WIFI_PWR_ON_BAT="off"
defaults.conf L0034: WOL_DISABLE="Y"
defaults.conf L0035: SOUND_POWER_SAVE_ON_AC="1"
defaults.conf L0036: SOUND_POWER_SAVE_ON_BAT="1"
defaults.conf L0037: SOUND_POWER_SAVE_CONTROLLER="Y"
defaults.conf L0038: BAY_POWEROFF_ON_AC="0"
defaults.conf L0039: BAY_POWEROFF_ON_BAT="0"
defaults.conf L0040: BAY_DEVICE="sr0"
defaults.conf L0041: RUNTIME_PM_ON_AC="on"
defaults.conf L0042: RUNTIME_PM_ON_BAT="auto"
/etc/tlp.conf L0387: RUNTIME_PM_DRIVER_DENYLIST=""
defaults.conf L0044: USB_AUTOSUSPEND="1"
defaults.conf L0045: USB_EXCLUDE_AUDIO="1"
defaults.conf L0046: USB_EXCLUDE_BTUSB="0"
defaults.conf L0047: USB_EXCLUDE_PHONE="0"
defaults.conf L0048: USB_EXCLUDE_PRINTER="1"
defaults.conf L0049: USB_EXCLUDE_WWAN="0"
defaults.conf L0051: RESTORE_DEVICE_STATE_ON_STARTUP="0"
defaults.conf L0052: RESTORE_THRESHOLDS_ON_BAT="0"
defaults.conf L0053: NATACPI_ENABLE="1"
defaults.conf L0054: TPACPI_ENABLE="1"
defaults.conf L0055: TPSMAPI_ENABLE="1"
/etc/tlp.conf L0087: CPU_SCALING_GOVERNOR_ON_AC="performance"
/etc/tlp.conf L0088: CPU_SCALING_GOVERNOR_ON_BAT="powersave"
/etc/tlp.conf L0134: CPU_MIN_PERF_ON_AC="0"
/etc/tlp.conf L0135: CPU_MAX_PERF_ON_AC="100"
/etc/tlp.conf L0136: CPU_MIN_PERF_ON_BAT="0"
/etc/tlp.conf L0137: CPU_MAX_PERF_ON_BAT="30"
/etc/tlp.conf L0149: CPU_BOOST_ON_AC="1"
/etc/tlp.conf L0150: CPU_BOOST_ON_BAT="0"
/etc/tlp.conf L0158: CPU_HWP_DYN_BOOST_ON_AC="1"
/etc/tlp.conf L0159: CPU_HWP_DYN_BOOST_ON_BAT="0"
/etc/tlp.conf L0189: PLATFORM_PROFILE_ON_AC="performance"
/etc/tlp.conf L0190: PLATFORM_PROFILE_ON_BAT="low-power"
/etc/tlp.conf L0302: INTEL_GPU_MIN_FREQ_ON_AC="100"
/etc/tlp.conf L0303: INTEL_GPU_MIN_FREQ_ON_BAT="100"
/etc/tlp.conf L0304: INTEL_GPU_MAX_FREQ_ON_AC="1500"
/etc/tlp.conf L0305: INTEL_GPU_MAX_FREQ_ON_BAT="800"
/etc/tlp.conf L0306: INTEL_GPU_BOOST_FREQ_ON_AC="1500"
/etc/tlp.conf L0307: INTEL_GPU_BOOST_FREQ_ON_BAT="1000"

+++ System Info
System         = Framework A4 Laptop (13th Gen Intel Core)
BIOS           = 03.03
OS Release     = KDE neon 5.27
Kernel         = 6.2.0-26-generic #26~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Thu Jul 13 16:27:29 UTC 2 x86_64
/proc/cmdline  = BOOT_IMAGE=/boot/vmlinuz-6.2.0-26-generic root=UUID=0719daf5-3d44-47f2-bb69-13471a992566 ro text mem_sleep_default=deep nvme.noacpi=1 module_blacklist=hid_sensor_hub
Init system    = systemd v249 (249.11-0ubuntu3.9)
Boot mode      = UEFI

+++ TLP Status
State          = enabled
RDW state      = enabled
Last run       = 21:36:43,    144 sec(s) ago
Mode           = battery
Power source   = battery

+++ Processor
CPU model      = 13th Gen Intel(R) Core(TM) i5-1340P

/sys/devices/system/cpu/cpu0/cpufreq/scaling_driver    = intel_pstate
/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor  = powersave
/sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors = performance powersave
/sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq  =   400000 [kHz]
/sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq  =  1900000 [kHz]
/sys/devices/system/cpu/cpu0/cpufreq/energy_performance_preference = power [HWP.EPP]
/sys/devices/system/cpu/cpu0/cpufreq/energy_performance_available_preferences = default performance balance_performance balance_power power 

/sys/devices/system/cpu/cpu1..cpu15: omitted for clarity, use -v to show all

/sys/devices/system/cpu/intel_pstate/status            = active
/sys/devices/system/cpu/intel_pstate/min_perf_pct      =  10 [%]
/sys/devices/system/cpu/intel_pstate/max_perf_pct      =  30 [%]
/sys/devices/system/cpu/intel_pstate/no_turbo          =   1
/sys/devices/system/cpu/intel_pstate/hwp_dynamic_boost =   0
/sys/devices/system/cpu/intel_pstate/turbo_pct         = (not available) 
/sys/devices/system/cpu/intel_pstate/num_pstates       = (not available)

/sys/module/workqueue/parameters/power_efficient       = Y
/proc/sys/kernel/nmi_watchdog                          = 0

+++ Platform Profile
/sys/firmware/acpi/platform_profile                    = (not available)
/sys/firmware/acpi/platform_profile_choices            = (not available)

+++ Temperatures
CPU temp               =    47 [°C]
Fan speed              = (not available)

+++ File System
/proc/sys/vm/laptop_mode               =     2
/proc/sys/vm/dirty_writeback_centisecs =  6000
/proc/sys/vm/dirty_expire_centisecs    =  6000
/proc/sys/vm/dirty_ratio               =    20
/proc/sys/vm/dirty_background_ratio    =    10

+++ Disks
Devices = nvme0n1 sda

  Type       = NVMe
  Disk ID    = nvme-WDS500G1X0E-00AFY0_21152R801585
  Model      = WDS500G1X0E-00AFY0                      
  Firmware   = 614300WD
  Temp       = 36 °C
  Scheduler  = [none] mq-deadline (multi queue)

  Runtime PM:
    /sys/block/nvme0n1/device/power/control = auto, autosuspend_delay_ms = (not available)

  SMART info:
    Critical Warning:                   0x00
    Temperature:                        36 Celsius
    Available Spare:                    100%
    Available Spare Threshold:          10%
    Percentage Used:                    0%
    Data Units Written:                 11 979 725 [6.13 TB]
    Power Cycles:                       2 587
    Power On Hours:                     5 055
    Unsafe Shutdowns:                   105
    Media and Data Integrity Errors:    0

  Type       = USB
  Disk ID    = usb-SMI_USB_DISK_AA00000000015055-0:0
  Model      = SMI USB DISK
  Firmware   = unknown
  APM Level  = none/disabled
  Status     = standby
  Scheduler  = none [mq-deadline] (multi queue)

  Runtime PM:
    /sys/block/sda/device/power/control = auto, autosuspend_delay_ms = 15000

+++ Intel Graphics
/sys/class/drm/card0/device/driver           = i915

/sys/class/drm/card0/power/rc6_enable        =  1 (enabled)
/sys/kernel/debug/dri/0/i915_fbc_status      = FBC disabled: pixel format not supported
/sys/kernel/debug/dri/0/i915_edp_psr_status  = PSR mode: disabled

/sys/class/drm/card0/gt_min_freq_mhz         =   100 [MHz]
/sys/class/drm/card0/gt_max_freq_mhz         =   800 [MHz]
/sys/class/drm/card0/gt_boost_freq_mhz       =  1000 [MHz]
/sys/class/drm/card0/gt_RPn_freq_mhz         =   100 [MHz] (GPU min)
/sys/class/drm/card0/gt_RP0_freq_mhz         =  1450 [MHz] (GPU max)

+++ Other Graphics
/sys/class/drm/card1/device/driver           = evdi

/sys/class/drm/card2/device/driver           = evdi

/sys/class/drm/card3/device/driver           = evdi

/sys/class/drm/card4/device/driver           = evdi

+++ Wireless
bluetooth = off (software)
nfc       = none (no device)
wifi      = on
wwan      = none (no device)

hci0(btusb)                   : bluetooth, not connected
wlp170s0(iwlwifi)             : wifi, connected, power management = on

+++ Audio
/sys/module/snd_hda_intel/parameters/power_save            = 1
/sys/module/snd_hda_intel/parameters/power_save_controller = Y

+++ PCIe Active State Power Management
/sys/module/pcie_aspm/parameters/policy = default performance powersave [powersupersave]

+++ PCIe Runtime Power Management
Enable devices    = (disabled)
Disable devices   = (disabled)
Device denylist   = (disabled)
Driver denylist   = (disabled)

/sys/bus/pci/devices/0000:00:00.0/power/control = auto (0x060000, Host bridge, no driver)
/sys/bus/pci/devices/0000:00:02.0/power/control = auto (0x030000, VGA compatible controller, i915)
/sys/bus/pci/devices/0000:00:04.0/power/control = auto (0x118000, Signal processing controller, proc_thermal_pci)
/sys/bus/pci/devices/0000:00:06.0/power/control = auto (0x060400, PCI bridge, pcieport)
/sys/bus/pci/devices/0000:00:07.0/power/control = auto (0x060400, PCI bridge, pcieport)
/sys/bus/pci/devices/0000:00:07.1/power/control = auto (0x060400, PCI bridge, pcieport)
/sys/bus/pci/devices/0000:00:07.2/power/control = auto (0x060400, PCI bridge, pcieport)
/sys/bus/pci/devices/0000:00:07.3/power/control = auto (0x060400, PCI bridge, pcieport)
/sys/bus/pci/devices/0000:00:08.0/power/control = auto (0x088000, System peripheral, no driver)
/sys/bus/pci/devices/0000:00:0a.0/power/control = auto (0x118000, Signal processing controller, intel_vsec)
/sys/bus/pci/devices/0000:00:0d.0/power/control = auto (0x0c0330, USB controller, xhci_hcd)
/sys/bus/pci/devices/0000:00:0d.2/power/control = auto (0x0c0340, USB controller, thunderbolt)
/sys/bus/pci/devices/0000:00:0d.3/power/control = auto (0x0c0340, USB controller, thunderbolt)
/sys/bus/pci/devices/0000:00:14.0/power/control = auto (0x0c0330, USB controller, xhci_hcd)
/sys/bus/pci/devices/0000:00:14.2/power/control = auto (0x050000, RAM memory, no driver)
/sys/bus/pci/devices/0000:00:15.0/power/control = auto (0x0c8000, Serial bus controller, intel-lpss)
/sys/bus/pci/devices/0000:00:15.1/power/control = auto (0x0c8000, Serial bus controller, intel-lpss)
/sys/bus/pci/devices/0000:00:15.3/power/control = auto (0x0c8000, Serial bus controller, intel-lpss)
/sys/bus/pci/devices/0000:00:16.0/power/control = auto (0x078000, Communication controller, mei_me)
/sys/bus/pci/devices/0000:00:16.3/power/control = auto (0x070002, Serial controller, serial)
/sys/bus/pci/devices/0000:00:1d.0/power/control = auto (0x060400, PCI bridge, pcieport)
/sys/bus/pci/devices/0000:00:1f.0/power/control = auto (0x060100, ISA bridge, no driver)
/sys/bus/pci/devices/0000:00:1f.3/power/control = auto (0x040380, Audio device, snd_hda_intel)
/sys/bus/pci/devices/0000:00:1f.4/power/control = auto (0x0c0500, SMBus, i801_smbus)
/sys/bus/pci/devices/0000:00:1f.5/power/control = auto (0x0c8000, Serial bus controller, intel-spi)
/sys/bus/pci/devices/0000:01:00.0/power/control = auto (0x010802, Non-Volatile memory controller, nvme)
/sys/bus/pci/devices/0000:aa:00.0/power/control = auto (0x028000, Network controller, iwlwifi)

+++ USB
Autosuspend       = enabled
Device allowlist  = (not configured)
Device denylist   = (not configured)
Exclude audio     = enabled
Exclude bluetooth = disabled
Exclude phones    = disabled
Exclude printers  = enabled
Exclude WWAN      = disabled

Bus 004 Device 001 ID 1d6b:0003 control = auto, autosuspend_delay_ms =    0 -- Linux Foundation 3.0 root hub (hub)
Bus 003 Device 002 ID 27c6:609c control = auto, autosuspend_delay_ms = 2000 -- Shenzhen Goodix Technology Co.,Ltd. Goodix USB2.0 MISC (no driver)
Bus 003 Device 003 ID 8087:0032 control = auto, autosuspend_delay_ms = 2000 -- Intel Corp. AX210 Bluetooth (btusb)
Bus 003 Device 001 ID 1d6b:0002 control = auto, autosuspend_delay_ms =    0 -- Linux Foundation 2.0 root hub (hub)
Bus 002 Device 003 ID 090c:3350 control = auto, autosuspend_delay_ms = 2000 -- Silicon Motion, Inc. - Taiwan (formerly Feiya Technology Corp.) USB DISK (usb-storage)
Bus 002 Device 001 ID 1d6b:0003 control = auto, autosuspend_delay_ms =    0 -- Linux Foundation 3.0 root hub (hub)
Bus 001 Device 001 ID 1d6b:0002 control = auto, autosuspend_delay_ms =    0 -- Linux Foundation 2.0 root hub (hub)

+++ Battery Care
Plugin: generic
Supported features: none available

+++ Battery Status: BAT1
/sys/class/power_supply/BAT1/manufacturer                   = NVT
/sys/class/power_supply/BAT1/model_name                     = Framewo
/sys/class/power_supply/BAT1/cycle_count                    =    145
/sys/class/power_supply/BAT1/charge_full_design             =   3572 [mAh]
/sys/class/power_supply/BAT1/charge_full                    =   3072 [mAh]
/sys/class/power_supply/BAT1/charge_now                     =   3047 [mAh]
/sys/class/power_supply/BAT1/current_now                    =    635 [mA]
/sys/class/power_supply/BAT1/status                         = Discharging

/sys/class/power_supply/BAT1/charge_control_start_threshold = (not available) 
/sys/class/power_supply/BAT1/charge_control_end_threshold   = (not available) 

Charge                                                      =   99.2 [%]
Capacity                                                    =   86.0 [%]
1 Like

Wait. I realized, that I upgraded to 6.2 just now

1 Like

Yep, it was a kernel thing. Neon gets updates a bit after Ubuntu does and Ubuntu LTS was also stuck on 5.19.

6.2 reduces consumption to ~7W and ~9W with expansion cards, which are expected values from a Frame.work laptop.

Also, the power reading in intel_gpu_top now works.

The sad part is that no one ever mentioned that anywhere before. Anyway, thx guys for help.


Hi @Wiktor_Tomanek , tagging this as solved. cheers!

Thanks guys for the help.