[RESPONDED] Thunderbolt dock not recognize


I have a Framework Laptop 11th with Windows 11.
Since severals days, my laptop does not recognize my thunderbolt dock (Belkin Thunderbolt 3 Pro Dock).
I use this dock since 6 months and suddenly after reconnecting, does not recognize my dock.
It does not even charge anymore.
I tried to:

  • Update Windows
  • Reinstalle Thunderbolt driver from Windows drivers package
  • Update BIOS with last (Beta) BIOS
  • Buy a new Thunderbolt cable
  • Try my dock with my Lenovo professionnal laptop (it’s works)
  • Try my Framework Laptop with another dock
  • Try to connect my dock directly on USB C port (without dongle)

My laptop works with another dock BUT I think this one is recognized in USB C mode because in the Thunderbolt control center, it is not identified.

Is my dock dying or the problem is from the Framework laptop ?

Thanks in advance



I think it’s related to other issues people have been getting due to the firmware updates. Left hand tb seem to be unable to use display port alt mode but can use pd. Right tb can connect but that’s it. Since you use Windows It seem likely it’s in the firmware instead of OS related.

I have two posts on the topic that I think are related. And one from the framework team by @nrp I believe. But haven’t found it yet. Will edit it in later. My bad it was by @Kieran_Levin

See below link. Where you can see other people having similar issues.

Some other possible related topics.


Thank’s for your reply but I had this problem before firmware upgrade and before any action.

I will look at the topics that you share.

Thank’s !!

Yeah but you also upgraded the firmware/bios which it seems like it introduced another issue. To check if it’s your dock I would try another machine with the old dock to see if the behaviour persists.

There is also the third option. It’s the firmware AND the dock. Good luck! If you find a solution do post it.

I just tried to downgrade firmware from 3.17 to 3.10 AND fully resetting the mainboard state but it doesn’t work.

Please note that the retimers issue has to do with the 12th gen bios, and not the 11th gen. Your bios versions shouldn’t be affecting your tb ports. I would stay on 3.17 for a bevy of other improvements the latest have included.

1 Like


I’ll keep you posted.
I contacted the support and after several manipulations, the conclusion is that the 11th is not fully compatible with TB.

I don’t know what to do because I use the TB every day with my dock.


Hi @GIMENEZ_Alexis,

That is correct, 11th Gen Intel Core Framework Laptops are not Thunderbolt certified and only the 12th Gen Intel Core Framework Laptops have that certification as mentioned in our blog post located here: Framework | Framework Laptops now have 4 Thunderbolt 4 ports

Framework Laptops with 12th Gen Intel Core processors (including the Chromebook Edition) are now Thunderbolt 4 certified on all four Expansion Card bays when updated to our next firmware release.”