[RESPONDED] Ubuntu 20.04.4 LTS on the Framework Laptop

Ubuntu 20.04.4 LTS is now available and works out of the box.


You can follow the guide.


:white_check_mark: Wifi works
:white_check_mark: Bluetooth works
:white_check_mark: Fingerprint Scanner works (hardware issue of erasing old fingerprint scans fixed here)
:white_check_mark: PSR / Panel Self Refresh disablement is no longer necessary

Here is the link to the release: Ubuntu 20.04.6 LTS (Focal Fossa)

20.04.3 LTS

On 20.04.3 LTS, additional workarounds were required

Update, Most of the initial tweaking can be handled by @lightrush 's Saltstack, found HERE (read the whole thing first)

NOTE: WiFi and fingerprint reader workarounds are no longer needed as long as you get the latest updates for Ubuntu 20.04 (as of Jan 18th 2022)

The following portion of this post is not necessary if using lightrush’s method

So, Here is the quick rundown for those installing, now that most of the issues seem to be easily resolved. Addition config time beyond base install: ~5 minutes

  1. Get wifi going:
    The following works a treat! (just be sure the paths to the directory match up)
  1. Resolve sleep battery drain:



@Skye_Leake were you able to install it and validate that it works?

I just received my framework laptop today and installed 21.04.3 with no luck on getting wifi working. I’ve tried installing the intel drivers from the post on this forum, but don’t have a wifi option in the settings to configure. I confirmed the drivers are in the /lib/firmware folder.

I also ran lspci and don’t see the hardware listed in addition to running lshw -c network.

Side note- Bluetooth is working, which I believe is using the same card, right? If so, seems my physical install is in order.

Any thoughts or ideas on where I go next?


1 Like

@MikeL On a Mint install, I had to upgrade the kernel to 5.11.0-25 for the Wifi to work, and there have been some reports of regressions in the Wifi support from higher versions of the kernel - maybe trying different kernel versions may iron out the kink?

1 Like

Tried rolling it back to 5.11.0-25 with no luck. Unfortunately when I did, the trackpad stopped working as well. I am currently back to running 5.11.0-27 with the trackpad working again, but no progress on wifi. I allowed 3rd party drivers when I installed Ubuntu, so may go back and try a clean install with standard drivers. Any other thoughts?

Is anyone running the Framework on 20.04.3 with wifi success?


Is there a way for you to jump forward to kernel 5.12.19? My BT and WiFi work fine with this kernel and nixOS. (If I recall correctly, 5.13 broke BT again.)


I’ve updated the kernel to 5.12.19 and still cannot see the wireless network interface. Bailing on 20.04.3 in leu of 21.04, where the wireless was detected immediately. Thanks for all the advice from all!

@MikeL you may find helpful details in this thread: https://community.frame.work/t/linux-users-dont-upgrade-to-5-13. It mentions installing Intel drivers, but I did not do that.

BT and WiFi are on the same NVMe card. I would expect the OS to detect WiFi if it can see BT. Have you looked through dmsg for clues?

I would suggest you try booting from install media if you can find one with the right kernel. (Maybe Manjaro?) I’ve read that WiFi works with kernel 5.13 – that might be a way to verify the WiFi hardware is working.

Possibly the nixOS install media will work with WiFi. If that works for you, I’m happy to help you configure a nixOS installation with kernel 5.12.19. Checkout this article for info on that: NixOS on the Framework - Graham Christensen.

1 Like

@ericgundrum thank you for the offer and help so far. I confirmed the card is not the issue with 21.04. I was foolishly trying the LTS, which was making it harder in the long run. Things are looking good now with 21.04. Thanks again!


@MikeL glad to here it is working for you. Be sure to test the BT before you really need it, just in case it is not working with that OS. :slight_smile:


Still waiting on hardware, and will be for another week or two.

I just tried out 20.04.3 as well, and can confirm that WiFi did not work, and Bluetooth only partially worked. We recommend sticking with 21.04 for now, or using an older WiFi card instead of the AX210.


@ericgundrum Confirmed bluetooth working great! Has good distance and sounds great on Bose BT earbuds. Been listening to music for a few hours to ensure long term connectivity and it’s looking good. (21.04)

Thanks again!

1 Like

Hardware should be shipped to me in a few days.
I am no Linux Guru, but I think I am gonna give 20.04.3 a try with an older wireless card, assuming I have time I will fiddle with it.

Plan is to use an Intel 9560AC, (20ish dollar part form 2018 timeframe)
I don’t have any other wifi-6 capable hardware so I am not really missing out. I’ll let you all know how my little experiment goes.

1 Like

For the Linux Minters out there, if there are any others, from a baseline Mint xfce 20.2 with kernel 5.11.0-25, the apt update/upgrade today raises the linux-firmware version to 1.187.16. It seems to have a regression for the AX210 (noted in the Ubuntu bugtracker already https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1941044).

For now used timeshift to recover and am just holding this package back, and things seem to work OK.


It should be noted that Ubuntu 21.04 is using 5.11.0-31 and this works out of the box with wifi and bluetooth.


Yes, this allows the iwlwifi driver to load. It then seems to work OK on my 2.4GHz network but flickers on my 5GHz network.

The kernel bug thread for the 5GHz problem has someone suggesting that it’s a flawed AP to blame - updating the firmware on my router (a Netgear Nighthawk) has indeed seemed to fix this for me in that I can remain connected. Speeds are not great though.

I am using 20.04.3 on my framework laptop. I did not run the installer though - I had the drive ready installed from my desktop in preparation for the laptop arriving so I do not know if the installer would work.

It is necessary to move the /usr/lib/firmware/iwlwifi-ty-a0-gf-a0.pnvm file aside for the ax210 wifi to work. As noted above I also had to update my router firmware to get the wifi to be stable - if you see the message “No beacon heard and the session protection is over already…” in dmesg, that’s how I fixed it.

I couldn’t initially log-in, possibly because it was trying an X desktop and I’d previously used the install with an nvidia GPU. Switching to wayland fixed that.

Bluetooth works fine for headphones. Also works with an xbox elite series 2 controller in steam (with the usual changes that requires).

Touchpad works in what I’d call semi-multitouch mode. I have multitouch scrolling but any number of finger clicks is interpreted as a left-button click except for the front-middle and front-right areas of the touchpad. I can get used to this I think. I have turned off PS/2 emulation in the bios but I don’t know if that helped anything as I didn’t try with it on.

Speakers work fine, volume hotkeys work fine, backlight hotkeys work fine, airplane mode and screenshot keys work fine, framework-logo key opens rhythmbox, media-transport keys all work fine.

I haven’t bothered to try and set up the fingerprint sensor.

I ran geekbench 5 and here are the results.

I’m using the i5-1135G7 DIY kit with the framework-supplied AX210 no vPro wifi card and the framework-supplied 2x8GB RAM kit. I used this SSD because of its low power-draw.

Overall, no complaints and certainly a nice upgrade from my previous machine (a 2015-era MacBook 12").

1 Like

Could you elaborate slightly? What do you mean by aside?

(My linux experience is very… One dimensional.)

I mean do what Random_User said here: Ubuntu 20.04.3 LTS on the Framework Laptop - #17 by RandomUser