[RESPONDED] Ubuntu 23.10/Kernel 6.5/FW 3.03 -- load-driven RGB display static

I had RGB static similar to what you have, after I upgraded my mainboard from Intel 13th gen to AMD 7640U. In my case, disconnecting and reconnecting the display cable to the mainboard fixed it. I see you already tried that, though, so I have no other suggestions.

At any rate, I would think this isn’t a software issue (i.e. it’s not an issue with the distro or the kernel or the display drivers), but instead a hardware issue.

1 Like

Finally got around to a memtest, had to disable secure boot. It ran twice and passed with 0 issues.

However, after rebooting, my boot drive can no longer be found, and i was presented with this message:

So i re-enabled secure boot and rebooted again. Same message.

Then i go to thu boot manager, and see:

So it … Kinda looks like my mainboard is falling apart? :frowning:

Memtest shouldn’t cause the drive to not be detected at all, yeah?

Is there a place to double check the drive in the uefi/bios somewhere?
Settings are pretty slim.

so this is weird – I finally made an install USB to try re-installing and the computer found my boot disk, and booted as normal!

very puzzling, tho I’m thankful I still have a successful boot. I’m going to try the “repair mode” on ubuntu’s install media if that exists tho… since the way i got to 23.10 is quite goofy.

Memtest should not, but switching the boot mode from uefi to bios could make a uefi install not show up as a boot option.

i don’t believe I did this.

Unless memtest did it on its own.

It’s no matter now tho, I’m back to the original problem of RGB static.
How would I debug which hardware the issue could be?

  • mainboard
  • display
  • ?

Given memtest passed, reseating the display cable sounds like a reasonable next step (low effort and really hard to exclude otherwise).

Did not see an indication if this was tested (I may have missed this if you did).

1 Like

I did try it before my trip, but I can try it again when I get back. (I didn’t bring the super handy screwdriver with me :smiley: (for real, it’s super nice, thank you!))

1 Like

Awesome, appreciate it.

@Matt_Hartley, re-did this, and took a bunch of pictures of the quality of the connector / cable routing, too (I don’t know what to look for, so hopefully the pictures are sufficient)





RGB static still exists tho. What other debugging techniques can I try?
I’m still skeptical of the possibility of a hardware issue because of the Manjaro Linux link from above mentioning some fix in Kernel 6.6.

Appreciate the images. I agree, if it’s working on Manjaro, it’s not going to be a hardware issue. As stated here, just to clarify:

We are only testing again 22.04.3 using OEM C kernel per the guide. 6.2 and while there are mixed results, whatever the latest happens to be on 23.10 happens to be using are not tested - at all.

If 22.04.3 feels long in the tooth and dated, we recommend giving Fedora 39 as spin - works very well with kernel 6.5.11-300.

I’ll at the very least try a live USB with Fedora 39, as the issue is present on any iso i’ve booted so far (ubuntu only so far)

1 Like

I just tried following the instructions here: https://github.com/FrameworkComputer/linux-docs/blob/main/ubuntu-22.04-amd-fw13.md#this-is-for-amd-ryzen-7040-series-configuration-on-the-framework-laptop-13-only
(new installation)

but I still have RGB static.

Same with Fedora 39 (since I have an empty disk, why not try installing all the things! (separately, with erasing))

I think the only last thing I can try is to try to rule out if it’s a display issue by temporarily connecting the display from the other frame.work laptop to this one’s mainboard, and seeing if the problem is the same (which would reveal display is fine, mainboard or software has issues).

I tried hooking up a known working display and received diagnostic blinks from My Framework Laptop (Intel 11th Gen Intel® Core™) is not powering on (I see this says 11th gen intel, but I couldn’t find a guide for AMD)

Blink 12 was red, which is (not) Internal display initialized OK

Switching back to the display the AMD shipped with boots, but still has RGB Static

Located your ticket (RMA), doesn’t looked blocked. Nov 27 (today) they just emailed your a status update on the ticket. It’s in an active ticket queue.

1 Like

I just created a ticket a few minutes ago with the same symptoms.
Difficulty: I use Windows 11.

It seems fine until Windows takes over. Then I get RGB static all over the place. I wondered if it might be grounding, so I removed and reinstalled screws to see if that might help. It seemed to help a little?

I also noticed that external displays are not affected, including Displayport displays via MST. Digitally-speaking, everything seems fine.

I also see RGB (mostly green, some red) static on the laptop screen, not on external monitor. Not really noticeable except on solid black screen, so more of an annoyance. Does seem to be load-related, if I start something up to saturate all the CPUs it becomes much more noticeable, even on a normal screen with a lot of things going on.

Ubuntu 22.04.03
linux-image-oem-22.04d 6.5.0.1014.16

Here is a video of System Monitor and a black background. You can see the static intensify under load. I’m running a parallel version of Conway’s Life written in rust to saturate all CPU cores.
https://gitlab.com/makr17/rust-life
The first two attempts don’t last very long, but you can see the static spike (the program found a cycle and exited). The third attempt ramps up the CPU nicely and you can see the static intensify with it and stay strong.
Video demonstrating the issue
I’m not sure why Google Drive’s Preview won’t play the video, I shot it on one of their phones (a Pixel 8).

Hi @Mark_Bracher

If you can try taking some very focused (tapping the phone screen) photos, perhaps I can see this better. I have tried watching the video provided and I am not seeing the green and red on the laptop screen. I’m sure it’s there, I am just not seeing it in the video.

This looks good, this is correct.

When you repeat this process, try doing so two terminal tabs open:

sudo dmesg -w

and

journalctl -f

We should see some activity happen pretty quickly when you repeat the steps to create the issue. In a pinch, using these real time follow modes allow us to see where the error appears to be happening pretty quickly. Also saves us digging through the logs looking for the event as we can catch it in real time.

Here are three stills of the laptop screen under load
https://photos.app.goo.gl/DX7o6ZaPzvvBTxgw9

When you repeat this process, try doing so two terminal tabs open:

sudo dmesg -w

and

journalctl -f

both were quiet until mid-way through the test when I was deauthed from wifi. All messages in both windows after the start of the test pertain to that.

Based on the images and the lack luster logs, plus assuming that was supposed to be a solid dark/black screen, that looks like a bad screen connection or a screen itself. Please file a ticket and link to this thread.