[RESPONDED] Ubuntu 23.10/Kernel 6.5/FW 3.03 -- load-driven RGB display static

Second title:

Ubuntu isn’t new enough for the AMD frame.work?

Original title:

New display, occasionally turns black briefly, and has rgb static in varying densities (noticible on dark screens)

I just got a new Machine, one of the 13" AMDs.

This behavior that I’m seeing is super weird,

  • occasionally, the screen will just turn off (for less than one second)
  • always, there is rgb static – it’s not as noticible when the OS is fully booted after maybe 30s(?), but during boot (and after login) it looks real bad
    • However!, when I was converting the video using HandBrake for upload, I noticed the rgb static get real bad again while the conversion was going on, and then it went back to “subtle” when the conversion was done – so this effect seems to be related to the amount of work the cpu is doing?

I’d tried re-seating the display cable connection, and it seems to have made no difference.

Could this be a driver or firmware issue? I did transplant my storage/OS drive from an Intel machine (11th gen) into this AMD machine.

How do I debug this to see which thing could be the problem?
So for, my options are:

  • firmware
  • driver
  • cpu (internal gpu issue)
  • display problem
  • (potentially) goofy cable

But the fact the static gets goofier when under load kind of eliminates display / cable issues, right?

Here is a video of the effect in action during a reboot:

Related: I was blocked?

Well, you don’t seem to be blocked if you were able to add that.

1 Like

There’s some trigger phrases that get automatically rejected, though I thought that was mostly around / proc / cpuinfo or something like that.

I thought it might be a hardware issue since you mentioned it happens mostly at boot but it looks like it’s only after the bootloader takes over, so could very well be a driver issue. I would try memtest or make sure firmware and drivers are correct?

re, firmware, here is what I’m trying:

wget https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/snapshot/linux-firmware-20231030.tar.gz
tar -xf linux-firmware-20231030.tar.gz 
sudo cp linux-firmware-20231030/amdgpu/* /lib/firmware/amdgpu/
sudo update-initramfs -uk 'all'

updates firmware to ~ 10 days ago: kernel/git/firmware/linux-firmware.git - Repository of firmware blobs for use with the Linux kernel

idk if this is “correct”, but it’s updated :upside_down_face:

I read here: Reddit - Dive into anything
that AMD recommends a newer kernel (6.4) than what comes with Ubuntu 23.04 (kernel 6.2). I tried Upgrading to 23.10, but ran in to: Bug #2039922 “Upgrade to 23.10 fails with error “An unresolvable...” : Bugs : ubuntu-release-upgrader package : Ubuntu

So I guess for now, I have very up to date linux-firmware, but still only 6.2.0-36-generic for the kernel.

RGB static issue is not not resolved yet.

I also tried installing amdgpu from here: https://www.amd.com/en/support/linux-drivers
but it seemed like a no-op as amdgpu is already active.

❯  lspci -k | grep -A 3 -E "(VGA|3D)"
pcilib: Error reading /sys/bus/pci/devices/0000:00:08.3/label: Operation not permitted
c1:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Phoenix1 (rev cb)
	Subsystem: Device f111:0006
	Kernel driver in use: amdgpu
	Kernel modules: amdgpu

Gonna try memtest

update on memtest, got a “Bad shim signature” error, so I’m looking in to that

I missed the chance to change my boot situation, but during this boot I noticed some interesting messages printed,
and while looking for those logs, i found more interesting information, unsure if relevant:

from journalctl -b

Nov 10 00:19:00 hephaestus firefox_firefox.desktop[13351]: [GFX1-]: Couldn't sanitize RENDERER device: GFX1103_R1
Nov 10 00:19:00 hephaestus ubuntu-report[3283]: level=error msg="data were not delivered successfully to metrics server, r>

but here we go, in the logs for dmesg (slash var slash log slash dmesg (typing it out blocks my post) ),
this is what I saw during boot:

 796   │ [    0.488442] kernel: fbcon: Taking over console
 797   │ [    0.488471] kernel: amd_gpio AMDI0030:00: Invalid config param 0014
 798   │ [    0.488492] kernel: amd_gpio AMDI0030:00: Invalid config param 0014
 799   │ [    0.488513] kernel: amd_gpio AMDI0030:00: Invalid config param 0014
 800   │ [    0.488542] kernel: amd_gpio AMDI0030:00: Invalid config param 0014
 801   │ [    0.488565] kernel: amd_gpio AMDI0030:00: Invalid config param 0014
 802   │ [    0.488585] kernel: amd_gpio AMDI0030:00: Invalid config param 0014
 803   │ [    0.488606] kernel: amd_gpio AMDI0030:00: Invalid config param 0014
 804   │ [    0.488914] kernel: pcieport 0000:00:02.2: PME: Signaling with IRQ 38

which points to a driver issue, I believe – fixed in Kernel 6.6: Error: amd_gpio AMDI0030:00: Invalid config param 0014 - Support - Manjaro Linux Forum

Trying to upgrade the kernel to 6.5.7 (latest available at the time), following this: You Can Now Install Linux Kernel 6.5 on Ubuntu, Here’s How - 9to5Linux

there is a tool now to manage kernel installations, which is great.

upgrading didn’t go well. few errors, got dumped in a initramfs prompt.
I suppose I’ll just stay on kernel 6.2 for now.

Not a direct assist unfortunately, but it CAN work great. I have run 22.04 since day one of my Batch 2… shipped with 3.02 BIOS and that was quite problematic. Not the same as yours, but definitely not a great experience. I installed the OEM kernel and BIOS 3.03 when it came out and since then it’s been smooth sailing. Zero issues, great speed and just a nice laptop to work with,

Hope that gives you hope at least :slight_smile:

1 Like

how / where do you do that?
(which kernel is OEM?)

the AMD batch 2? I think I’m batch 3 or 4? I received the machine only a couple days ago.

Thanks! I can try updating the BIOS/UEFI I think I saw a support page for that around here somewhere

1 Like
1 Like

Just echoing what @Gavin_Haslett has provided, those are the main resources when trying Ubuntu on AMD framework machine.

1 Like

You may want to review Framework’s guides on Ubuntu setup, there are some “gotchas” specific to the AMD systems. I’m not sure if these would be the cause of your specific issue but the official documentation is always a great place to start.

has anyone ran in to my core issue? I have RGB static on my display when my CPU is working?

I currently have this situation:

  • Kernel 6.5.0-10-generic
  • Ubuntu 23.10
  • BIOS 3.03

I’ve not tried a fresh install yet – usually a very very last resort. But I can give that a go next week. Until then, all I can do is debug and troubleshoot :tada:

Update: new issue in addition to the static: my backlight just gave up on me… which i know because a flashlight on the screen allowed me to save my work. Rebooting turned the back light on tho.
Oh! So this probably means the brief turn offs i’ve been seeing are the backlight! Not the actual screen!

I have not heard of anyone suffering such issues. It really sounds like a hardware issue to me. Have you opened a support ticket yet?

I have not, been trying to determine if it is a software issue – which I’ve felt like I maybe need kernel 6.6 to really be sure, but idk.

I’ll open a ticket with a link to this thread and see what happens!

I’m presently not convinced it’s not a software issue.
Last night, I “suspended” my laptop, but left the lid open – at some point in the night the fan went full blast, backlight turned on, and the screen was just black with frozen rgb static (still mostly black screen tho)

I had RGB static similar to what you have, after I upgraded my mainboard from Intel 13th gen to AMD 7640U. In my case, disconnecting and reconnecting the display cable to the mainboard fixed it. I see you already tried that, though, so I have no other suggestions.

At any rate, I would think this isn’t a software issue (i.e. it’s not an issue with the distro or the kernel or the display drivers), but instead a hardware issue.

1 Like

Finally got around to a memtest, had to disable secure boot. It ran twice and passed with 0 issues.

However, after rebooting, my boot drive can no longer be found, and i was presented with this message:

So i re-enabled secure boot and rebooted again. Same message.

Then i go to thu boot manager, and see:

So it … Kinda looks like my mainboard is falling apart? :frowning:

Memtest shouldn’t cause the drive to not be detected at all, yeah?

Is there a place to double check the drive in the uefi/bios somewhere?
Settings are pretty slim.

so this is weird – I finally made an install USB to try re-installing and the computer found my boot disk, and booted as normal!

very puzzling, tho I’m thankful I still have a successful boot. I’m going to try the “repair mode” on ubuntu’s install media if that exists tho… since the way i got to 23.10 is quite goofy.

Memtest should not, but switching the boot mode from uefi to bios could make a uefi install not show up as a boot option.

i don’t believe I did this.

Unless memtest did it on its own.

It’s no matter now tho, I’m back to the original problem of RGB static.
How would I debug which hardware the issue could be?

  • mainboard
  • display
  • ?