[SOLVED] 12th gen : Bluetooth not showing devices on Ubuntu mate 22 with kernel 5.15 or 5.18

Just received my FW laptop and inserted my ssd from my previous laptop.
It works like a charme.
Except when I go in bluetooth I don t see any device around me , especially my mouse.
When I click search it looks like it is alive :

0 bluetooth hci0 unblocked unblocked
1 wlan phy0 unblocked unblocked

Don’t know if that’s relevant, but in my case kernel 5.15 totally broke my wifi. Was forced to roll back to 5.13 for it to work.

Thanks @Korvin it actually work with mainline 5.13 !
So I need to run kernel :

  • 5.18 to use my intel 12th gen Ecores and manage power…
  • And at the same time I need to run 5.13 to have my mouse working !
  • Provided my system ubuntu 22 is shipped with kernel 5.15 and I need it so I don t break half of my system

hummmm. Juste rebooted on kernel 5.18 and now my mouse is there !
Doesn t make much sens, I can also see other blutooth devices.
Solved, somehow :smiley:

1 Like

Bluetooth is a mystery. The Bluetooth standard and its state machine are so complicated that there are no people on Earth who understand it in every detail. So rebooting the system or unpairing and then pairing the device again are still good options if in doubt.

1 Like