[SOLVED] 12th Gen - External USB-C 4k monitor - Poor performance

I’m using a 4k monitor over usb-c with my 12th gen DIY edition, and Gentoo Linux.

I’m using the modesetting X11 driver with Glamor acceleration. Linux 6.1.10, with a hand-built kernel config.

Basically, graphics performance really lags when using this external monitor. Things like browsing the web. Graphics performance is snappy without the external monitor.

I don’t see any particular errors or warnings in dmesg or Xorg.0.log,

Any suggestions? Should I expect this to work better?


you’re missing two critical pieces of information here:

  • Does this also happen on the stock kernel?
  • Where is your modified kernel config? Without there is nothing we can do to help you.

Here’s my kernel config: MicroBin

There isn’t really a stock kernel for this distro. Is there any recommended list of kernel modules/features for Framework laptops? I mostly worked off of the suggestions on this wiki page. then added things as I ran into them.

I have had similar experiences with a bad cord. Have you tried swapping it out…before you go down the software rabbit hole?

It’s probably running on 30Hz. For some reason that always lags, in my experience, even on dedicated cards on desktop.
Can you check? Perhaps try with the display port adapter or a different cable or something?
I haven’t managed to get 60fps over USB-C on my 4k screen either, but I rarely use it and never bothered to check what the problem is there, and yes, it lags on the laptop while only letting me choose 30Hz, and if I explicitly choose 30 on the desktop it also lags behind but is perfectly fine on 60.

I’d check the following:

  • Refresh rate, is it set correctly?
  • This is a direct connection (no docks or adapters) to the display?
  • I’d test this with Display Port or HDMI for a better experience. I’ve used USB-C successfully in the past, but it can be hit and miss.

Sorry, took a while to get a DP adapter.

  • Both DP and USB-C seem to be running at 60hz and perform similarly.
  • No docks or adapters
  • Tried another cable without change

I did get some performance benefit in chrome by setting up VA-API but overall performance remains poor

Let’s start off with the output of xrandr. Also, what types of performance issues are you experiencing?

  • Which are applications are open?
  • Which specific changes made?
  • What type of lag are you experiencing?

Sorry for the slow responses.

After some debugging … it turns out that I was having an issue with excessive CPU throttling that was fixed with the 3.0.6 BIOS update ([IN-TICKET] 12th gen - excessive CPU throttling on Linux - Can't get above 46c and pegs to 400mhz under load - #2 by NegatedVoid).

Now, the 4k external over usb-c … is working great. I guess powering the larger resolution just tended to push the mainboard harder and it was probably throttling inappropriately.


Delighted this has been resolved with the update! :slight_smile: Thanks for the update.