[SOLVED] Bluetooth - Not finding new Pixel Ear Buds (Ubuntu 22.04)

Received my sweet, new DIY! A breeze to assemble.

I elected to stay with the Ubuntu experience so installed 22.04 LTS (long term support), using the regular installer to “Do something different” to put root and home on btrfs partitions (snapshots take less than a second!). The OS is fully patched and updated.

All excellent so far… Oh wait. With bluetooth on, it only sees 3 devices when my old computer lists around 12 to 15 devices in my vicinity. And my Pixel Pro ear buds are not one of the three.

Any advice welcome.

Note: This is not a real deal breaker for me. I have wired ear buds that function great with my new Framework! But it would sure be nice to use the pixels…


I ended up … following instructions all over again (LOL).

The issue was on the Pixel Pro earbuds side.
I had to literally follow their instructions (gasp) to pair the ear buds. Open the earbud case (with buds remaining in the case), press the barely visible pairing button on the back of the case; then in bluetooth settings in Settings on my laptop I finally saw the earbuds discovered but not set up. Several attempts clicking there and the ear buds are successfully paired!

Here is a link (I assume the video shows the steps - just scanning it reminded me of my mistake, prompting me to follow instructions. Don’t tell the wife!):


Once you were able to pair the headphones did they work with no issues? I just received some Pixel Buds Pro and once I pair them with Ubuntu I can’t play any music, it just doesn’t work.

I find that happening occasionally. I end up turning bluetooth off and back on and/or (very infrequently) having to re-pair the Pixel Ear Buds with Ubuntu.

2nd reply: My Pixel Earbuds received an “update” today.
And now I find they refused to work with my Pixel 7 phone! … but worked fine with my Framework 13.
These earbuds remind me of printing from computers - it works, it doesn’t, inconsistent…
I ended up not just rebooting my phone, but removing the existing bind. Did another bind, another reboot of the phone, … eventually got the buds to work with the phone.
So some problems with one platform may not be caused by that platform.